summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2020-12-18 00:02:42 +0100
committerMichał Górny <mgorny@gentoo.org>2020-12-18 00:17:14 +0100
commit146002722415aa10b2af35993a413f617e940346 (patch)
tree8b9a61ed6fa1c81dd68d7dbbd5718528b8b2de86
parentdev-python/micawber: Bump to 0.5.2 (diff)
downloadgentoo-146002722415aa10b2af35993a413f617e940346.tar.gz
gentoo-146002722415aa10b2af35993a413f617e940346.tar.bz2
gentoo-146002722415aa10b2af35993a413f617e940346.zip
dev-python/sphinx-gallery: Bump to 0.8.2
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/sphinx-gallery/Manifest1
-rw-r--r--dev-python/sphinx-gallery/sphinx-gallery-0.8.2.ebuild45
2 files changed, 46 insertions, 0 deletions
diff --git a/dev-python/sphinx-gallery/Manifest b/dev-python/sphinx-gallery/Manifest
index 2e04380e3250..5631d932eb2f 100644
--- a/dev-python/sphinx-gallery/Manifest
+++ b/dev-python/sphinx-gallery/Manifest
@@ -1,2 +1,3 @@
DIST sphinx-gallery-0.3.1.tar.gz 88807 BLAKE2B 79218a1f438e2b8607c52b14f098c0136cb4d5ce15a12d82bdb3caf0c7c1090e7c4f210437fc660d8d4d19bf87bbaa2ec3c208d2dc8a77ad9deea5b5cefa3c05 SHA512 c51eaaef63a7496e223a4541d0560f694420b6ac4b2cde3779c405f0ab92d34aef7a37e4c41da9e59bd8a050c8d3eed330df3799e76a60ae35cdbc6f7c9cb8c1
DIST sphinx-gallery-0.8.1.tar.gz 6502920 BLAKE2B 35f6bfe6039910518c21dadcdb7d814f4400baf3996ee5df21ff6a16b8fe87b0ec0355073b854e9b07ab7f2aced6d2de4453b9ebb2aa142506e9cbfebb99ea4c SHA512 0e77b75fe1d9c44d68235603529c116fad0460156d59f6b2f41ff299e42074930694f1768d99fe585428734617d18e1f1379fdc14e359b0274d1614c092141f6
+DIST sphinx-gallery-0.8.2.tar.gz 6530210 BLAKE2B ba1500b9870d89c686dd1afbcab4797e15944cbda4d8d2faf02bb65435fa4208bf7dfae70285c920ad2f3b82bc085b06629fb3d2807462f92e75be91ef1e81a8 SHA512 52dfcf320d1e53b2ee985482af5cee63582b26aa6f3969f2d83e6ffb9503712f5d1a865c849c4b2111f7fd4349cefb158874d8faa323e4e7d73bf547a26f3a93
diff --git a/dev-python/sphinx-gallery/sphinx-gallery-0.8.2.ebuild b/dev-python/sphinx-gallery/sphinx-gallery-0.8.2.ebuild
new file mode 100644
index 000000000000..02a760490661
--- /dev/null
+++ b/dev-python/sphinx-gallery/sphinx-gallery-0.8.2.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{6..9} )
+
+inherit distutils-r1
+
+DESCRIPTION="Sphinx extension to automatically generate an examples gallery"
+HOMEPAGE="
+ https://sphinx-gallery.github.io/
+ https://github.com/sphinx-gallery/sphinx-gallery"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~x86 ~amd64-linux ~x86-linux"
+IUSE=""
+
+RDEPEND="
+ dev-python/matplotlib[${PYTHON_USEDEP}]
+ dev-python/pillow[${PYTHON_USEDEP}]
+ dev-python/sphinx[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/joblib[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+src_prepare() {
+ sed -i -e 's:--cov-report= --cov=sphinx_gallery::' setup.cfg || die
+
+ # tests require internet
+ sed -e 's:test_embed_code_links_get_data:_&:' \
+ -i sphinx_gallery/tests/test_docs_resolv.py || die
+ sed -e 's:test_run_sphinx:_&:' \
+ -e 's:test_embed_links_and_styles:_&:' \
+ -i sphinx_gallery/tests/test_full.py || die
+
+ distutils-r1_src_prepare
+}