summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIonen Wolkens <ionen@gentoo.org>2021-09-30 11:56:02 -0400
committerIonen Wolkens <ionen@gentoo.org>2021-09-30 12:01:24 -0400
commit1496388bbcd50a6b6c567fb15a0bd24756f0be26 (patch)
tree5fb059ef946ffb1b74d5325c0c6bd76e3ae68d3c
parentdev-db/postgresql: Bump to 14.0 (diff)
downloadgentoo-1496388bbcd50a6b6c567fb15a0bd24756f0be26.tar.gz
gentoo-1496388bbcd50a6b6c567fb15a0bd24756f0be26.tar.bz2
gentoo-1496388bbcd50a6b6c567fb15a0bd24756f0be26.zip
app-portage/iwdevtools: add 0.8.0
Signed-off-by: Ionen Wolkens <ionen@gentoo.org>
-rw-r--r--app-portage/iwdevtools/Manifest1
-rw-r--r--app-portage/iwdevtools/iwdevtools-0.8.0.ebuild64
2 files changed, 65 insertions, 0 deletions
diff --git a/app-portage/iwdevtools/Manifest b/app-portage/iwdevtools/Manifest
index 66f7098216c0..cd89822bee70 100644
--- a/app-portage/iwdevtools/Manifest
+++ b/app-portage/iwdevtools/Manifest
@@ -1 +1,2 @@
DIST iwdevtools-0.7.0.tar.gz 56208 BLAKE2B 205bb9bc1e894b9cc6a9c3abb4f902c9c3f8337fff8618df162f4dc5d78416fe8e2852cb513d4153d8acf2a0d918e43352714502e1f40faffc777e19ad81ab55 SHA512 ec528901229066d333fcd8f53060601628b682a93c3e07a89826ff0fd2e406a4dffe76397883d4c50b459588cc6364873c43e5129bd172049c30aea039ae36d5
+DIST iwdevtools-0.8.0.tar.gz 57529 BLAKE2B b8068c7781b8b164b9b5d191f8a33a4a89854edb7c78c56d4f1312dd0d051d0b033f21611066303acb7efdf8403d6869458db98e7b1b2a293c779cca2bdcdd36 SHA512 df39fa02d7f4f72334286305bfa9c2db6d5db90bddc47194e3383a99492366796c7ae2e751bcf8af01d14cfa0bac88ea8d9c8678b7891f85aaa1b20e4a9e91cb
diff --git a/app-portage/iwdevtools/iwdevtools-0.8.0.ebuild b/app-portage/iwdevtools/iwdevtools-0.8.0.ebuild
new file mode 100644
index 000000000000..c1c495dcafbf
--- /dev/null
+++ b/app-portage/iwdevtools/iwdevtools-0.8.0.ebuild
@@ -0,0 +1,64 @@
+# Copyright 2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit meson optfeature
+
+DESCRIPTION="Small tools to aid with Gentoo development, primarily intended for QA"
+HOMEPAGE="https://github.com/ionenwks/iwdevtools"
+SRC_URI="https://github.com/ionenwks/iwdevtools/archive/refs/tags/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~x86"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ app-misc/pax-utils
+ app-portage/portage-utils
+ sys-apps/diffutils
+ sys-apps/file
+ sys-apps/portage
+ sys-apps/util-linux"
+BDEPEND="
+ sys-apps/help2man
+ test? ( ${RDEPEND} )"
+
+src_configure() {
+ local emesonargs=(
+ -Ddocdir=${PF}
+ -Deprefix="${EPREFIX}"
+ -Dshellcheck=false
+ $(meson_use test)
+ )
+
+ meson_src_configure
+}
+
+pkg_postinst() {
+ optfeature "detecting potential ABI issues using abidiff" dev-util/libabigail
+
+ if [[ ! ${REPLACING_VERSIONS} ]]; then
+ elog "Optional portage integration relies on using /etc/portage/bashrc."
+ elog "The example bashrc can be used as-is if not already using one:"
+ elog
+ elog " ln -s ../../usr/share/${PN}/bashrc ${EROOT}/etc/portage/bashrc"
+ elog
+ elog "Otherwise, inspect the tools' --help output and the example to integrate"
+ elog "(if not defining the same phase functions, the example can be sourced)."
+ elog
+ elog "Note that \`eqawarn\` is used for portage output by default. QA messages"
+ elog "aren't logged / shown post-emerge unless e.g. in /etc/portage/make.conf:"
+ elog
+ elog ' PORTAGE_ELOG_CLASSES="${PORTAGE_ELOG_CLASSES} qa"'
+ elog
+ elog "See ${EROOT}/usr/share/doc/${PF}/README.rst* for information on tools."
+ fi
+
+ if ver_test ${REPLACING_VERSIONS} -le 0.7.0; then
+ elog "qa-* bashrcs now use \`eqawarn\` for portage output. If no longer"
+ elog "seeing messages post-emerge, ensure 'qa' is in PORTAGE_ELOG_CLASSES."
+ fi
+}