summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-09-25 12:56:19 +0200
committerMichał Górny <mgorny@gentoo.org>2021-09-25 15:23:06 +0200
commit157947d0105e325de7f0c5c4773f884004be6ab7 (patch)
treedb772d5a84b0a23584ef6b7dfaf5643af7d64155
parentdev-python/platformdirs: Mark ALLARCHES (diff)
downloadgentoo-157947d0105e325de7f0c5c4773f884004be6ab7.tar.gz
gentoo-157947d0105e325de7f0c5c4773f884004be6ab7.tar.bz2
gentoo-157947d0105e325de7f0c5c4773f884004be6ab7.zip
dev-python/scipy: Skip tests broken by new lapack
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/scipy/scipy-1.6.3.ebuild7
1 files changed, 7 insertions, 0 deletions
diff --git a/dev-python/scipy/scipy-1.6.3.ebuild b/dev-python/scipy/scipy-1.6.3.ebuild
index e98e4bd93794..08a959a4ad0b 100644
--- a/dev-python/scipy/scipy-1.6.3.ebuild
+++ b/dev-python/scipy/scipy-1.6.3.ebuild
@@ -108,6 +108,13 @@ python_prepare_all() {
sed -e "s:== 'levy_stable':in ('levy_stable', 'crystalball', 'ncf'):" \
-i scipy/stats/tests/test_continuous_basic.py || die
+ if has_version ">=sci-libs/lapack-3.10"; then
+ sed -e 's:test_sort(:_&:' \
+ -i scipy/linalg/tests/test_decomp.py || die
+ sed -e 's:test_solve_discrete_are:_&:' \
+ -i scipy/linalg/tests/test_solvers.py || die
+ fi
+
distutils-r1_python_prepare_all
}