summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrice Clement <monsieurp@gentoo.org>2018-01-07 22:46:34 +0100
committerPatrice Clement <monsieurp@gentoo.org>2018-01-07 22:52:03 +0100
commit15dd089f16501e34ad722e32a32068d911cb4fae (patch)
tree5c95d75c8802a4ce230989ac697f2b29769cfc17
parentsys-apps/mawk: Drop old (diff)
downloadgentoo-15dd089f16501e34ad722e32a32068d911cb4fae.tar.gz
gentoo-15dd089f16501e34ad722e32a32068d911cb4fae.tar.bz2
gentoo-15dd089f16501e34ad722e32a32068d911cb4fae.zip
app-editors/neovim: add PREFER_LUA CMake option.
This option allows neovim to build even when the luajit USE flag is disabled. Courtesy of Kumba <gentoo-bugs-72052@khumba.net>. Closes: https://bugs.gentoo.org/643752 Package-Manager: Portage-2.3.13, Repoman-2.3.3
-rw-r--r--app-editors/neovim/neovim-0.2.0-r1.ebuild1
-rw-r--r--app-editors/neovim/neovim-0.2.2-r1.ebuild1
-rw-r--r--app-editors/neovim/neovim-9999.ebuild1
3 files changed, 3 insertions, 0 deletions
diff --git a/app-editors/neovim/neovim-0.2.0-r1.ebuild b/app-editors/neovim/neovim-0.2.0-r1.ebuild
index 13a7786ff184..12fbcafd7b64 100644
--- a/app-editors/neovim/neovim-0.2.0-r1.ebuild
+++ b/app-editors/neovim/neovim-0.2.0-r1.ebuild
@@ -64,6 +64,7 @@ src_configure() {
local mycmakeargs=(
-DFEAT_TUI=$(usex tui)
-DENABLE_JEMALLOC=$(usex jemalloc)
+ -DPREFER_LUA=$(usex luajit no yes)
)
cmake-utils_src_configure
}
diff --git a/app-editors/neovim/neovim-0.2.2-r1.ebuild b/app-editors/neovim/neovim-0.2.2-r1.ebuild
index 13a7786ff184..12fbcafd7b64 100644
--- a/app-editors/neovim/neovim-0.2.2-r1.ebuild
+++ b/app-editors/neovim/neovim-0.2.2-r1.ebuild
@@ -64,6 +64,7 @@ src_configure() {
local mycmakeargs=(
-DFEAT_TUI=$(usex tui)
-DENABLE_JEMALLOC=$(usex jemalloc)
+ -DPREFER_LUA=$(usex luajit no yes)
)
cmake-utils_src_configure
}
diff --git a/app-editors/neovim/neovim-9999.ebuild b/app-editors/neovim/neovim-9999.ebuild
index 13a7786ff184..12fbcafd7b64 100644
--- a/app-editors/neovim/neovim-9999.ebuild
+++ b/app-editors/neovim/neovim-9999.ebuild
@@ -64,6 +64,7 @@ src_configure() {
local mycmakeargs=(
-DFEAT_TUI=$(usex tui)
-DENABLE_JEMALLOC=$(usex jemalloc)
+ -DPREFER_LUA=$(usex luajit no yes)
)
cmake-utils_src_configure
}