summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAkinori Hattori <hattya@gentoo.org>2016-04-10 22:07:04 +0900
committerAkinori Hattori <hattya@gentoo.org>2016-04-10 22:07:04 +0900
commit15e61d9f8844cf4a43d8c14732c742725751a1bc (patch)
treeec899d07082c91d3a71bb8fefcf513fbb8db7260
parentmedia-libs/libsixel: drop old (diff)
downloadgentoo-15e61d9f8844cf4a43d8c14732c742725751a1bc.tar.gz
gentoo-15e61d9f8844cf4a43d8c14732c742725751a1bc.tar.bz2
gentoo-15e61d9f8844cf4a43d8c14732c742725751a1bc.zip
media-libs/libsixel: new upstream release
Package-Manager: portage-2.2.26
-rw-r--r--media-libs/libsixel/Manifest1
-rw-r--r--media-libs/libsixel/libsixel-1.6.1.ebuild48
2 files changed, 49 insertions, 0 deletions
diff --git a/media-libs/libsixel/Manifest b/media-libs/libsixel/Manifest
index 7a060f79db26..9b4758e9a1d6 100644
--- a/media-libs/libsixel/Manifest
+++ b/media-libs/libsixel/Manifest
@@ -1 +1,2 @@
DIST libsixel-1.6.0.tar.gz 4744476 SHA256 06bf22621112f7313d8f5f8a8bec80268969166acae988e449b7cb33883b15c0 SHA512 5e8cfaf67bf8b6b18173f69c230fa75fe7f56448345287ad95716f1e0f45d08a289703eab62897d947c13c13acbf4c08e9ff8fd177452a7ed11dbb6efc7490ea WHIRLPOOL fbd3d94e47bb0aa2dfe6ce2aa9add5e3ed9b5abf84f39f142c093229628d3ea7ac9553c8fa4c555935aed71a4939ce76ba349d7ece58a4e34c81363381a923d7
+DIST libsixel-1.6.1.tar.gz 4745924 SHA256 dfb03e764ff535fcb789f45487b5a284c8998e8202907eb3abc47385f88299ae SHA512 163799d864551c1d53823bf8f976afe20a825cc039361a636e5f08444c67a682c1fd297d83e5830d993ee703502e99cd31e6bb2f009933c1de89efb6c5429178 WHIRLPOOL 3b4e2fde4de40925f2975bbac234e856c1fe87fa2673782a501faa76f2375d69b8f501848cca4366ad5c2fa534decb6f67284cc3b326d83e982091d454ca599a
diff --git a/media-libs/libsixel/libsixel-1.6.1.ebuild b/media-libs/libsixel/libsixel-1.6.1.ebuild
new file mode 100644
index 000000000000..2aa181387587
--- /dev/null
+++ b/media-libs/libsixel/libsixel-1.6.1.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="6"
+
+inherit bash-completion-r1
+
+DESCRIPTION="A lightweight, fast implementation of DEC SIXEL graphics codec"
+HOMEPAGE="https://github.com/saitoha/libsixel"
+SRC_URI="https://github.com/saitoha/libsixel/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT public-domain"
+SLOT="0"
+KEYWORDS="~amd64 ~ia64 ~x86"
+IUSE="curl gd gtk jpeg png"
+
+RDEPEND="curl? ( net-misc/curl )
+ gd? ( media-libs/gd )
+ gtk? ( x11-libs/gdk-pixbuf:2 )
+ jpeg? ( virtual/jpeg:0 )
+ png? ( media-libs/libpng:0 )"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+
+src_configure() {
+ econf \
+ $(use_with curl libcurl) \
+ $(use_with gd) \
+ $(use_with gtk gdk-pixbuf2) \
+ $(use_with jpeg) \
+ $(use_with png) \
+ --disable-python \
+ --with-bashcompletiondir=$(get_bashcompdir)
+}
+
+src_test() {
+ emake test
+}
+
+src_install() {
+ default
+
+ cd images
+ docompress -x /usr/share/doc/${PF}/images
+ docinto images
+ dodoc egret.jpg map{8,16}.png snake.jpg vimperator3.png
+}