summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorThomas Deutschmann <whissi@gentoo.org>2020-07-24 02:59:07 +0200
committerThomas Deutschmann <whissi@gentoo.org>2020-07-24 03:02:19 +0200
commit1632545a561002c8d2b743f6130bbd25b5a7a742 (patch)
treee7203a2da2def8cade91cbebb077054d2c9aafce
parentmedia-libs/noise-suppression-for-voice: please repoman (diff)
downloadgentoo-1632545a561002c8d2b743f6130bbd25b5a7a742.tar.gz
gentoo-1632545a561002c8d2b743f6130bbd25b5a7a742.tar.bz2
gentoo-1632545a561002c8d2b743f6130bbd25b5a7a742.zip
mail-client/thunderbird: move fatal rust version check to pkg_setup
In case no rust version is installed yet, the rust check in pkg_pretend will block any PM run which would pull in rust. Moving fatal check to pkg_setup will still prevent unnecessary compile time but avoid that block. Closes: https://bugs.gentoo.org/733692 Package-Manager: Portage-2.3.103, Repoman-2.3.23 Signed-off-by: Thomas Deutschmann <whissi@gentoo.org>
-rw-r--r--mail-client/thunderbird/thunderbird-68.10.0.ebuild17
1 files changed, 13 insertions, 4 deletions
diff --git a/mail-client/thunderbird/thunderbird-68.10.0.ebuild b/mail-client/thunderbird/thunderbird-68.10.0.ebuild
index 42387e59ccef..e2ff8fb43575 100644
--- a/mail-client/thunderbird/thunderbird-68.10.0.ebuild
+++ b/mail-client/thunderbird/thunderbird-68.10.0.ebuild
@@ -220,10 +220,10 @@ pkg_pretend() {
local rustc_version=( $(eselect --brief rust show 2>/dev/null) )
rustc_version=${rustc_version[0]/rust-bin-/}
rustc_version=${rustc_version/rust-/}
- [[ -z "${rustc_version}" ]] && die "Failed to determine rustc version!"
-
- if ver_test "${rustc_version}" -ge "1.45.0" ; then
- die "Rust >=1.45.0 is not supported. Please use 'eselect rust' to switch to <rust-1.45.0!"
+ if [[ -n "${rustc_version}" ]] ; then
+ if ver_test "${rustc_version}" -ge "1.45.0" ; then
+ die "Rust >=1.45.0 is not supported. Please use 'eselect rust' to switch to <rust-1.45.0!"
+ fi
fi
if use pgo ; then
@@ -247,6 +247,15 @@ pkg_setup() {
moz_pkgsetup
if [[ ${MERGE_TYPE} != binary ]] ; then
+ local rustc_version=( $(eselect --brief rust show 2>/dev/null) )
+ rustc_version=${rustc_version[0]/rust-bin-/}
+ rustc_version=${rustc_version/rust-/}
+ [[ -z "${rustc_version}" ]] && die "Failed to determine rustc version!"
+
+ if ver_test "${rustc_version}" -ge "1.45.0" ; then
+ die "Rust >=1.45.0 is not supported. Please use 'eselect rust' to switch to <rust-1.45.0!"
+ fi
+
# Ensure we have enough disk space to compile
if use pgo || use lto || use debug || use test ; then
CHECKREQS_DISK_BUILD="8G"