summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPacho Ramos <pacho@gentoo.org>2018-04-22 21:14:10 +0200
committerPacho Ramos <pacho@gentoo.org>2018-04-22 21:39:49 +0200
commit169b77e8ecf3d4f9c03e7efc84945439f766169a (patch)
tree706539dede0feba3acc3aa619f2dbe93daf1dc18
parentgames-arcade/missile: Drop old (diff)
downloadgentoo-169b77e8ecf3d4f9c03e7efc84945439f766169a.tar.gz
gentoo-169b77e8ecf3d4f9c03e7efc84945439f766169a.tar.bz2
gentoo-169b77e8ecf3d4f9c03e7efc84945439f766169a.zip
games-arcade/moleinvasion: Stop using games.eclass
Package-Manager: Portage-2.3.31, Repoman-2.3.9
-rw-r--r--games-arcade/moleinvasion/files/moleinvasion-0.4-underlink.patch4
-rw-r--r--games-arcade/moleinvasion/moleinvasion-0.4-r2.ebuild46
2 files changed, 48 insertions, 2 deletions
diff --git a/games-arcade/moleinvasion/files/moleinvasion-0.4-underlink.patch b/games-arcade/moleinvasion/files/moleinvasion-0.4-underlink.patch
index 6f4c5fdf4075..7ee61f91e378 100644
--- a/games-arcade/moleinvasion/files/moleinvasion-0.4-underlink.patch
+++ b/games-arcade/moleinvasion/files/moleinvasion-0.4-underlink.patch
@@ -1,5 +1,5 @@
---- Makefile.old 2011-06-14 22:12:00.920386798 +0200
-+++ Makefile 2011-06-14 22:12:22.118716548 +0200
+--- a/Makefile.old 2011-06-14 22:12:00.920386798 +0200
++++ b/Makefile 2011-06-14 22:12:22.118716548 +0200
@@ -11,7 +11,7 @@
EDTOB = editor
EDWOB = editworld
diff --git a/games-arcade/moleinvasion/moleinvasion-0.4-r2.ebuild b/games-arcade/moleinvasion/moleinvasion-0.4-r2.ebuild
new file mode 100644
index 000000000000..885dd1d1524f
--- /dev/null
+++ b/games-arcade/moleinvasion/moleinvasion-0.4-r2.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+inherit desktop
+
+DESCRIPTION="Mole infested 2D platform game"
+HOMEPAGE="http://moleinvasion.tuxfamily.org/"
+SRC_URI="ftp://download.tuxfamily.org/minvasion/packages/MoleInvasion-${PV}.tar.bz2
+ music? ( mirror://gentoo/${PN}-music-20090731.tar.gz )"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="music"
+
+DEPEND="media-libs/libsdl[opengl,video]
+ virtual/opengl
+ media-libs/sdl-image[jpeg,png]
+ media-libs/sdl-mixer[vorbis]
+ media-libs/sdl-ttf
+"
+RDEPEND="${DEPEND}"
+
+S="${WORKDIR}/${P}/src"
+
+src_prepare() {
+ default
+ use music && mv -f "${WORKDIR}"/music ../
+ sed -i \
+ -e '/^CFLAGS/s:= -g:+=:' \
+ -e '/^LDFLAGS/d' \
+ -e "/^FINALEXEDIR/s:/usr.*:/usr/bin:" \
+ -e "/^FINALDATADIR/s:/usr.*:/usr/share/${PN}:" \
+ Makefile || die "sed failed"
+
+ eapply "${FILESDIR}"/${P}-opengl.patch \
+ "${FILESDIR}"/${P}-underlink.patch
+}
+
+src_install() {
+ emake DESTDIR="${D}" install install-data
+ newicon ../gfx/icon.xpm ${PN}.xpm
+ make_desktop_entry ${PN} "Mole Invasion"
+ doman ../debian/*.6
+}