summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <andreas.sturmlechner@gmail.com>2015-11-13 22:25:45 +0100
committerMichael Palimaka <kensington@gentoo.org>2015-11-15 02:19:34 +1100
commit17f716f5326cbaf8548f1127e43e5547adfaad6c (patch)
tree1f66bc2dcd8e3eae8d995dc5915226af156aa14e
parentapp-crypt/eid-mw: revise and correct patches (diff)
downloadgentoo-17f716f5326cbaf8548f1127e43e5547adfaad6c.tar.gz
gentoo-17f716f5326cbaf8548f1127e43e5547adfaad6c.tar.bz2
gentoo-17f716f5326cbaf8548f1127e43e5547adfaad6c.zip
kde-base/kcheckpass: Add alternative deps on pam providers, fix DEPEND
kde-plasma/plasma-workspace and kde-plasma/kscreenlocker will start to block kde-base/kdebase-pam due to colliding files in /etc/pam.d/ In order to avoid another full block, let kcheckpass be satisfied by these packages as well. Package-Manager: portage-2.2.20.1
-rw-r--r--kde-base/kcheckpass/kcheckpass-4.11.22-r1.ebuild37
1 files changed, 37 insertions, 0 deletions
diff --git a/kde-base/kcheckpass/kcheckpass-4.11.22-r1.ebuild b/kde-base/kcheckpass/kcheckpass-4.11.22-r1.ebuild
new file mode 100644
index 000000000000..bc4f592ce846
--- /dev/null
+++ b/kde-base/kcheckpass/kcheckpass-4.11.22-r1.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+KMNAME="kde-workspace"
+inherit kde4-meta
+
+DESCRIPTION="A simple password checker, used by any software in need of user authentication"
+KEYWORDS="~amd64 ~arm ~ppc ~ppc64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="debug pam"
+
+DEPEND="
+ pam? ( virtual/pam )
+"
+RDEPEND="${DEPEND}
+ pam? ( || (
+ >=kde-base/kdebase-pam-7
+ kde-plasma/kscreenlocker
+ <kde-plasma/plasma-workspace-5.4.50
+ ) )
+"
+
+src_prepare() {
+ kde4-meta_src_prepare
+
+ use pam && epatch "${FILESDIR}/${PN}-4.4.2-no-SUID-no-GUID.patch"
+}
+
+src_configure() {
+ local mycmakeargs=(
+ $(cmake-utils_use_with pam)
+ )
+
+ kde4-meta_src_configure
+}