summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBernd Waibel <waebbl@gmail.com>2019-05-11 15:41:31 +0200
committerAndreas Sturmlechner <asturm@gentoo.org>2019-05-19 13:22:16 +0200
commit1811a29598d18bc02b7a5cc86271f9d2e96bf731 (patch)
tree7b8bc1960c17c2c848a60c9416295bf1d620ee94
parentpackage.mask: Last rite net-proxy/nylon (diff)
downloadgentoo-1811a29598d18bc02b7a5cc86271f9d2e96bf731.tar.gz
gentoo-1811a29598d18bc02b7a5cc86271f9d2e96bf731.tar.bz2
gentoo-1811a29598d18bc02b7a5cc86271f9d2e96bf731.zip
sci-libs/libmed: remove static-libs
* Remove static-libs USE flag due to bug #682676 * Depend on >=hdf5-1.10.x * sort mycmakeargs * in src_install change ${D} to ${ED} * update maintainers (see bug #682676) Closes: https://bugs.gentoo.org/682676 Package-Manager: Portage-2.3.62, Repoman-2.3.12 Signed-off-by: Bernd Waibel <waebbl@gmail.com> Closes: https://github.com/gentoo/gentoo/pull/11970 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
-rw-r--r--sci-libs/libmed/libmed-4.0.0-r1.ebuild103
-rw-r--r--sci-libs/libmed/metadata.xml8
2 files changed, 109 insertions, 2 deletions
diff --git a/sci-libs/libmed/libmed-4.0.0-r1.ebuild b/sci-libs/libmed/libmed-4.0.0-r1.ebuild
new file mode 100644
index 000000000000..832a6c7398fd
--- /dev/null
+++ b/sci-libs/libmed/libmed-4.0.0-r1.ebuild
@@ -0,0 +1,103 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+# EAPI=7 uses ninja generator by default but it's incompatible with USE=fortran
+# https://github.com/Kitware/ninja/tree/features-for-fortran#readme
+CMAKE_MAKEFILE_GENERATOR=emake
+
+FORTRAN_NEEDED=fortran
+
+# NOTE:The build for multiple python versions should be possible but
+# complicated for the build system
+PYTHON_COMPAT=( python2_7 python3_{5,6,7} )
+
+inherit cmake-utils fortran-2 python-single-r1
+
+MY_P="med-${PV}"
+
+DESCRIPTION="A library to store and exchange meshed data or computation results"
+HOMEPAGE="https://www.salome-platform.org/"
+SRC_URI="http://files.salome-platform.org/Salome/other/${MY_P}.tar.gz"
+
+LICENSE="GPL-3 LGPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc fortran mpi python test"
+
+REQUIRED_USE="python? ( ${PYTHON_REQUIRED_USE} )"
+RDEPEND="
+ >=sci-libs/hdf5-1.10.0[fortran=,mpi=]
+ mpi? ( virtual/mpi[fortran=] )
+ python? ( ${PYTHON_DEPS} )
+"
+DEPEND="${RDEPEND}"
+BDEPEND="python? ( >=dev-lang/swig-2.0.9:0 )"
+
+S="${WORKDIR}"/${MY_P}
+
+PATCHES=(
+ "${FILESDIR}/${PN}-3.3.1-cmake-fortran.patch"
+ "${FILESDIR}/${PN}-3.3.1-disable-python-compile.patch" # managed by function of python eclass
+ "${FILESDIR}/${PN}-3.3.1-mpi.patch"
+ "${FILESDIR}/${P}-cmakelist.patch"
+ "${FILESDIR}/${P}-tests.patch" # disable a few tests not running
+ "${FILESDIR}/${P}-installdoc.patch"
+)
+
+DOCS=( AUTHORS ChangeLog NEWS README TODO )
+
+pkg_setup() {
+ use python && python-single-r1_pkg_setup
+ use fortran && fortran-2_pkg_setup
+}
+
+src_prepare() {
+ # fixes for correct libdir name
+ sed -i -e "s@SET(_install_dir lib/python@SET(_install_dir $(get_libdir)/python@" \
+ ./python/CMakeLists.txt || die "sed failed"
+ for cm in ./src/CMakeLists.txt ./tools/medimport/CMakeLists.txt
+ do
+ sed -i -e "s@INSTALL(TARGETS \(.*\) DESTINATION lib)@INSTALL(TARGETS \1 DESTINATION $(get_libdir))@" \
+ "${cm}" || die "sed on ${cm} failed"
+ done
+
+ cmake-utils_src_prepare
+}
+
+src_configure() {
+ local mycmakeargs=(
+ # as indicated in the CMakeLists.txt, the shipped documentation is generated by a custom doxygen,
+ # so let's avoid rebuilding it because it will be different
+ -DMEDFILE_BUILD_DOC=OFF
+ -DMEDFILE_BUILD_FORTRAN=$(usex fortran)
+ -DMEDFILE_BUILD_PYTHON=$(usex python)
+ -DMEDFILE_BUILD_SHARED_LIBS=ON
+ -DMEDFILE_BUILD_STATIC_LIBS=OFF
+ -DMEDFILE_BUILD_TESTS=$(usex test)
+ -DMEDFILE_DOC_DIRECTORY="${EPREFIX}"/usr/share/doc/${PF}/html # custom var created by patches
+ -DMEDFILE_INSTALL_DOC=$(usex doc)
+ -DMEDFILE_USE_MPI=$(usex mpi)
+ )
+ cmake-utils_src_configure
+}
+
+src_install() {
+ cmake-utils_src_install
+
+ # the optimization done in CMakeLists.txt has been disabled so
+ # we need to do it manually
+ use python && python_optimize
+
+ # Prevent test executables being installed
+ if use test; then
+ rm -r "${ED}"/usr/bin/{testc,testf,testpy} || die "failed to delete test executables"
+ fi
+}
+
+src_test() {
+ # override parallel mode only for tests
+ local myctestargs=( "-j 1" )
+ cmake-utils_src_test
+}
diff --git a/sci-libs/libmed/metadata.xml b/sci-libs/libmed/metadata.xml
index 11287d1296cc..e54fc02c2ba5 100644
--- a/sci-libs/libmed/metadata.xml
+++ b/sci-libs/libmed/metadata.xml
@@ -2,7 +2,11 @@
<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
<maintainer type="person">
- <email>fordfrog@gentoo.org</email>
- <name>Miroslav Ć ulc</name>
+ <email>waebbl@gmail.com</email>
+ <name>Bernd Waibel</name>
+ </maintainer>
+ <maintainer type="project">
+ <email>proxy-maint@gentoo.org</email>
+ <description>Proxy Maintainer Team</description>
</maintainer>
</pkgmetadata>