summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRichard Yao <ryao@gentoo.org>2017-03-28 22:50:01 -0400
committerRichard Yao <ryao@gentoo.org>2017-03-28 22:52:42 -0400
commit182ae685bf4df5318726e676c1e580e6e3b4412e (patch)
tree8021b1f17cc52b67d00d0e0207741f77070ccdb6
parentStabilize net-libs/libscsi-1.18.0 on amd64 and x86, bug #609094 (diff)
downloadgentoo-182ae685bf4df5318726e676c1e580e6e3b4412e.tar.gz
gentoo-182ae685bf4df5318726e676c1e580e6e3b4412e.tar.bz2
gentoo-182ae685bf4df5318726e676c1e580e6e3b4412e.zip
net-dns/https_dns_proxy: New package
Tested on ~mips. Will commit snapshot at later point Package-Manager: Portage-2.3.3, Repoman-2.3.0-r1 Signed-off-by: Richard Yao <ryao@gentoo.org>
-rw-r--r--net-dns/https_dns_proxy/https_dns_proxy-9999.ebuild28
-rw-r--r--net-dns/https_dns_proxy/metadata.xml11
2 files changed, 39 insertions, 0 deletions
diff --git a/net-dns/https_dns_proxy/https_dns_proxy-9999.ebuild b/net-dns/https_dns_proxy/https_dns_proxy-9999.ebuild
new file mode 100644
index 000000000000..b38110db87b7
--- /dev/null
+++ b/net-dns/https_dns_proxy/https_dns_proxy-9999.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+inherit git-r3 cmake-utils
+
+DESCRIPTION="A lightweight DNS-over-HTTPS proxy."
+HOMEPAGE="https://github.com/aarond10/https_dns_proxy"
+EGIT_REPO_URI="https://github.com/aarond10/${PN}.git"
+SRC_URI=""
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS=""
+IUSE=""
+
+DEPEND="dev-libs/libev
+ net-dns/c-ares
+ >=net-misc/curl-7.53.0[http2,ssl]
+ "
+RDEPEND="${DEPEND}"
+
+src_install(){
+ cmake-utils_src_install
+ exeinto /usr/bin
+ doexe "${S}_build/https_dns_proxy"
+}
diff --git a/net-dns/https_dns_proxy/metadata.xml b/net-dns/https_dns_proxy/metadata.xml
new file mode 100644
index 000000000000..3f5fcedb56b1
--- /dev/null
+++ b/net-dns/https_dns_proxy/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>ryao@gentoo.org</email>
+ <name>Richard Yao</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">wrouesnel/dns-over-https-proxy</remote-id>
+ </upstream>
+</pkgmetadata>