summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-06-14 12:20:18 +0200
committerMichał Górny <mgorny@gentoo.org>2021-06-14 12:36:23 +0200
commit18615d3901d6e081821414c20966fc843dd2412d (patch)
tree1354ab16c27dab2cad14cc3c6b592a59e4b36db0
parentx11-misc/xscreensaver: Fix compilation for USE=-opengl (diff)
downloadgentoo-18615d3901d6e081821414c20966fc843dd2412d.tar.gz
gentoo-18615d3901d6e081821414c20966fc843dd2412d.tar.bz2
gentoo-18615d3901d6e081821414c20966fc843dd2412d.zip
dev-python/diskcache: Enable py3.10, skip django tests
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/diskcache/diskcache-5.2.1-r1.ebuild42
1 files changed, 42 insertions, 0 deletions
diff --git a/dev-python/diskcache/diskcache-5.2.1-r1.ebuild b/dev-python/diskcache/diskcache-5.2.1-r1.ebuild
new file mode 100644
index 000000000000..362a97886afd
--- /dev/null
+++ b/dev-python/diskcache/diskcache-5.2.1-r1.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{8..10} )
+PYTHON_REQ_USE="sqlite"
+
+inherit distutils-r1
+
+HOMEPAGE="http://www.grantjenks.com/docs/diskcache/
+ https://github.com/grantjenks/python-diskcache/"
+DESCRIPTION="Disk and file backed cache"
+SRC_URI="
+ https://github.com/grantjenks/python-diskcache/archive/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz"
+S=${WORKDIR}/python-diskcache-${PV}
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~mips ~ppc64 ~x86 ~amd64-linux ~x86-linux"
+
+distutils_enable_sphinx docs
+distutils_enable_tests pytest
+
+src_prepare() {
+ # remove dep on pytest-xdist and pytest-cov
+ sed -i -e '/-n auto/d' -e '/--cov/d' tox.ini || die
+
+ distutils-r1_src_prepare
+}
+
+python_test() {
+ local ignore=(
+ # django tests don't work with django-3.2, and django-3.1
+ # doesn't work with py3.10
+ tests/test_djangocache.py
+ tests/test_doctest.py
+ README.rst
+ )
+ epytest ${ignore[@]/#/--ignore }
+}