summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeroen Roovers <jer@gentoo.org>2020-01-09 14:32:35 +0100
committerJeroen Roovers <jer@gentoo.org>2020-01-09 14:39:04 +0100
commit1865f8c4b92381c1407fdb97ad3a92b74ea05862 (patch)
tree5e490bca8902f5d54cdde98357e68e0cbbac3a0e
parentnet-libs/libpcap: USE=remote, EAPI=7, strip pcap-config -L/usr/lib (diff)
downloadgentoo-1865f8c4b92381c1407fdb97ad3a92b74ea05862.tar.gz
gentoo-1865f8c4b92381c1407fdb97ad3a92b74ea05862.tar.bz2
gentoo-1865f8c4b92381c1407fdb97ad3a92b74ea05862.zip
net-libs/libpcap: Add USE=yydebug
Package-Manager: Portage-2.3.84, Repoman-2.3.20 Signed-off-by: Jeroen Roovers <jer@gentoo.org>
-rw-r--r--net-libs/libpcap/libpcap-1.9.1-r1.ebuild3
-rw-r--r--net-libs/libpcap/libpcap-9999.ebuild8
-rw-r--r--net-libs/libpcap/metadata.xml1
3 files changed, 8 insertions, 4 deletions
diff --git a/net-libs/libpcap/libpcap-1.9.1-r1.ebuild b/net-libs/libpcap/libpcap-1.9.1-r1.ebuild
index bf2ab94c1396..704e1bbe519a 100644
--- a/net-libs/libpcap/libpcap-1.9.1-r1.ebuild
+++ b/net-libs/libpcap/libpcap-1.9.1-r1.ebuild
@@ -16,7 +16,7 @@ SRC_URI="
LICENSE="BSD"
SLOT="0"
KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~riscv ~s390 ~sh ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~x86-solaris"
-IUSE="bluetooth dbus netlink -remote static-libs usb"
+IUSE="bluetooth dbus netlink -remote static-libs usb -yydebug"
RDEPEND="
bluetooth? ( net-wireless/bluez:=[${MULTILIB_USEDEP}] )
@@ -52,6 +52,7 @@ multilib_src_configure() {
$(use_enable dbus) \
$(use_enable remote) \
$(use_enable usb) \
+ $(use_enable yydebug) \
$(use_with netlink libnl) \
--enable-ipv6
}
diff --git a/net-libs/libpcap/libpcap-9999.ebuild b/net-libs/libpcap/libpcap-9999.ebuild
index 1a75013c5b77..a6571d9395c0 100644
--- a/net-libs/libpcap/libpcap-9999.ebuild
+++ b/net-libs/libpcap/libpcap-9999.ebuild
@@ -13,7 +13,7 @@ HOMEPAGE="
LICENSE="BSD"
SLOT="0"
-IUSE="bluetooth dbus netlink -remote static-libs usb"
+IUSE="bluetooth dbus netlink -remote static-libs usb -yydebug"
KEYWORDS=""
RDEPEND="
@@ -30,7 +30,7 @@ DEPEND="
"
PATCHES=(
- "${FILESDIR}"/${PN}-1.9.0-pcap-config-includedir.patch
+ "${FILESDIR}"/${PN}-1.9.1-pcap-config.patch
"${FILESDIR}"/${PN}-9999-prefix-darwin.patch
)
@@ -47,7 +47,9 @@ multilib_src_configure() {
$(use_enable dbus) \
$(use_enable remote) \
$(use_enable usb) \
- $(use_with netlink libnl)
+ $(use_enable yydebug) \
+ $(use_with netlink libnl) \
+ --enable-ipv6
}
multilib_src_compile() {
diff --git a/net-libs/libpcap/metadata.xml b/net-libs/libpcap/metadata.xml
index 54d027060e7b..6fb2c6c97aed 100644
--- a/net-libs/libpcap/metadata.xml
+++ b/net-libs/libpcap/metadata.xml
@@ -8,6 +8,7 @@
<use>
<flag name="netlink">Use <pkg>dev-libs/libnl</pkg> to put wireless interfaces in monitor mode.</flag>
<flag name="remote">Enable remote packet capture which may expose libpcap-based applications to attacks by malicious remote capture servers!</flag>
+<flag name="yydebug">Enable parser debugging code</flag>
</use>
<upstream>
<remote-id type="cpe">cpe:/a:tcpdump:libpcap</remote-id>