summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLars Wendler <polynomial-c@gentoo.org>2018-05-07 14:11:04 +0200
committerLars Wendler <polynomial-c@gentoo.org>2018-05-07 14:49:17 +0200
commit187e9e33af5de84492219471628e301be03b5539 (patch)
treef68231dda735fec39ddbbc3843aebc57b72a431d
parentmedia-video/smplayer: drop -Werror to allow gcc-8, bug #654724 (diff)
downloadgentoo-187e9e33af5de84492219471628e301be03b5539.tar.gz
gentoo-187e9e33af5de84492219471628e301be03b5539.tar.bz2
gentoo-187e9e33af5de84492219471628e301be03b5539.zip
dev-libs/libotf: 0.9.16 version bump. Use pkg-config to find freetype
Closes: https://bugs.gentoo.org/655042 Package-Manager: Portage-2.3.36, Repoman-2.3.9 Closes: https://github.com/gentoo/gentoo/pull/8298
-rw-r--r--dev-libs/libotf/Manifest1
-rw-r--r--dev-libs/libotf/files/libotf-0.9.13-build.patch8
-rw-r--r--dev-libs/libotf/files/libotf-0.9.16-freetype_pkgconfig.patch33
-rw-r--r--dev-libs/libotf/libotf-0.9.16.ebuild50
4 files changed, 88 insertions, 4 deletions
diff --git a/dev-libs/libotf/Manifest b/dev-libs/libotf/Manifest
index 974a58494215..4e5bb767bce5 100644
--- a/dev-libs/libotf/Manifest
+++ b/dev-libs/libotf/Manifest
@@ -1 +1,2 @@
DIST libotf-0.9.13.tar.gz 388832 BLAKE2B 73d15db54457afe98016b3958668fd5d62e81c8f53d34bc8ddd6ce5c18e54085a9d3ff1648e2170c7a97823dcbd9ef117f3e66befbea272dd98193baf63d6039 SHA512 86ddf071df371ee44910afc02432352356bfa1c2a55b44274c95fc4e7ec4fca982a7fcde35aaa63a8cb332e98388a9faf9a94fbf0f39e85668630f77d841ef31
+DIST libotf-0.9.16.tar.gz 423979 BLAKE2B 838e7c855f93ebb30bcccd1d3055f662da1736bb85fa398f9ffe84411249f63e4f66908b55534c2f07446b45ae7912745a92bbf0404f8d62eeb3a9119a604b37 SHA512 0f68c45c1224f02dc0f1a8e9915dd9c1c70d71259b4e2f7bbd4fbec6426e58d4a26e4cbf28dbb8ed051ba6f532f99fc4e74b4ddf97a93ec947fa6260c875d0b4
diff --git a/dev-libs/libotf/files/libotf-0.9.13-build.patch b/dev-libs/libotf/files/libotf-0.9.13-build.patch
index 519722f43371..41fcb834f3d4 100644
--- a/dev-libs/libotf/files/libotf-0.9.13-build.patch
+++ b/dev-libs/libotf/files/libotf-0.9.13-build.patch
@@ -1,5 +1,5 @@
---- example/Makefile.am
-+++ example/Makefile.am
+--- a/example/Makefile.am
++++ b/example/Makefile.am
@@ -37,8 +37,7 @@
otfdump_LDADD = ${CommonLDADD}
@@ -10,8 +10,8 @@
otftobdf_SOURCE = otftobdf.c
otftobdf_LDADD = ${CommonLDADD}
---- libotf.pc.in
-+++ libotf.pc.in
+--- a/libotf.pc.in
++++ b/libotf.pc.in
@@ -7,5 +7,6 @@
Description: OpenType font library
Version: @PACKAGE_VERSION@
diff --git a/dev-libs/libotf/files/libotf-0.9.16-freetype_pkgconfig.patch b/dev-libs/libotf/files/libotf-0.9.16-freetype_pkgconfig.patch
new file mode 100644
index 000000000000..a57e92e1b1c2
--- /dev/null
+++ b/dev-libs/libotf/files/libotf-0.9.16-freetype_pkgconfig.patch
@@ -0,0 +1,33 @@
+--- libotf-0.9.16/configure.ac
++++ libotf-0.9.16/configure.ac
+@@ -48,23 +48,24 @@
+ AC_FUNC_ALLOCA
+ AC_FUNC_MALLOC
+
++PKG_PROG_PKG_CONFIG
++
+ # Check for Freetype2 usability.
+-AC_CHECK_PROG(HAVE_FREETYPE_CONFIG, freetype-config, yes)
+-if test "x$HAVE_FREETYPE_CONFIG" = "xyes"; then
+- FREETYPE_INC=`freetype-config --cflags`
++PKG_CHECK_MODULES(FREETYPE, freetype2, [
++ FREETYPE_INC="$FREETYPE_CFLAGS"
+ CPPFLAGS="$CPPFLAGS $FREETYPE_INC"
+ AC_CHECK_HEADER(ft2build.h, HAVE_FREETYPE=yes,
+ HAVE_FREETYPE=no CPPFLAGS=$save_CPPFLAGS)
+ if test "x$HAVE_FREETYPE" = "xyes" ; then
+- FREETYPE_LD_FLAGS=`freetype-config --libs`;
++ FREETYPE_LD_FLAGS="$FREETYPE_LIBS"
+ LIBS="$LIBS $FREETYPE_LD_FLAGS"
+ AC_CHECK_LIB(freetype, FT_Init_FreeType, HAVE_FREETYPE=yes,
+ HAVE_FREETYPE=no)
+ fi
+-fi
++])
+
+ if test "x$HAVE_FREETYPE" != "xyes" ; then
+- echo "Freetype library wan't found in your system!"
++ echo "Freetype library not found in your system!"
+ exit 1
+ fi
+ AC_SUBST(FREETYPE_INC)
diff --git a/dev-libs/libotf/libotf-0.9.16.ebuild b/dev-libs/libotf/libotf-0.9.16.ebuild
new file mode 100644
index 000000000000..1fdded3749e9
--- /dev/null
+++ b/dev-libs/libotf/libotf-0.9.16.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+inherit autotools
+
+DESCRIPTION="Library for handling OpenType fonts (OTF)"
+HOMEPAGE="http://www.nongnu.org/m17n/"
+SRC_URI="mirror://nongnu/m17n/${P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~sh ~sparc ~x86 ~amd64-linux ~x86-linux"
+IUSE="static-libs X"
+
+RDEPEND=">=media-libs/freetype-2.4.9
+ X? (
+ x11-libs/libX11
+ x11-libs/libXaw
+ x11-libs/libXt
+ )"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig
+ X? (
+ x11-libs/libICE
+ x11-libs/libXmu
+ x11-proto/xproto
+ )"
+
+DOCS="AUTHORS ChangeLog NEWS README"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-0.9.13-build.patch
+ "${FILESDIR}"/${PN}-0.9.16-freetype_pkgconfig.patch
+)
+
+src_prepare() {
+ default
+ eautoreconf
+}
+
+src_configure() {
+ export ac_cv_header_X11_Xaw_Command_h=$(usex X)
+ econf $(use_enable static-libs static)
+}
+
+src_install() {
+ default
+ find "${ED}" -name "*.la" -delete || die
+}