summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2021-03-18 00:01:36 +0000
committerLars Wendler <polynomial-c@gentoo.org>2021-03-22 09:57:45 +0100
commit18b0451c9ae2db037d996b0a5156ba41bf9d1f5a (patch)
tree1d3fbbde494006833a918806c9512d21d775c273
parentsys-libs/zlib-ng: add preliminary intrinics (diff)
downloadgentoo-18b0451c9ae2db037d996b0a5156ba41bf9d1f5a.tar.gz
gentoo-18b0451c9ae2db037d996b0a5156ba41bf9d1f5a.tar.bz2
gentoo-18b0451c9ae2db037d996b0a5156ba41bf9d1f5a.zip
sys-libs/zlib-ng: add blocker on sys-libs/zlib when using compat mode
Warn users if USE=compat is enabled and also include a link to upstream's interpretation of what USE=compat provides. Signed-off-by: Sam James <sam@gentoo.org> Signed-off-by: Lars Wendler <polynomial-c@gentoo.org>
-rw-r--r--sys-libs/zlib-ng/zlib-ng-2.0.1-r1.ebuild14
1 files changed, 14 insertions, 0 deletions
diff --git a/sys-libs/zlib-ng/zlib-ng-2.0.1-r1.ebuild b/sys-libs/zlib-ng/zlib-ng-2.0.1-r1.ebuild
index c00074bbf786..291818622291 100644
--- a/sys-libs/zlib-ng/zlib-ng-2.0.1-r1.ebuild
+++ b/sys-libs/zlib-ng/zlib-ng-2.0.1-r1.ebuild
@@ -18,6 +18,8 @@ IUSE="compat ${CPU_USE[@]} test"
RESTRICT="!test? ( test )"
+RDEPEND="compat? ( !sys-libs/zlib )"
+
src_prepare() {
cmake_src_prepare
@@ -67,3 +69,15 @@ src_configure() {
cmake_src_configure
}
+
+src_install() {
+ cmake_src_install
+
+ if use compat ; then
+ ewarn "zlib-ng is experimental and replacing the system zlib is dangerous"
+ ewarn "Please be careful!"
+ ewarn
+ ewarn "The following link explains the guarantees (and what is NOT guaranteed):"
+ ewarn "https://github.com/zlib-ng/zlib-ng/blob/2.0.x/PORTING.md"
+ fi
+}