summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAnthony G. Basile <blueness@gentoo.org>2019-02-24 12:32:23 -0500
committerAnthony G. Basile <blueness@gentoo.org>2019-02-24 12:32:23 -0500
commit191bb01de7bf7ed60044650624ac063b69da0e75 (patch)
tree574d0421bbd9bd593104bfb56f136468f956b34f
parentsci-chemistry/gromacs: added v2018.6 (diff)
downloadgentoo-191bb01de7bf7ed60044650624ac063b69da0e75.tar.gz
gentoo-191bb01de7bf7ed60044650624ac063b69da0e75.tar.bz2
gentoo-191bb01de7bf7ed60044650624ac063b69da0e75.zip
net-vpn/tor: version bump to 0.3.5.8
Signed-off-by: Anthony G. Basile <blueness@gentoo.org> Package-Manager: Portage-2.3.51, Repoman-2.3.11
-rw-r--r--net-vpn/tor/Manifest1
-rw-r--r--net-vpn/tor/tor-0.3.5.8.ebuild87
2 files changed, 88 insertions, 0 deletions
diff --git a/net-vpn/tor/Manifest b/net-vpn/tor/Manifest
index f8d6bb2eb129..2a4824601f4e 100644
--- a/net-vpn/tor/Manifest
+++ b/net-vpn/tor/Manifest
@@ -1,3 +1,4 @@
DIST tor-0.3.4.9.tar.gz 6695931 BLAKE2B ebfe0f49ae923e63b0bd8a7cafc453d7b0775cbfd167463b364490faf9bbf61decd28906d8f5bb08bfa9a5a10b371d9188a5019314c0de5ace15cc379347f88e SHA512 cc254a2cc2f21b4511e9cb215ba5f05fefc4dceffcf46a402efa2d3540872a4ed8e0095245df0802ea12c1367451bc16ca60c0aea6a77e2139580f3c5ba8c02f
DIST tor-0.3.5.7.tar.gz 6934521 BLAKE2B 3af9a1a14fa5ea7ce0a5be08db3e2cbe4188d569bda92c7a24a66f94d79869acfd1ba9e1c51bfb0ac3f6399d79b907888d1546ba7898af9563d65f5288c09577 SHA512 e3a7be620c228c3bc73ea9350a19abecb0ac6dae2b309d6233151ab2377c754110a9854d8d221f380f80cffa2f723d266bd09b3432ae33c319c0fe9a7e538bc9
+DIST tor-0.3.5.8.tar.gz 6994335 BLAKE2B d37006ee48f6ecb9205fe9ad1178f2375aec5a8f8c614a85af398e2114d13e4ef7dcfc501685f2f6d4dbb44cca2ab318be69ac37686a3ef1bb980adcdefcac11 SHA512 47a21cdd6d4563dd9bfb43c26f054f00747d069611dc9b16eb11b9653fab5c0133fb8bd30e162fa27d90d6bc4f88c0e2bf49eb4fe54529017d5eb87c3bb86132
DIST tor-0.4.0.1-alpha.tar.gz 7087989 BLAKE2B 757a478ac9619553b687144fa2c5e56cfa9324800f567fb66fd2d637f33f8886ec13cf96accc46bd8c93dd8adcdcf51f0ed3c50e377af6e198cdfc3734741425 SHA512 4c09837316921d170a8866116bbbd31603fd312e0e2282abcf13e52a656141d22e3d0dd91185c0429cf9ae080d06bd100f747d18795b1b606aec7178c19f5bac
diff --git a/net-vpn/tor/tor-0.3.5.8.ebuild b/net-vpn/tor/tor-0.3.5.8.ebuild
new file mode 100644
index 000000000000..2e27b784b6bc
--- /dev/null
+++ b/net-vpn/tor/tor-0.3.5.8.ebuild
@@ -0,0 +1,87 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="7"
+
+inherit flag-o-matic readme.gentoo-r1 systemd user
+
+MY_PV="$(ver_rs 4 -)"
+MY_PF="${PN}-${MY_PV}"
+DESCRIPTION="Anonymizing overlay network for TCP"
+HOMEPAGE="http://www.torproject.org/"
+SRC_URI="https://www.torproject.org/dist/${MY_PF}.tar.gz
+ https://archive.torproject.org/tor-package-archive/${MY_PF}.tar.gz"
+S="${WORKDIR}/${MY_PF}"
+
+LICENSE="BSD GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~mips ~ppc ~ppc64 ~x86 ~ppc-macos"
+IUSE="caps libressl lzma scrypt seccomp selinux systemd tor-hardening test zstd"
+
+DEPEND="
+ app-text/asciidoc
+ dev-libs/libevent[ssl]
+ sys-libs/zlib
+ caps? ( sys-libs/libcap )
+ !libressl? ( dev-libs/openssl:0=[-bindist] )
+ libressl? ( dev-libs/libressl:0= )
+ lzma? ( app-arch/xz-utils )
+ scrypt? ( app-crypt/libscrypt )
+ seccomp? ( sys-libs/libseccomp )
+ systemd? ( sys-apps/systemd )
+ zstd? ( app-arch/zstd )"
+RDEPEND="${DEPEND}
+ selinux? ( sec-policy/selinux-tor )"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-0.2.7.4-torrc.sample.patch
+ "${FILESDIR}"/${PN}-0.3.3.2-alpha-tor.service.in.patch
+)
+
+DOCS=( README ChangeLog ReleaseNotes doc/HACKING )
+
+pkg_setup() {
+ enewgroup tor
+ enewuser tor -1 -1 /var/lib/tor tor
+}
+
+src_configure() {
+ export ac_cv_lib_cap_cap_init=$(usex caps)
+ econf \
+ --localstatedir="${EPREFIX}/var" \
+ --enable-system-torrc \
+ --enable-asciidoc \
+ --disable-android \
+ --disable-libfuzzer \
+ --disable-module-dirauth \
+ --enable-pic \
+ --disable-rust \
+ --disable-restart-debugging \
+ --disable-zstd-advanced-apis \
+ $(use_enable lzma) \
+ $(use_enable scrypt libscrypt) \
+ $(use_enable seccomp) \
+ $(use_enable systemd) \
+ $(use_enable tor-hardening gcc-hardening) \
+ $(use_enable tor-hardening linker-hardening) \
+ $(use_enable test unittests) \
+ $(use_enable test coverage) \
+ $(use_enable zstd)
+}
+
+src_install() {
+ default
+ readme.gentoo_create_doc
+
+ newconfd "${FILESDIR}"/tor.confd tor
+ newinitd "${FILESDIR}"/tor.initd-r8 tor
+ systemd_dounit contrib/dist/tor.service
+
+ keepdir /var/lib/tor
+
+ fperms 750 /var/lib/tor
+ fowners tor:tor /var/lib/tor
+
+ insinto /etc/tor/
+ newins "${FILESDIR}"/torrc-r1 torrc
+}