summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2017-09-12 23:53:09 +0200
committerAndreas Sturmlechner <asturm@gentoo.org>2017-09-13 00:13:21 +0200
commit1957168b7133a68c101af9ce423c656da19cb1a8 (patch)
tree59a0054e2672135cfc076033c1ecccd3fe3eab31
parentmedia-gfx/kgraphviewer: Drop slot 4 (diff)
downloadgentoo-1957168b7133a68c101af9ce423c656da19cb1a8.tar.gz
gentoo-1957168b7133a68c101af9ce423c656da19cb1a8.tar.bz2
gentoo-1957168b7133a68c101af9ce423c656da19cb1a8.zip
media-sound/soundkonverter: 3.0.0 version bump
See also: https://github.com/dfaust/soundkonverter/issues/23 Package-Manager: Portage-2.3.8, Repoman-2.3.3
-rw-r--r--media-sound/soundkonverter/Manifest1
-rw-r--r--media-sound/soundkonverter/files/soundkonverter-3.0.0-deps.patch11
-rw-r--r--media-sound/soundkonverter/soundkonverter-3.0.0.ebuild54
3 files changed, 66 insertions, 0 deletions
diff --git a/media-sound/soundkonverter/Manifest b/media-sound/soundkonverter/Manifest
index 807b2f5b0188..4f60f153f7e5 100644
--- a/media-sound/soundkonverter/Manifest
+++ b/media-sound/soundkonverter/Manifest
@@ -1 +1,2 @@
DIST 29024-soundkonverter-2.2.2.tar.gz 858128 SHA256 327de45ea21780d77c53835289e6b6dba196706d76df755fe5dd338761e97663 SHA512 d0539405feb229b6e844b814ae22705f4213acebac688fb6286c0d76c3d4cbea6dfe297448b148c6502be7eb1925fee2a1274ccf8df8d1c7ecb93e36fd7a6f6f WHIRLPOOL 8d4127a274041506c6436dcda128cad86ae0345470debe120c5989ca954b5c3dd4a3133959104ee7154e832830c689a00c598db9e00a1488579b513066dcdec3
+DIST soundkonverter-3.0.0.tar.gz 821111 SHA256 f6864a9f145100b721e176b1af8c44646201fcad0886614ea30790a0c3320aee SHA512 5120de077082cc7a760cd1d1f4a7dd804ce8f4190c94d8d2b14baa92c851c6f6338c6f075bfa5a8fed8891840938a790e3765465b49c8863166f0805b355506a WHIRLPOOL 2b5600db2072d780891753bda2cb43901920e2170238cca9cdcb562410caffa63faecc904c1ddce277a8d70e1efa376d28cc19540c8c24c636a61b62afa823d2
diff --git a/media-sound/soundkonverter/files/soundkonverter-3.0.0-deps.patch b/media-sound/soundkonverter/files/soundkonverter-3.0.0-deps.patch
new file mode 100644
index 000000000000..aa5f68af9394
--- /dev/null
+++ b/media-sound/soundkonverter/files/soundkonverter-3.0.0-deps.patch
@@ -0,0 +1,11 @@
+--- a/CMakeLists.txt 2017-09-12 23:39:15.648029711 +0200
++++ b/CMakeLists.txt 2017-09-12 23:44:47.944469934 +0200
+@@ -30,7 +30,7 @@
+ include(ECMInstallIcons)
+ include(FeatureSummary)
+
+-find_package(Qt5 REQUIRED COMPONENTS Network Core Widgets)
++find_package(Qt5 REQUIRED COMPONENTS Core Widgets Xml)
+ find_package(KF5 REQUIRED COMPONENTS I18n XmlGui KIO Solid Config ConfigWidgets WidgetsAddons KDELibs4Support)
+ find_package(KF5Cddb)
+ find_package(Phonon4Qt5 REQUIRED)
diff --git a/media-sound/soundkonverter/soundkonverter-3.0.0.ebuild b/media-sound/soundkonverter/soundkonverter-3.0.0.ebuild
new file mode 100644
index 000000000000..9061189c8875
--- /dev/null
+++ b/media-sound/soundkonverter/soundkonverter-3.0.0.ebuild
@@ -0,0 +1,54 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit kde5
+
+DESCRIPTION="Frontend to various audio converters"
+HOMEPAGE="https://www.linux-apps.com/search?projectSearchText=soundKonverter
+ https://github.com/dfaust/soundkonverter"
+SRC_URI="https://github.com/dfaust/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-2"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="
+ $(add_frameworks_dep kcompletion)
+ $(add_frameworks_dep kconfig)
+ $(add_frameworks_dep kconfigwidgets)
+ $(add_frameworks_dep kcoreaddons)
+ $(add_frameworks_dep kdelibs4support)
+ $(add_frameworks_dep ki18n)
+ $(add_frameworks_dep kio)
+ $(add_frameworks_dep knotifications)
+ $(add_frameworks_dep kservice)
+ $(add_frameworks_dep ktextwidgets)
+ $(add_frameworks_dep kwidgetsaddons)
+ $(add_frameworks_dep kxmlgui)
+ $(add_frameworks_dep solid)
+ $(add_kdeapps_dep libkcddb)
+ $(add_qt_dep qtgui)
+ $(add_qt_dep qtwidgets)
+ $(add_qt_dep qtxml)
+ media-libs/phonon[qt5]
+ >=media-libs/taglib-1.10
+ media-sound/cdparanoia
+"
+DEPEND="${RDEPEND}
+ sys-devel/gettext
+"
+
+PATCHES=( "${FILESDIR}/${P}-deps.patch" )
+
+S="${WORKDIR}"/${P}/src
+
+pkg_postinst() {
+ kde5_pkg_postinst
+
+ elog "soundKonverter optionally supports many different audio formats."
+ elog "You will need to install the appropriate encoding packages for the"
+ elog "formats you require. For a full listing, consult the README file"
+ elog "in /usr/share/doc/${PF}"
+}