summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorManuel Rüger <mrueg@gentoo.org>2019-01-09 16:44:08 +0100
committerManuel Rüger <mrueg@gentoo.org>2019-01-09 16:44:08 +0100
commit1a733e460f0368825faec1d49b9a965381513c08 (patch)
treeb5353dd4976d6fda9b24c474b720aa27212801e8
parentapp-text/manpager: Keyword 1 ~amd64-fbsd (diff)
downloadgentoo-1a733e460f0368825faec1d49b9a965381513c08.tar.gz
gentoo-1a733e460f0368825faec1d49b9a965381513c08.tar.bz2
gentoo-1a733e460f0368825faec1d49b9a965381513c08.zip
app-emulation/containerd: Version bump to 1.2.2
Package-Manager: Portage-2.3.54, Repoman-2.3.12 Signed-off-by: Manuel Rüger <mrueg@gentoo.org>
-rw-r--r--app-emulation/containerd/Manifest1
-rw-r--r--app-emulation/containerd/containerd-1.2.2.ebuild56
2 files changed, 57 insertions, 0 deletions
diff --git a/app-emulation/containerd/Manifest b/app-emulation/containerd/Manifest
index aa52e9843542..14fe116537fc 100644
--- a/app-emulation/containerd/Manifest
+++ b/app-emulation/containerd/Manifest
@@ -4,3 +4,4 @@ DIST containerd-1.1.2.tar.gz 5124208 BLAKE2B d989519d6bef4e12d1fa04aa00bfee223e9
DIST containerd-1.1.4.tar.gz 5328134 BLAKE2B cb69f9bd80bc279ae2bd85c75152dacdbdf13df9aa2efae2453c11bf6ea9b990a4e8ec3cb07778ff1b07ef2fbc05d19bb5714616fa5618f590dc8c5b5c2b2bd0 SHA512 c51b3168b8d8121b1479f75f5ba21280848bb1cbed2d2c4a7e315ec24d1805fc9c512a1fc53e8e8fc32e150c7f2becb8daca0ecab4eaf760b3274c11fbcd6ea8
DIST containerd-1.2.0.tar.gz 4605096 BLAKE2B 5bcfb252933d4f8d5ab6c7e91505cfec34137545121440cd6935e05cd3c62a4969fff8b90b628634c01cc9a4dc3901c307604ab30f45a03dd20112653da9437d SHA512 f7e1ede8db253c666dc9d68642951a427722945da60acf8631312377c84aab14c7a8b14e81f9a63ab8f909d25eb55911c0f2eef68f11380c66cd77bada8577bd
DIST containerd-1.2.1.tar.gz 4605947 BLAKE2B 340daac847eaa653d15894fd65c190702807400dfb8293b5a2507b9a13a86752c00357cf6aeb3735c57878c34f79c35076d7087a905ee7efe7971746c792a212 SHA512 0949299afe17e269a6c551e865e500afeeaba700cf78bb12fef4af8e6d48a2f699976e81dad44d797bb13079361f5d5e05e9abe903a3b158af93f2aaa95712e5
+DIST containerd-1.2.2.tar.gz 4607013 BLAKE2B aca366f23cb24ddd0363333e5a4ab0fc833f917c7f1f01d56fd22bdb4bc6721f077e5ba411db6faecc4152b8f047af5da95283029f6e66dadad49c7296b82c89 SHA512 0fdd8799c5afb75074b6f00d5191e983ff570b323242665055c73b2e7a6bdd74a745e287f4f7b675dde26e8bf083c144104151e794ad24d2a8f6f39ae2ee6fff
diff --git a/app-emulation/containerd/containerd-1.2.2.ebuild b/app-emulation/containerd/containerd-1.2.2.ebuild
new file mode 100644
index 000000000000..8ccee3fc69ac
--- /dev/null
+++ b/app-emulation/containerd/containerd-1.2.2.ebuild
@@ -0,0 +1,56 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+EGO_PN="github.com/containerd/${PN}"
+
+inherit toolchain-funcs
+
+if [[ ${PV} == *9999 ]]; then
+ inherit golang-vcs
+else
+ MY_PV="${PV/_rc/-rc.}"
+ EGIT_COMMIT="v${MY_PV}"
+ CONTAINERD_COMMIT="9754871865f7fe2f4e74d43e2fc7ccd237edcbce"
+ SRC_URI="https://${EGO_PN}/archive/${EGIT_COMMIT}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~arm ~arm64 ~ppc64"
+ inherit golang-vcs-snapshot
+fi
+
+DESCRIPTION="A daemon to control runC"
+HOMEPAGE="https://containerd.tools"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+IUSE="apparmor +btrfs +cri hardened +seccomp"
+
+DEPEND="btrfs? ( sys-fs/btrfs-progs )
+ seccomp? ( sys-libs/libseccomp )"
+RDEPEND=">=app-emulation/runc-1.0.0_rc5
+ seccomp? ( sys-libs/libseccomp )"
+
+S=${WORKDIR}/${P}/src/${EGO_PN}
+
+RESTRICT="test"
+
+src_prepare() {
+ default
+ if [[ ${PV} != *9999* ]]; then
+ sed -i -e "s/git describe --match.*$/echo ${PV})/"\
+ -e "s/git rev-parse HEAD.*$/echo $CONTAINERD_COMMIT)/"\
+ -e "s/-s -w//" \
+ Makefile || die
+ fi
+}
+
+src_compile() {
+ local options=( $(usex btrfs "" "no_btrfs") $(usex cri "" "no_cri") $(usex seccomp "seccomp" "") $(usex apparmor "apparmor" "") )
+ export GOPATH="${WORKDIR}/${P}" # ${PWD}/vendor
+ LDFLAGS=$(usex hardened '-extldflags -fno-PIC' '') BUILDTAGS="${options[@]}" emake
+}
+
+src_install() {
+ newinitd "${FILESDIR}"/${PN}.initd ${PN}
+ keepdir /var/lib/containerd
+ dobin bin/containerd{-shim,-stress,} bin/ctr
+}