summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatt Turner <mattst88@gentoo.org>2021-04-01 16:08:55 -0400
committerMatt Turner <mattst88@gentoo.org>2021-04-01 16:13:00 -0400
commit1ac982ebcba006eb94b18a6e7a4ed55d026098e1 (patch)
tree311a74288cb079716c0b23b82c6520e094ed9161
parentapp-admin/pass: Propagate keywords (diff)
downloadgentoo-1ac982ebcba006eb94b18a6e7a4ed55d026098e1.tar.gz
gentoo-1ac982ebcba006eb94b18a6e7a4ed55d026098e1.tar.bz2
gentoo-1ac982ebcba006eb94b18a6e7a4ed55d026098e1.zip
app-admin/pass: Version bump to 1.7.4_pre20210216
Signed-off-by: Matt Turner <mattst88@gentoo.org>
-rw-r--r--app-admin/pass/Manifest1
-rw-r--r--app-admin/pass/pass-1.7.4_pre20210216.ebuild92
2 files changed, 93 insertions, 0 deletions
diff --git a/app-admin/pass/Manifest b/app-admin/pass/Manifest
index f12d405e6d6a..dcd8486ea58f 100644
--- a/app-admin/pass/Manifest
+++ b/app-admin/pass/Manifest
@@ -1 +1,2 @@
DIST password-store-1.7.3.tar.xz 63416 BLAKE2B 5931608e0208dfe6965b79f586c153a4930d1c3d3b74433d026ee0bc5889fcc29334c637ca4fb68308d0169bad7c8235b6632e9f80eda1e24f0f5721353f88e3 SHA512 89755a7b02f05d75055a9fc14fd3f456c0a49ec31bdffd097a027f91228c64a98b18c1e80017aeda811773ae3287ff1b9737532da8ded06799d8fe3979ca06f7
+DIST password-store-918992c19231b33b3d4a3288a7288a620e608cb4.tar.xz 65000 BLAKE2B 2bd7768fe1a93ce55b0daf15088bde7ce75dbe33f44b1890e27ca6efe70fadb07610b830bd9926f6c88b33c4d3ae208b0035f13e81f28978cb26454332a19b13 SHA512 63a448e4da3da60d3dfe02b02eb11417e179c4f0b973c822bfbb485262076ae7458c3e35e95b2ad9997a2ddfa8bbe91a822c86d7ad5d2f7a6e6cb90d11774aa9
diff --git a/app-admin/pass/pass-1.7.4_pre20210216.ebuild b/app-admin/pass/pass-1.7.4_pre20210216.ebuild
new file mode 100644
index 000000000000..190d2cec6a45
--- /dev/null
+++ b/app-admin/pass/pass-1.7.4_pre20210216.ebuild
@@ -0,0 +1,92 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit bash-completion-r1 elisp-common
+
+if [[ ${PV} = 9999* ]]; then
+ EGIT_REPO_URI="https://git.zx2c4.com/password-store"
+ inherit git-r3
+else
+ KEYWORDS="~amd64 ~arm64 ~x86 ~x64-macos"
+ COMMIT_ID="918992c19231b33b3d4a3288a7288a620e608cb4"
+ SRC_URI="https://git.zx2c4.com/password-store/snapshot/password-store-${COMMIT_ID}.tar.xz"
+ S="${WORKDIR}/${PN}"
+fi
+
+DESCRIPTION="Stores, retrieves, generates, and synchronizes passwords securely"
+HOMEPAGE="https://www.passwordstore.org/"
+
+SLOT="0"
+LICENSE="GPL-2"
+IUSE="+git wayland X zsh-completion fish-completion emacs dmenu importers elibc_Darwin"
+
+RDEPEND="
+ app-crypt/gnupg
+ media-gfx/qrencode
+ >=app-text/tree-1.7.0
+ git? ( dev-vcs/git )
+ wayland? ( gui-apps/wl-clipboard )
+ X? ( x11-misc/xclip )
+ elibc_Darwin? ( app-misc/getopt )
+ zsh-completion? ( app-shells/gentoo-zsh-completions )
+ fish-completion? ( app-shells/fish )
+ dmenu? ( x11-misc/dmenu x11-misc/xdotool )
+ emacs? ( >=app-editors/emacs-23.1:* >=app-emacs/f-0.11.0 >=app-emacs/s-1.9.0 >=app-emacs/with-editor-2.5.11 )
+"
+
+src_unpack() {
+ default
+
+ # Hack: Tests fail if the path length is too long
+ mv "${WORKDIR}/password-store-${COMMIT_ID}" "${WORKDIR}/${PN}"
+}
+
+src_prepare() {
+ default
+
+ use elibc_Darwin || return
+ # use coreutils'
+ sed -i -e 's/openssl base64/base64/g' src/platform/darwin.sh || die
+ # host getopt isn't cool, and we aren't brew (rip out brew reference)
+ sed -i -e '/^GETOPT=/s/=.*$/=getopt-long/' src/platform/darwin.sh || die
+ # make sure we can find "mount"
+ sed -i -e 's:mount -t:/sbin/mount -t:' src/platform/darwin.sh || die
+}
+
+src_compile() {
+ use emacs && elisp-compile contrib/emacs/*.el
+}
+
+src_install() {
+ emake install \
+ DESTDIR="${D}" \
+ PREFIX="${EPREFIX}/usr" \
+ BASHCOMPDIR="$(get_bashcompdir)" \
+ WITH_BASHCOMP=yes \
+ WITH_ZSHCOMP=$(usex zsh-completion) \
+ WITH_FISHCOMP=$(usex fish-completion)
+ use dmenu && dobin contrib/dmenu/passmenu
+ if use emacs; then
+ elisp-install ${PN} contrib/emacs/*.{el,elc}
+ elisp-site-file-install "${FILESDIR}/50${PN}-gentoo.el"
+ fi
+ if use importers; then
+ exeinto /usr/share/${PN}/importers
+ doexe contrib/importers/*
+ fi
+}
+
+pkg_postinst() {
+ use emacs && elisp-site-regen
+ if use importers; then
+ einfo "To import passwords from other password managers, you may use the"
+ einfo "various importer scripts found in:"
+ einfo " ${EROOT}/usr/share/${PN}/importers/"
+ fi
+}
+
+pkg_postrm() {
+ use emacs && elisp-site-regen
+}