summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Thode <prometheanfire@gentoo.org>2019-04-04 09:45:13 -0500
committerMatthew Thode <prometheanfire@gentoo.org>2019-04-04 09:47:04 -0500
commit1b8a267cb717a535563f8c3d54753d5b98656b3f (patch)
tree157ec80b99ff458d1c8df86c045467ee5edd6d81
parentdev-python/PyECLib: 1.6.0 bump (diff)
downloadgentoo-1b8a267cb717a535563f8c3d54753d5b98656b3f.tar.gz
gentoo-1b8a267cb717a535563f8c3d54753d5b98656b3f.tar.bz2
gentoo-1b8a267cb717a535563f8c3d54753d5b98656b3f.zip
sys-cluster/swift: add doc support
Thanks Hank Leininger for the patch Fixes: https://bugs.gentoo.org/682478 Package-Manager: Portage-2.3.62, Repoman-2.3.12 Signed-off-by: Matthew Thode <prometheanfire@gentoo.org>
-rw-r--r--sys-cluster/swift/swift-2.21.0-r1.ebuild (renamed from sys-cluster/swift/swift-2.21.0.ebuild)7
-rw-r--r--sys-cluster/swift/swift-2019.1.9999.ebuild7
2 files changed, 12 insertions, 2 deletions
diff --git a/sys-cluster/swift/swift-2.21.0.ebuild b/sys-cluster/swift/swift-2.21.0-r1.ebuild
index d96686a8d7fa..ec5ee0cd41ee 100644
--- a/sys-cluster/swift/swift-2.21.0.ebuild
+++ b/sys-cluster/swift/swift-2.21.0-r1.ebuild
@@ -19,7 +19,7 @@ fi
LICENSE="Apache-2.0"
SLOT="0"
-IUSE="proxy account container object +memcached"
+IUSE="account container doc +memcached object proxy"
REQUIRED_USE="|| ( proxy account container object )"
CDEPEND=">=dev-python/pbr-1.8.0[${PYTHON_USEDEP}]"
@@ -109,6 +109,11 @@ python_install_all() {
newins "etc/object-expirer.conf-sample" "object-expirer.conf"
fi
+ if use doc; then
+ doman doc/manpages/*
+ dodoc -r doc/{s3api,saio,source}
+ fi
+
fowners root:swift "/etc/swift" || die "fowners failed"
fperms 0750 /etc/swift
}
diff --git a/sys-cluster/swift/swift-2019.1.9999.ebuild b/sys-cluster/swift/swift-2019.1.9999.ebuild
index d96686a8d7fa..ec5ee0cd41ee 100644
--- a/sys-cluster/swift/swift-2019.1.9999.ebuild
+++ b/sys-cluster/swift/swift-2019.1.9999.ebuild
@@ -19,7 +19,7 @@ fi
LICENSE="Apache-2.0"
SLOT="0"
-IUSE="proxy account container object +memcached"
+IUSE="account container doc +memcached object proxy"
REQUIRED_USE="|| ( proxy account container object )"
CDEPEND=">=dev-python/pbr-1.8.0[${PYTHON_USEDEP}]"
@@ -109,6 +109,11 @@ python_install_all() {
newins "etc/object-expirer.conf-sample" "object-expirer.conf"
fi
+ if use doc; then
+ doman doc/manpages/*
+ dodoc -r doc/{s3api,saio,source}
+ fi
+
fowners root:swift "/etc/swift" || die "fowners failed"
fperms 0750 /etc/swift
}