summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2016-03-03 11:58:01 +0100
committerAlexis Ballier <aballier@gentoo.org>2016-03-03 11:58:10 +0100
commit1c1491debaf5316851abf30a34e4084342c38e8c (patch)
treef73ebcfe348a208a5760f094604771e513d94a97
parentdev-python/pypy: Drop old (diff)
downloadgentoo-1c1491debaf5316851abf30a34e4084342c38e8c.tar.gz
gentoo-1c1491debaf5316851abf30a34e4084342c38e8c.tar.bz2
gentoo-1c1491debaf5316851abf30a34e4084342c38e8c.zip
dev-lang/ocaml: add tests support
Package-Manager: portage-2.2.27 Signed-off-by: Alexis Ballier <aballier@gentoo.org>
-rw-r--r--dev-lang/ocaml/ocaml-4.03.0_beta1.ebuild8
1 files changed, 8 insertions, 0 deletions
diff --git a/dev-lang/ocaml/ocaml-4.03.0_beta1.ebuild b/dev-lang/ocaml/ocaml-4.03.0_beta1.ebuild
index 803426547831..0aea93c39f97 100644
--- a/dev-lang/ocaml/ocaml-4.03.0_beta1.ebuild
+++ b/dev-lang/ocaml/ocaml-4.03.0_beta1.ebuild
@@ -91,6 +91,14 @@ src_compile() {
fi
}
+src_test() {
+ if use ocamlopt ; then
+ emake -j1 tests
+ else
+ ewarn "${PN} testsuite requires ocamlopt useflag"
+ fi
+}
+
src_install() {
emake BINDIR="${ED}"/usr/bin \
LIBDIR="${ED}"/usr/$(get_libdir)/ocaml \