summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Seifert <soap@gentoo.org>2016-11-18 19:19:38 +0100
committerDavid Seifert <soap@gentoo.org>2016-11-18 23:39:37 +0100
commit1c4a7faeaaf81bf5f804449d00bea58ae5bd0b24 (patch)
treeb64d456f6d1d7ecbe3658fc9a192ff9969492f00
parentsci-biology/arb: Fix overlong DESCRIPTION (diff)
downloadgentoo-1c4a7faeaaf81bf5f804449d00bea58ae5bd0b24.tar.gz
gentoo-1c4a7faeaaf81bf5f804449d00bea58ae5bd0b24.tar.bz2
gentoo-1c4a7faeaaf81bf5f804449d00bea58ae5bd0b24.zip
sci-biology/biogrep: Port to EAPI=6
* Add USE="doc" and USE="examples" * Run 'eautoreconf' to modernize configure script Package-Manager: portage-2.3.2
-rw-r--r--sci-biology/biogrep/Manifest1
-rw-r--r--sci-biology/biogrep/biogrep-1.0-r2.ebuild36
2 files changed, 37 insertions, 0 deletions
diff --git a/sci-biology/biogrep/Manifest b/sci-biology/biogrep/Manifest
index 6b0006a2c106..155e123703d4 100644
--- a/sci-biology/biogrep/Manifest
+++ b/sci-biology/biogrep/Manifest
@@ -1 +1,2 @@
+DIST biogrep-1.0.pdf 22179 SHA256 87f6a0952a2ebba43fff265d2396851d0be0b578fa94ff11f7dc0427bf784528 SHA512 b0430bded7529a14e3e551e4c7deeffdbdbbe674b5a4bd68afa359b2a4e9f0b8fb4a6474673d298508fa728cf83a328327860e60b3777e92afb15fa87f076411 WHIRLPOOL 02e4c3cc8dfc15f48107731d8515df60e4bde0546eb93cb20bcefb22a1da4a7d7aef05ad7225330e1b276ad7bd34ac7cc1ff2dbbb76a75631c90679cf821c68b
DIST biogrep-1.0.tar.gz 71867 SHA256 15421d79f6f16d6bf9bef132a97f7f9ede1bd42d3fb90572df04a1e1abd8cfd8 SHA512 da07ea6f5f6fd601a94dc1b9495b204affcdc4d5e7fedfebbb65d6382ef0573e43b4ebd081c24909b2790ec2ae532505604112d4943c3e4e6575e13bdcdf1ae3 WHIRLPOOL 3b73e1d0908a7ceebe72a2660c2b13df168449d246411e1a29b3b910951c9932f86f3a829499bc53c22a6b6881097d846bfa6bd95968f246a669076c798af173
diff --git a/sci-biology/biogrep/biogrep-1.0-r2.ebuild b/sci-biology/biogrep/biogrep-1.0-r2.ebuild
new file mode 100644
index 000000000000..7a5e486d48f3
--- /dev/null
+++ b/sci-biology/biogrep/biogrep-1.0-r2.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+inherit autotools
+
+DESCRIPTION="Multithreaded tool for matching large sets of patterns against biosequence DBs"
+HOMEPAGE="http://stephanopoulos.openwetware.org/BIOGREP.html"
+SRC_URI="http://www.openwetware.org/images/3/3d/${P^}.tar.gz -> ${P}.tar.gz
+ doc? ( http://www.openwetware.org/images/4/49/${PN^}.pdf -> ${P}.pdf )"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc examples"
+
+src_prepare() {
+ default
+ mv configure.{in,ac} || die
+ eautoreconf
+}
+
+src_install() {
+ use doc && DOCS+=( "${DISTDIR}"/${P}.pdf )
+ if use examples; then
+ # remove cruft before installing examples
+ find examples/ \( -name 'CVS' -o -name '*~' \) -exec rm -rf '{}' + || die
+
+ DOCS+=( examples )
+ docompress -x /usr/share/doc/${PF}/examples
+ fi
+
+ default
+}