summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Thode <prometheanfire@gentoo.org>2020-06-02 12:55:20 -0500
committerMatthew Thode <prometheanfire@gentoo.org>2020-06-02 12:55:43 -0500
commit1cff54398d13ce884ca2d49e2a355b5aea4be604 (patch)
tree35530ce6d735752a9c44735701c6f541c775dfaa
parentapp-vim/editorconfig-vim-1.1.1: Version bump (diff)
downloadgentoo-1cff54398d13ce884ca2d49e2a355b5aea4be604.tar.gz
gentoo-1cff54398d13ce884ca2d49e2a355b5aea4be604.tar.bz2
gentoo-1cff54398d13ce884ca2d49e2a355b5aea4be604.zip
app-emulation/diskimage-builder: 3.0.0 droppying py2 support
Package-Manager: Portage-2.3.99, Repoman-2.3.22 Signed-off-by: Matthew Thode <prometheanfire@gentoo.org>
-rw-r--r--app-emulation/diskimage-builder/Manifest1
-rw-r--r--app-emulation/diskimage-builder/diskimage-builder-3.0.0.ebuild39
2 files changed, 40 insertions, 0 deletions
diff --git a/app-emulation/diskimage-builder/Manifest b/app-emulation/diskimage-builder/Manifest
index 170e92ebed2d..76b03b95339d 100644
--- a/app-emulation/diskimage-builder/Manifest
+++ b/app-emulation/diskimage-builder/Manifest
@@ -1 +1,2 @@
DIST diskimage-builder-2.37.3.tar.gz 444207 BLAKE2B 602a5063d54d3d4bce1a2b5a3e941ef5ad69709733c9aa9543c6b3f7e7ef1bd45399d0fd7e5b2f6dc3dc8f38fba1bf108473f89252c4b9b181f97c4dc02af18e SHA512 fff684c348f5b2ba0d3ae5ce955be4b1d47cead934c96eddcd137b1568961661c949cb53d3134359d0fa8ab753c559b7f83d5555cb6dc8fbd121cb9d05a4a66a
+DIST diskimage-builder-3.0.0.tar.gz 434880 BLAKE2B 1b51540c023852ef363788821844c34dacc33021412cf94aad5078adc526ff66693a1d7109610b4aeb0aecf3fbfa0725f7caecc471e7c6df56d266723d1411fe SHA512 dd45f8dbfd8d3af3b5862564af1a5585adeb3536fc701cd186453eba82ef85d5b2f6a95abb820f658e0332b466fec097c52f041dfe61127d58da80a0c4d9e84c
diff --git a/app-emulation/diskimage-builder/diskimage-builder-3.0.0.ebuild b/app-emulation/diskimage-builder/diskimage-builder-3.0.0.ebuild
new file mode 100644
index 000000000000..720474e33c48
--- /dev/null
+++ b/app-emulation/diskimage-builder/diskimage-builder-3.0.0.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{6,7,8} )
+inherit distutils-r1
+
+DESCRIPTION="Golden Disk Image builder."
+HOMEPAGE="http://docs.openstack.org/developer/diskimage-builder/"
+if [[ ${PV} == 9999* ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://opendev.org/openstack/diskimage-builder.git"
+else
+ SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+ KEYWORDS="~amd64 ~arm64 ~x86 ~amd64-linux ~x86-linux"
+fi
+
+LICENSE="Apache-2.0"
+SLOT="0"
+IUSE=""
+
+CDEPEND=">=dev-python/pbr-2.0.0[${PYTHON_USEDEP}]
+ !~dev-python/pbr-2.1.0[${PYTHON_USEDEP}]"
+DEPEND="${CDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]"
+RDEPEND="${CDEPEND}
+ >=dev-python/Babel-2.3.4[${PYTHON_USEDEP}]
+ !~dev-python/Babel-2.4.0[${PYTHON_USEDEP}]
+ >=dev-python/networkx-1.10[${PYTHON_USEDEP}]
+ >=dev-python/pyyaml-3.12[${PYTHON_USEDEP}]
+ >=dev-python/six-1.10.0[${PYTHON_USEDEP}]
+ >=dev-python/stevedore-1.20.0[${PYTHON_USEDEP}]
+ app-emulation/qemu
+ sys-block/parted
+ sys-fs/multipath-tools
+ sys-fs/dosfstools
+ sys-apps/gptfdisk
+ !dev-python/dib-utils[${PYTHON_USEDEP}]"