summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTim Harder <radhermit@gentoo.org>2017-02-02 09:07:08 -0500
committerTim Harder <radhermit@gentoo.org>2017-02-02 09:07:53 -0500
commit1d20934855c8b80cb5ec55dcef14a93a79bfc36f (patch)
tree53ab28f3726c0a362235016c35586aad44ead36c
parentapp-vim/vim-rest-console: version bump to 2.6.0 (diff)
downloadgentoo-1d20934855c8b80cb5ec55dcef14a93a79bfc36f.tar.gz
gentoo-1d20934855c8b80cb5ec55dcef14a93a79bfc36f.tar.bz2
gentoo-1d20934855c8b80cb5ec55dcef14a93a79bfc36f.zip
app-text/yodl: version bump to 3.08.02
-rw-r--r--app-text/yodl/Manifest1
-rw-r--r--app-text/yodl/yodl-3.08.02.ebuild48
2 files changed, 49 insertions, 0 deletions
diff --git a/app-text/yodl/Manifest b/app-text/yodl/Manifest
index ec03c078b906..e1eaa6f9d36c 100644
--- a/app-text/yodl/Manifest
+++ b/app-text/yodl/Manifest
@@ -1 +1,2 @@
DIST yodl-3.08.01.tar.gz 283634 SHA256 958497939d9f3d1c6d0e2e74f7592d5a98f9ddb6f95c50c1247e41600d2765b7 SHA512 a88ab79657661262f4ccce4fd307ba41a05bcefbb534a2b5ed84115ab592ddf3ce883747aad5c028e73142ec91815ee86e1ae16ab9d319fe2045a2b0a08ab42c WHIRLPOOL aa9d9c0d58da0d5dbda3acd4f4f5fe5867873a23fd0f133404a6be9965001c1326714fc05296fa2a91912fe011391dd51819a40d2ddecfd7d99cfd8ac833339d
+DIST yodl-3.08.02.tar.gz 283890 SHA256 19264d7a1ed00edaa896e41b5aeacb722a4ca79dd6958731229f1bd1d1dd91bc SHA512 adad9f6235288f0ae6990c0dbba3cd7c8461172ae83231ca8fa113275d04ad20d3722e70f6f0ffcf072a19b4816e556b9b09227123516fc4a0170bc053b48b8e WHIRLPOOL ed3b5e0cc141f6b0c84191791f86af361cddf1753c2080eb8bc7f43e0eae78d329fd00b16a98bb14f1f2d93d91aab9b3a7947e7e065fcf2b4706fbfde5d9f868
diff --git a/app-text/yodl/yodl-3.08.02.ebuild b/app-text/yodl/yodl-3.08.02.ebuild
new file mode 100644
index 000000000000..f787158b0807
--- /dev/null
+++ b/app-text/yodl/yodl-3.08.02.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+inherit toolchain-funcs
+
+DESCRIPTION="Your Own Document Language: a pre-document language and tools to process it"
+HOMEPAGE="https://fbb-git.github.io/yodl/ https://github.com/fbb-git/yodl"
+SRC_URI="https://github.com/fbb-git/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc"
+
+DEPEND=">=dev-util/icmake-8.00.00"
+
+S=${WORKDIR}/${P}/${PN}
+
+src_prepare() {
+ sed -e "/DOC.* =/s/yodl\(-doc\)\?/${PF}/" \
+ -e "/COMPILER =/s/gcc/$(tc-getCC)/" \
+ -e "/CXX =/s/g++/$(tc-getCXX)/" \
+ -i INSTALL.im || die
+
+ sed -e "s/ar r /$(tc-getAR) r /" \
+ -e "s/ranlib/$(tc-getRANLIB)/" \
+ -i icmake/stdcompile || die
+
+ default
+}
+
+src_compile() {
+ ./build programs || die
+ ./build macros || die
+ ./build man || die
+ use doc && { ./build manual || die ; }
+}
+
+src_install() {
+ ./build install programs "${ED}" || die
+ ./build install macros "${ED}" || die
+ ./build install man "${ED}" || die
+ ./build install docs "${ED}" || die
+ use doc && { ./build install manual "${ED}" || die ; }
+}