summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBenda Xu <heroxbd@gentoo.org>2022-02-06 22:45:05 +0800
committerBenda Xu <heroxbd@gentoo.org>2022-02-06 22:48:15 +0800
commit1d2b6d182c6d7945ec5166803ca071f640ad994b (patch)
tree2b97a26b51545435df3151e28d37d5bc73838076
parentprofiles/arch/powerpc/ppc64: use stable mask stellarium[webengine] (diff)
downloadgentoo-1d2b6d182c6d7945ec5166803ca071f640ad994b.tar.gz
gentoo-1d2b6d182c6d7945ec5166803ca071f640ad994b.tar.bz2
gentoo-1d2b6d182c6d7945ec5166803ca071f640ad994b.zip
dev-libs/rocr-runtime: drop proprietary AQLProfile.
Patch out the error messages. Closes: https://bugs.gentoo.org/716948 Package-Manager: Portage-3.0.30, Repoman-3.0.3 Signed-off-by: Benda Xu <heroxbd@gentoo.org>
-rw-r--r--dev-libs/rocr-runtime/files/rocr-runtime-4.3.0_no-sqlprofiler.patch29
-rw-r--r--dev-libs/rocr-runtime/rocr-runtime-4.3.0.ebuild4
2 files changed, 32 insertions, 1 deletions
diff --git a/dev-libs/rocr-runtime/files/rocr-runtime-4.3.0_no-sqlprofiler.patch b/dev-libs/rocr-runtime/files/rocr-runtime-4.3.0_no-sqlprofiler.patch
new file mode 100644
index 000000000000..fdb34b75b2d2
--- /dev/null
+++ b/dev-libs/rocr-runtime/files/rocr-runtime-4.3.0_no-sqlprofiler.patch
@@ -0,0 +1,29 @@
+Index: ROCR-Runtime-rocm-4.3.0/src/core/runtime/amd_gpu_agent.cpp
+===================================================================
+--- src/core/runtime/amd_gpu_agent.cpp
++++ src/core/runtime/amd_gpu_agent.cpp
+@@ -861,11 +861,6 @@ hsa_status_t GpuAgent::GetInfo(hsa_agent
+ setFlag(HSA_EXTENSION_IMAGES);
+ }
+
+- if (os::LibHandle lib = os::LoadLib(kAqlProfileLib)) {
+- os::CloseLib(lib);
+- setFlag(HSA_EXTENSION_AMD_AQLPROFILE);
+- }
+-
+ setFlag(HSA_EXTENSION_AMD_PROFILER);
+
+ break;
+Index: ROCR-Runtime-rocm-4.3.0/src/core/runtime/hsa.cpp
+===================================================================
+--- src/core/runtime/hsa.cpp
++++ src/core/runtime/hsa.cpp
+@@ -471,7 +471,7 @@ hsa_status_t hsa_system_get_major_extens
+ return HSA_STATUS_SUCCESS;
+ }
+
+- if (extension == HSA_EXTENSION_AMD_AQLPROFILE) {
++ if (0) {
+ if (version_major != hsa_ven_amd_aqlprofile_VERSION_MAJOR) {
+ debug_print("aqlprofile API incompatible ver %d, current ver %d\n",
+ version_major, hsa_ven_amd_aqlprofile_VERSION_MAJOR);
diff --git a/dev-libs/rocr-runtime/rocr-runtime-4.3.0.ebuild b/dev-libs/rocr-runtime/rocr-runtime-4.3.0.ebuild
index c1f5f5a3a07b..2be1fb23feb6 100644
--- a/dev-libs/rocr-runtime/rocr-runtime-4.3.0.ebuild
+++ b/dev-libs/rocr-runtime/rocr-runtime-4.3.0.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2021 Gentoo Authors
+# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
@@ -33,6 +33,8 @@ DEPEND="${COMMON_DEPEND}
BDEPEND="app-editors/vim-core"
# vim-core is needed for "xxd"
+PATCHES=( "${FILESDIR}"/${PN}-4.3.0_no-sqlprofiler.patch )
+
src_prepare() {
# ... otherwise system llvm/clang is used ...
sed -e "s:find_package(Clang REQUIRED HINTS \${CMAKE_INSTALL_PREFIX}/llvm \${CMAKE_PREFIX_PATH}/llvm PATHS /opt/rocm/llvm ):find_package(Clang REQUIRED HINTS ${EPREFIX}/usr/lib/llvm/roc ):" -i image/blit_src/CMakeLists.txt || die