summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorConrad Kostecki <conikost@gentoo.org>2021-01-27 19:27:51 +0100
committerConrad Kostecki <conikost@gentoo.org>2021-01-27 19:34:50 +0100
commit1ee0871f7dc6c409477ba02b3df019bbe5410309 (patch)
tree7c5b426b75ce366baef8da6f8419169c22520b02
parentapp-benchmarks/wrk: drop old version (diff)
downloadgentoo-1ee0871f7dc6c409477ba02b3df019bbe5410309.tar.gz
gentoo-1ee0871f7dc6c409477ba02b3df019bbe5410309.tar.bz2
gentoo-1ee0871f7dc6c409477ba02b3df019bbe5410309.zip
app-benchmarks/sysbench: drop old version
Package-Manager: Portage-3.0.14, Repoman-3.0.2 Signed-off-by: Conrad Kostecki <conikost@gentoo.org>
-rw-r--r--app-benchmarks/sysbench/sysbench-1.0.20.ebuild72
1 files changed, 0 insertions, 72 deletions
diff --git a/app-benchmarks/sysbench/sysbench-1.0.20.ebuild b/app-benchmarks/sysbench/sysbench-1.0.20.ebuild
deleted file mode 100644
index d985c12d2a3d..000000000000
--- a/app-benchmarks/sysbench/sysbench-1.0.20.ebuild
+++ /dev/null
@@ -1,72 +0,0 @@
-# Copyright 1999-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-PYTHON_COMPAT=( python3_{6..9} )
-
-inherit autotools python-single-r1
-
-DESCRIPTION="A scriptable multi-threaded benchmark tool based on LuaJIT"
-HOMEPAGE="https://github.com/akopytov/sysbench"
-SRC_URI="https://github.com/akopytov/sysbench/archive/${PV}.tar.gz -> ${P}.tar.gz"
-
-LICENSE="GPL-2+"
-SLOT="0"
-KEYWORDS="amd64 ~arm ~arm64 x86"
-IUSE="+aio attachsql drizzle +largefile mysql postgres test"
-REQUIRED_USE="${PYTHON_REQUIRED_USE}"
-RESTRICT="!test? ( test )"
-
-RDEPEND="
- dev-lang/luajit:2
- aio? ( dev-libs/libaio )
- mysql? ( dev-db/mysql-connector-c:= )
- postgres? ( dev-db/postgresql:= )
- test? ( ${PYTHON_DEPS} )
-"
-DEPEND="
- dev-libs/concurrencykit
- dev-libs/libxslt
- test? (
- $(python_gen_cond_dep '
- dev-util/cram[${PYTHON_USEDEP}]
- ')
- )
- ${RDEPEND}
-"
-BDEPEND="
- sys-devel/libtool
- virtual/pkgconfig
-"
-
-src_prepare() {
- default
-
- rm -r third_party/{concurrency_kit/ck,cram,luajit/luajit} || die
-
- eautoreconf
-}
-
-src_configure() {
- # Current versions of 'dev-db/oracle-instantclient' aren't supported.
- # See: https://github.com/akopytov/sysbench/issues/390.
- local myeconfargs=(
- --disable-rpath
- $(use_enable aio)
- $(use_enable largefile)
- $(use_with attachsql)
- $(use_with drizzle)
- $(use_with mysql)
- $(use_with postgres pgsql)
- --with-system-ck
- --with-system-luajit
- --without-oracle
- )
-
- econf "${myeconfargs[@]}"
-}
-
-src_test() {
- emake check test
-}