summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAmadeusz Piotr Żołnowski <aidecoe@gentoo.org>2018-10-24 23:23:19 +0100
committerAmadeusz Piotr Żołnowski <aidecoe@gentoo.org>2018-10-24 23:26:59 +0100
commit1efa3958413cda09142e12371e54032a9c442e17 (patch)
tree14c15f04afc9cc1a3d1b79e4f82570a52175d7aa
parentapp-admin/puppet: 5.5.7 bump (diff)
downloadgentoo-1efa3958413cda09142e12371e54032a9c442e17.tar.gz
gentoo-1efa3958413cda09142e12371e54032a9c442e17.tar.bz2
gentoo-1efa3958413cda09142e12371e54032a9c442e17.zip
dev-lang/rebar-bin: Add new package
Fetch and install prebuilt binary as it's way easier than building this from source. Bug: https://bugs.gentoo.org/628876 Signed-off-by: Amadeusz Piotr Żołnowski <aidecoe@gentoo.org>
-rw-r--r--dev-util/rebar-bin/Manifest1
-rw-r--r--dev-util/rebar-bin/metadata.xml28
-rw-r--r--dev-util/rebar-bin/rebar-bin-3.6.2.ebuild31
3 files changed, 60 insertions, 0 deletions
diff --git a/dev-util/rebar-bin/Manifest b/dev-util/rebar-bin/Manifest
new file mode 100644
index 000000000000..da7580477903
--- /dev/null
+++ b/dev-util/rebar-bin/Manifest
@@ -0,0 +1 @@
+DIST rebar3 694889 BLAKE2B 3a8f5562a0c984caf5d7b3ba1063a90bf110a60cea316eaf88f5199b890e186f85193dc0302b36dc31051d3552912c8d1582f563f989df97ee28364a3f47512a SHA512 8fb5c7737d70fc7a706b1e124ab660550e8637da9258338016ab2e260f1c6d662548ef723705cd18210050d052e79945578623d9e9892e08dbfdb9cb04fd89fb
diff --git a/dev-util/rebar-bin/metadata.xml b/dev-util/rebar-bin/metadata.xml
new file mode 100644
index 000000000000..56b1d345d115
--- /dev/null
+++ b/dev-util/rebar-bin/metadata.xml
@@ -0,0 +1,28 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>aidecoe@gentoo.org</email>
+ <name>Amadeusz Żołnowski</name>
+ </maintainer>
+ <longdescription lang="en">
+ Rebar3 is an Erlang tool that makes it easy to create, develop, and
+ release Erlang libraries, applications, and systems in a repeatable
+ manner.
+
+ Rebar3 will:
+
+ - respect and enforce standard Erlang/OTP conventions for project
+ structure so they are easily reusable by the community;
+ - manage source dependencies and Erlang packages while ensuring
+ repeatable builds;
+ - handle build artifacts, paths, and libraries such that standard
+ development tools can be used without a headache;
+ - adapt to projects of all sizes on almost any platform;
+ - treat documentation as a feature, and errors or lack of documentation
+ as a bug.
+ </longdescription>
+ <upstream>
+ <remote-id type="github">erlang/rebar3</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-util/rebar-bin/rebar-bin-3.6.2.ebuild b/dev-util/rebar-bin/rebar-bin-3.6.2.ebuild
new file mode 100644
index 000000000000..9835d50cdf22
--- /dev/null
+++ b/dev-util/rebar-bin/rebar-bin-3.6.2.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+MY_PN=${P#-bin}
+MY_P=${MY_PN}-${PV}
+
+DESCRIPTION="A sophisticated build-tool for Erlang projects that follows OTP principles"
+HOMEPAGE="https://github.com/erlang/rebar3"
+
+SRC_URI="https://github.com/erlang/rebar3/releases/download/${PV}/rebar3"
+
+LICENSE="Apache-2.0"
+SLOT="3"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="dev-lang/erlang"
+DEPEND=""
+
+S="${WORKDIR}"
+
+QA_PREBUILT="/usr/bin/rebar3"
+
+src_unpack() {
+ cp -v "${DISTDIR}/${A}" "${S}/" || die
+}
+
+src_install() {
+ dobin rebar3
+}