summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSébastien Fabbro <bicatali@gentoo.org>2016-12-31 23:24:58 +0000
committerSébastien Fabbro <bicatali@gentoo.org>2017-01-02 16:13:45 +0000
commit1f1d0d72b8a6afea69473303c5002ab489e9852c (patch)
treefda4440f9a9faab57316e2d60bb9fde76f9f8d09
parentsci-libs/sundials: initial import (diff)
downloadgentoo-1f1d0d72b8a6afea69473303c5002ab489e9852c.tar.gz
gentoo-1f1d0d72b8a6afea69473303c5002ab489e9852c.tar.bz2
gentoo-1f1d0d72b8a6afea69473303c5002ab489e9852c.zip
dev-util/bazel: version bump
Switched to the "dist" version to allow bootstraping. Package-Manager: Portage-2.3.3, Repoman-2.3.1
-rw-r--r--dev-util/bazel/Manifest1
-rw-r--r--dev-util/bazel/bazel-0.4.3.ebuild69
2 files changed, 70 insertions, 0 deletions
diff --git a/dev-util/bazel/Manifest b/dev-util/bazel/Manifest
index ef34529106f0..bc68b9dbb891 100644
--- a/dev-util/bazel/Manifest
+++ b/dev-util/bazel/Manifest
@@ -1,2 +1,3 @@
DIST bazel-0.3.2.tar.gz 145095554 SHA256 9692ac3318a40e8a0530f68bbfc473ae5f6a4a5c0fe08d2f88612ca4d40ba54a SHA512 975faf5830e952bea5d3fa8d127e0d5d9654af83f1fba0d7e26f9e1c2c71dd58542efea2382b0c52c9fd24ae43ec66a3ca7451309f02fd65c0896bbbdb3c79f5 WHIRLPOOL ab487f84e8126ab2badfd84d1fe757170900fbb2f88dff79d6867fb694bbb8adf226b7b89bfdb9cf207595bfd235583a54b8102a1a009f58be7bd3be039e1aaa
DIST bazel-0.4.0.tar.gz 159192903 SHA256 2370649043b5b3c407016a74946d5c443dd5c8ba43c1ffe28b83553983e5057c SHA512 be5c91b8c8e7061c4992d477d9ffa7eaf11fcc064a54ae2db7ccf8fa931223e758288876b8c191f3d4ddf16dd1858b2c99ce1ef58da71dc2edbcc57b2036f871 WHIRLPOOL 72d720b57241bf5a4769d3e84d6dee787aed9b4bb32353a32f2a3580cd74b6185db2c002c1e403246c511af7072ce24ba3cb71a12fa426f97faf4dbae9dff9d1
+DIST bazel-0.4.3-dist.zip 90363167 SHA256 cbd2ab580181c17317cf18b2bf825bcded2d97cab01cd5b5fe4f4d520b64f90f SHA512 fd5886c5951c71181a73bd7efd66a09606f372e9f9af01a62436bfb3fb4f1e37095d1d11a567856b6e6649afddaae436df9f8aaa03a436e3427b2ee60a9b0370 WHIRLPOOL 367ea40bd5df22c5f8b2d7c77c176d9d23c301a7a28c39afd241888ed0de611fe3eccc2402173b3ea98cc980cd18208d4d8b452040910c4cc3d47797e646a58b
diff --git a/dev-util/bazel/bazel-0.4.3.ebuild b/dev-util/bazel/bazel-0.4.3.ebuild
new file mode 100644
index 000000000000..09ffca6720cc
--- /dev/null
+++ b/dev-util/bazel/bazel-0.4.3.ebuild
@@ -0,0 +1,69 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+inherit bash-completion-r1 java-pkg-2
+
+DESCRIPTION="Fast and correct automated build system"
+HOMEPAGE="http://bazel.io/"
+SRC_URI="https://github.com/bazelbuild/bazel/releases/download/${PV}/${P}-dist.zip"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="examples tools zsh-completion"
+# strip corrupts the bazel binary
+RESTRICT="strip"
+RDEPEND="virtual/jdk:1.8"
+DEPEND="${RDEPEND}
+ app-arch/unzip"
+
+S="${WORKDIR}"
+
+pkg_setup() {
+ echo ${PATH} | grep -q ccache && \
+ ewarn "${PN} usually fails to compile with ccache, you have been warned"
+ java-pkg-2_pkg_setup
+}
+
+src_compile() {
+ VERBOSE=yes ./compile.sh || die
+ # Use standalone strategy to deactivate the bazel sandbox, since it
+ # conflicts with FEATURES=sandbox.
+ echo "build --verbose_failures --spawn_strategy=standalone --genrule_strategy=standalone" \
+ > "${T}/bazelrc" || die
+ output/bazel --bazelrc="${T}/bazelrc" build scripts:bazel-complete.bash || die
+}
+
+src_test() {
+ output/bazel test \
+ --verbose_failures \
+ --spawn_strategy=standalone \
+ --genrule_strategy=standalone \
+ --verbose_test_summary \
+ examples/cpp:hello-success_test || die
+}
+
+src_install() {
+ output/bazel shutdown
+ dobin output/bazel
+ newbashcomp bazel-bin/scripts/bazel-complete.bash ${PN}
+ if use zsh-completion ; then
+ insinto /usr/share/zsh/site-functions
+ doins scripts/zsh_completion/_bazel
+ fi
+ if use examples; then
+ docinto examples
+ doins -r examples/*
+ docompress -x /usr/share/doc/${PF}/examples
+ fi
+ # could really build tools but I don't know which ones
+ # are actually used
+ if use tools; then
+ docinto tools
+ doins -r tools/*
+ docompress -x /usr/share/doc/${PF}/tools
+ fi
+}