summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorZero_Chaos <zerochaos@gentoo.org>2018-11-21 10:51:28 -0500
committerZero_Chaos <zerochaos@gentoo.org>2018-11-21 13:20:45 -0500
commit1f295ca9116ab000b0f701f58690974dbe7ea1ba (patch)
treeaa244eadd0cb2ed6f7cc7f1cb14ddd123468fe32
parentdev-ruby/metasploit_data_models: bump, x86 (diff)
downloadgentoo-1f295ca9116ab000b0f701f58690974dbe7ea1ba.tar.gz
gentoo-1f295ca9116ab000b0f701f58690974dbe7ea1ba.tar.bz2
gentoo-1f295ca9116ab000b0f701f58690974dbe7ea1ba.zip
dev-ruby/metasploit-credential: bump, x86
Package-Manager: Portage-2.3.52, Repoman-2.3.12 Signed-off-by: Rick Farina <zerochaos@gentoo.org>
-rw-r--r--dev-ruby/metasploit-credential/Manifest1
-rw-r--r--dev-ruby/metasploit-credential/metasploit-credential-2.0.14.ebuild28
-rw-r--r--dev-ruby/metasploit-credential/metasploit-credential-2.0.8.ebuild4
3 files changed, 31 insertions, 2 deletions
diff --git a/dev-ruby/metasploit-credential/Manifest b/dev-ruby/metasploit-credential/Manifest
index cae75fe92341..0b2f5ac8d412 100644
--- a/dev-ruby/metasploit-credential/Manifest
+++ b/dev-ruby/metasploit-credential/Manifest
@@ -1 +1,2 @@
+DIST metasploit-credential-2.0.14.gem 110592 BLAKE2B 09f3eee0f288ab26695177b014b98dc871f6f009f34aaad4fbd7dfcda8acc63f75524fe7d181b1dccca863cc83eb50f249e0c07cbb0f07e9c79856a4389cdcd9 SHA512 66670fc89dc61d6d32577c9b46dc6ddfab15b9c0118ba15cc7398e10ec8de63cd7150fbfaddbd01a573ead6d98619dd9c19a5835be58baaa1fc4a9c777839b00
DIST metasploit-credential-2.0.8.gem 110080 BLAKE2B 3963d4beb8ad12b42e8e79ae51016a74e8a0de6a1446817da16301ccc9756564dfba2847ebe9944cd563e4f113a6be3c9e96ee4240dc38c855fd47e81b145d74 SHA512 dac081be5347edd9f96e2e4956824e5982a1ab1ef13dd3113a1a5faf70e4dde570bb42ec404ab503b72ababbdae291d4b929946288452f712bf6a795177e1357
diff --git a/dev-ruby/metasploit-credential/metasploit-credential-2.0.14.ebuild b/dev-ruby/metasploit-credential/metasploit-credential-2.0.14.ebuild
new file mode 100644
index 000000000000..5220d95e6005
--- /dev/null
+++ b/dev-ruby/metasploit-credential/metasploit-credential-2.0.14.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2018 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+USE_RUBY="ruby24"
+
+RUBY_FAKEGEM_RECIPE_DOC="rdoc"
+
+inherit ruby-fakegem
+
+RUBY_FAKEGEM_EXTRAINSTALL="app config db spec"
+
+DESCRIPTION="Code for modeling and managing credentials in Metasploit"
+HOMEPAGE="https://github.com/rapid7/metasploit-credential"
+
+LICENSE="BSD"
+SLOT="${PV}"
+KEYWORDS="~amd64 ~arm ~x86"
+IUSE=""
+RESTRICT=test
+
+ruby_add_rdepend "dev-ruby/metasploit-concern:2.0
+ <=dev-ruby/metasploit_data_models-3.0.0:*
+ >=dev-ruby/metasploit-model-1.0.0
+ dev-ruby/rubyzip:1
+ dev-ruby/rubyntlm
+ >=dev-ruby/railties-4.2.6:4.2
+ dev-ruby/pg:*"
diff --git a/dev-ruby/metasploit-credential/metasploit-credential-2.0.8.ebuild b/dev-ruby/metasploit-credential/metasploit-credential-2.0.8.ebuild
index 2f53cf16491e..0488094fc921 100644
--- a/dev-ruby/metasploit-credential/metasploit-credential-2.0.8.ebuild
+++ b/dev-ruby/metasploit-credential/metasploit-credential-2.0.8.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2017 Gentoo Foundation
+# Copyright 1999-2018 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=6
@@ -25,4 +25,4 @@ ruby_add_rdepend "dev-ruby/metasploit-concern:2.0
dev-ruby/rubyzip:1
dev-ruby/rubyntlm
>=dev-ruby/railties-4.2.6:4.2
- dev-ruby/pg"
+ dev-ruby/pg:*"