summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLars Wendler <polynomial-c@gentoo.org>2017-05-09 09:55:17 +0200
committerLars Wendler <polynomial-c@gentoo.org>2017-05-09 09:56:16 +0200
commit1f362f4f4744ccb668f63ea34f521e3671acd99e (patch)
treefe44398b33bbe95102792da0a6ffaa0ae427f309
parentdev-util/kyua-0.13-r0: add ~alpha keyword (diff)
downloadgentoo-1f362f4f4744ccb668f63ea34f521e3671acd99e.tar.gz
gentoo-1f362f4f4744ccb668f63ea34f521e3671acd99e.tar.bz2
gentoo-1f362f4f4744ccb668f63ea34f521e3671acd99e.zip
net-libs/libetpan: Security bump to version 1.8 (bug #617936).
Package-Manager: Portage-2.3.5, Repoman-2.3.2
-rw-r--r--net-libs/libetpan/Manifest1
-rw-r--r--net-libs/libetpan/libetpan-1.8.ebuild75
2 files changed, 76 insertions, 0 deletions
diff --git a/net-libs/libetpan/Manifest b/net-libs/libetpan/Manifest
index 7be5769d863e..319b687252e7 100644
--- a/net-libs/libetpan/Manifest
+++ b/net-libs/libetpan/Manifest
@@ -1,3 +1,4 @@
DIST libetpan-1.6.tar.gz 6144117 SHA256 7962b1f9445be24d1eb72daddabaebb427074c14a50e9dad0cebdec044c71e17 SHA512 e3f19cfe231e8cadbb6cba3a765611e3aaeb260fa78e05cea1153a59015abe547c0f3a8b84c6b41cbbd17d04a4c7ab7b14d1b1b44a1a4b24ac124cb200a191a5 WHIRLPOOL b72a50513dbd55898e79b14a53088277b12ae7ac911ab0a9692d47f85dadd1b80a9ba616bd7a2beb89d9406940f4edf24cabf93aabef0cd27d6de6bef4e29a40
DIST libetpan-1.7.2.tar.gz 6186628 SHA256 32797282a420f3174f4a679548e20fa2bb4acb404b827d62c2f44d3de4eb3120 SHA512 b7b7c201d65bc2ad595b93d310d2569ca3bf61e599010e0f46a7e776da6ebc6a897df6e073a4878cb134d6d4bec6ea65b2a3e02d44b60f9045b5aa58b689cdca WHIRLPOOL 695b7104e79b9cfd0f482f686ad451aca319709b7455b14d8bdd3b788eb2c7e2c4a461c9fec2e4a9d4ffcc9fc1801113d8259524d9217c907fde0a2b631ce36f
DIST libetpan-1.7.tar.gz 6184289 SHA256 47d0c049d8adcdcfd0698e9f1fcb85416b0b2f476eed1f52aae72c2883cf05b0 SHA512 b90c46f6692df7a7889be68f5712a6b6d58ef1931edb82674da2cb6690c2150c935ca782fd32c1567c31cdff629261bd1ba23921b12431d781a086729489573e WHIRLPOOL b6c286a0554ecf4ad3c0d09dd45d1892a665bdc4eed4e19b65745de3a6195351cccef51da6447f34d57a29dacd01bbb16067d30911b837db914016ddb7ab2e87
+DIST libetpan-1.8.tar.gz 6188927 SHA256 4e67a7b4abadcf3cc16fa16e1621a68e54d489dadfd9a7d1f960c172e953b6eb SHA512 a5e97998803cc56dbd54356153c8579b52a9675fe95fbf642c3158215428d9d2cb30c4e0060c5f4dd760634fff5b1c2a32ce4bb70a5f2bc6398a071ce95e1efd WHIRLPOOL 41e7e184a3f1789726055cb8bc9941057eb0c4b7bf6057dd94519b46905c1dd9fa45c403fa05c45eaa2b36a03af74b35097348ed471b9428f6bf4e864dbdd791
diff --git a/net-libs/libetpan/libetpan-1.8.ebuild b/net-libs/libetpan/libetpan-1.8.ebuild
new file mode 100644
index 000000000000..57ea86199457
--- /dev/null
+++ b/net-libs/libetpan/libetpan-1.8.ebuild
@@ -0,0 +1,75 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+inherit autotools
+
+DESCRIPTION="A portable, efficient middleware for different kinds of mail access"
+HOMEPAGE="http://libetpan.sourceforge.net/"
+SRC_URI="https://github.com/dinhviethoa/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~mips ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos"
+IUSE="berkdb debug gnutls ipv6 liblockfile libressl sasl ssl static-libs"
+
+DEPEND="sys-libs/zlib
+ berkdb? ( sys-libs/db:= )
+ ssl? (
+ gnutls? ( net-libs/gnutls:= )
+ !gnutls? (
+ !libressl? ( dev-libs/openssl:0= )
+ libressl? ( dev-libs/libressl:0= )
+ )
+ )
+ sasl? ( dev-libs/cyrus-sasl:2 )
+ liblockfile? ( net-libs/liblockfile )"
+RDEPEND="${DEPEND}"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-1.0-nonnull.patch
+)
+
+pkg_setup() {
+ if use gnutls && ! use ssl ; then
+ ewarn "You have \"gnutls\" USE flag enabled but \"ssl\" USE flag disabled!"
+ ewarn "No ssl support will be available in ${PN}."
+ fi
+}
+
+src_prepare() {
+ default
+
+ sed -i \
+ -e "s/-O2 -g//" \
+ configure.ac
+
+ eautoreconf
+}
+
+src_configure() {
+ # in Prefix emake uses SHELL=${BASH}, export CONFIG_SHELL to the same so
+ # libtool recognises it as valid shell (bug #300211)
+ use prefix && export CONFIG_SHELL=${BASH}
+ # The configure script contains an error, in that it doesn't check the
+ # argument of --enable-{debug,optim}, hence --disable-debug results in
+ # --enable-debug=no, which isn't checked and debugging flags are blindly
+ # injected. So, avoid passing --disable-debug when we don't need it.
+ local myeconfargs=(
+ $(usex debug '--enable-debug' '')
+ $(use_enable berkdb db)
+ $(use_with sasl)
+ $(use_enable ipv6)
+ $(use_enable liblockfile lockfile)
+ $(usex ssl "$(use_with gnutls) $(use_with !gnutls openssl)" '--without-gnutls --without-openssl')
+ $(use_enable static-libs static)
+ )
+ econf "${myeconfargs[@]}"
+}
+
+src_install() {
+ default
+ if ! use static-libs ; then
+ find "${ED}" \( -name "*.a" -o -name "*.la" \) -delete || die
+ fi
+}