summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTed Tanberry <ted.tanberry@gmail.com>2015-10-10 22:18:12 +0200
committerJustin Lecher <jlec@gentoo.org>2015-10-14 14:47:58 +0200
commit1f3b594dde68ff07ecf429b10b2501660adc0f1d (patch)
treea76b5cd521eb202ce500009a71609b878b887503
parentsci-biology/bowtie: include descriptive header in patch (diff)
downloadgentoo-1f3b594dde68ff07ecf429b10b2501660adc0f1d.tar.gz
gentoo-1f3b594dde68ff07ecf429b10b2501660adc0f1d.tar.bz2
gentoo-1f3b594dde68ff07ecf429b10b2501660adc0f1d.zip
sci-biology/bowtie: remove REQUIRED_USE
When SSE2 support is not explicitly enabled, the user is informed by erroring out instead of portage recommending enabling cpu flags.
-rw-r--r--sci-biology/bowtie/bowtie-2.2.6.ebuild8
1 files changed, 7 insertions, 1 deletions
diff --git a/sci-biology/bowtie/bowtie-2.2.6.ebuild b/sci-biology/bowtie/bowtie-2.2.6.ebuild
index 50aca7e60d06..c15de562f28d 100644
--- a/sci-biology/bowtie/bowtie-2.2.6.ebuild
+++ b/sci-biology/bowtie/bowtie-2.2.6.ebuild
@@ -15,7 +15,6 @@ SLOT="2"
KEYWORDS="~amd64 ~x86"
IUSE="examples cpu_flags_x86_sse2 tbb"
-REQUIRED_USE="cpu_flags_x86_sse2"
RDEPEND="dev-lang/perl"
DEPEND="${RDEPEND}
@@ -27,6 +26,13 @@ S="${WORKDIR}/${PN}2-${PV}"
DOCS=( AUTHORS NEWS TUTORIAL )
HTML_DOCS=( doc/{manual.html,style.css} )
+pkg_pretend() {
+ if ! use cpu_flags_x86_sse2 ; then
+ eerror "This package requires a CPU supporting the SSE2 instruction set."
+ die "SSE2 support missing"
+ fi
+}
+
src_compile() {
emake \
CC="$(tc-getCC)" \