summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Gilbert <floppym@gentoo.org>2020-02-06 10:24:08 -0500
committerMike Gilbert <floppym@gentoo.org>2020-02-06 10:24:08 -0500
commit1f550c46e58f6d48b6072f50097e1c6d44a30485 (patch)
tree9f8e1653438e5e289c6bc235270d6db70bb6f2a4
parentdev-ruby/request_store: add ruby27 (diff)
downloadgentoo-1f550c46e58f6d48b6072f50097e1c6d44a30485.tar.gz
gentoo-1f550c46e58f6d48b6072f50097e1c6d44a30485.tar.bz2
gentoo-1f550c46e58f6d48b6072f50097e1c6d44a30485.zip
sys-apps/systemd: fix segfault in systemd-sysctl
Closes: https://bugs.gentoo.org/708462 Package-Manager: Portage-2.3.86_p1, Repoman-2.3.20_p43 Signed-off-by: Mike Gilbert <floppym@gentoo.org>
-rw-r--r--sys-apps/systemd/files/245-rc1-sysctl-segfault.patch23
-rw-r--r--sys-apps/systemd/systemd-245_rc1-r1.ebuild (renamed from sys-apps/systemd/systemd-245_rc1.ebuild)1
2 files changed, 24 insertions, 0 deletions
diff --git a/sys-apps/systemd/files/245-rc1-sysctl-segfault.patch b/sys-apps/systemd/files/245-rc1-sysctl-segfault.patch
new file mode 100644
index 000000000000..7618b2deba5e
--- /dev/null
+++ b/sys-apps/systemd/files/245-rc1-sysctl-segfault.patch
@@ -0,0 +1,23 @@
+From db99904bc8482efe556bb010a8b203a3e60ee37f Mon Sep 17 00:00:00 2001
+From: Yu Watanabe <watanabe.yu+github@gmail.com>
+Date: Thu, 6 Feb 2020 19:13:11 +0900
+Subject: [PATCH] sysctl: fix segfault
+
+Fixes #14801.
+---
+ src/sysctl/sysctl.c | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/src/sysctl/sysctl.c b/src/sysctl/sysctl.c
+index bbcf0c43235..0cdb740d218 100644
+--- a/src/sysctl/sysctl.c
++++ b/src/sysctl/sysctl.c
+@@ -257,7 +257,7 @@ static int parse_file(OrderedHashmap **sysctl_options, const char *path, bool ig
+
+ existing = ordered_hashmap_get(*sysctl_options, p);
+ if (existing) {
+- if (streq(value, existing->value)) {
++ if (streq_ptr(value, existing->value)) {
+ existing->ignore_failure = existing->ignore_failure || ignore_failure;
+ continue;
+ }
diff --git a/sys-apps/systemd/systemd-245_rc1.ebuild b/sys-apps/systemd/systemd-245_rc1-r1.ebuild
index 7bb75c3ee621..e889210fcbd7 100644
--- a/sys-apps/systemd/systemd-245_rc1.ebuild
+++ b/sys-apps/systemd/systemd-245_rc1-r1.ebuild
@@ -186,6 +186,7 @@ src_prepare() {
# Add local patches here
PATCHES+=(
"${FILESDIR}"/245-rc1-network-debug.patch
+ "${FILESDIR}"/245-rc1-sysctl-segfault.patch
)
if ! use vanilla; then