summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSergey Popov <pinkbyte@gentoo.org>2018-02-20 14:24:22 +0300
committerSergey Popov <pinkbyte@gentoo.org>2018-02-20 14:24:22 +0300
commit1f64762ca074542f9da3dc71e84b0d68c75dca06 (patch)
tree308d33eeb25ce1849a52116c76f18ad7e662eb85
parentnet-misc/quagga: drop old (diff)
downloadgentoo-1f64762ca074542f9da3dc71e84b0d68c75dca06.tar.gz
gentoo-1f64762ca074542f9da3dc71e84b0d68c75dca06.tar.bz2
gentoo-1f64762ca074542f9da3dc71e84b0d68c75dca06.zip
net-misc/quagga: version bump
Gentoo-Bug: 647788 Package-Manager: Portage-2.3.19, Repoman-2.3.6
-rw-r--r--net-misc/quagga/Manifest1
-rw-r--r--net-misc/quagga/quagga-1.2.4.ebuild135
2 files changed, 136 insertions, 0 deletions
diff --git a/net-misc/quagga/Manifest b/net-misc/quagga/Manifest
index b36c365ebb42..ba7b0e59f6fa 100644
--- a/net-misc/quagga/Manifest
+++ b/net-misc/quagga/Manifest
@@ -1,2 +1,3 @@
DIST ht-20040304-classless-bgp.patch 1581 BLAKE2B 64df9a86c235c4f6d35be0f19fe1b056958ae2fa28bd2e9e8d9902e569a8f9a2925ba45396bb92e345bfcaf8ca1ef9136a433c615a5bd12a279e7c062939549a SHA512 3df102d8ab88aaee1f109a2310602d6f734f2268252e5e42df752df7db7abeac526e969289481c4abfe905dcd41c35dee65196c48ac320fe9d083305451476e8
DIST quagga-1.2.2.tar.gz 2986142 BLAKE2B 2c2326e015ed4ce7364a960b56108bbd04c184b7cd78dca0cac528cd2869e65e6efbd40c303ce2b6eb29eed809e8b384baa36329b365ae6799a5b25fa21daa4c SHA512 861f6524bcdc01d1a895762bf1904744c12ae4dfc7c3583ecb7e55b3978c98187bde76df0ff85093c744139be9d5cf324fec75b5ba86cf1fdbce70d923710d14
+DIST quagga-1.2.4.tar.gz 2925847 BLAKE2B e0e8d8b8e2243bc5cecc2e66d26040780f839414a16fb8a719d25a6fe1c29dc8545a92700a3758100715e1efb3d874584903885af51ef9f5d88c4a02d02dbc74 SHA512 3e72440bcccfd3c1a449a62b7ff8623441256399a2bee0a39fa0a19694a5a78ac909c5c2128a24735bc034ea8b0811827293b480a2584a3a4c8ae36be9cf1fcd
diff --git a/net-misc/quagga/quagga-1.2.4.ebuild b/net-misc/quagga/quagga-1.2.4.ebuild
new file mode 100644
index 000000000000..eb16f21271dd
--- /dev/null
+++ b/net-misc/quagga/quagga-1.2.4.ebuild
@@ -0,0 +1,135 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+CLASSLESS_BGP_PATCH=ht-20040304-classless-bgp.patch
+
+inherit autotools eutils flag-o-matic multilib pam readme.gentoo-r1 systemd tmpfiles user
+
+DESCRIPTION="A free routing daemon replacing Zebra supporting RIP, OSPF and BGP"
+HOMEPAGE="http://quagga.net/"
+SRC_URI="mirror://nongnu/${PN}/${P}.tar.gz
+ bgpclassless? ( http://hasso.linux.ee/stuff/patches/quagga/${CLASSLESS_BGP_PATCH} )"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ppc ~s390 ~sparc ~x86"
+
+IUSE="bgpclassless caps fpm doc elibc_glibc ipv6 multipath nhrpd ospfapi pam protobuf +readline snmp tcp-zebra test"
+
+COMMON_DEPEND="
+ caps? ( sys-libs/libcap )
+ nhrpd? ( net-dns/c-ares:0= )
+ protobuf? ( dev-libs/protobuf-c:0= )
+ readline? (
+ sys-libs/readline:0=
+ pam? ( sys-libs/pam )
+ )
+ snmp? ( net-analyzer/net-snmp )
+ !elibc_glibc? ( dev-libs/libpcre )"
+DEPEND="${COMMON_DEPEND}
+ sys-apps/gawk
+ sys-devel/libtool:2
+ test? ( dev-util/dejagnu )"
+RDEPEND="${COMMON_DEPEND}
+ sys-apps/iproute2"
+
+PATCHES=(
+ "${FILESDIR}/${PN}-0.99.22.4-ipctl-forwarding.patch"
+)
+
+DISABLE_AUTOFORMATTING=1
+DOC_CONTENTS="Sample configuration files can be found in /usr/share/doc/${PF}/samples
+You have to create config files in /etc/quagga before
+starting one of the daemons.
+
+You can pass additional options to the daemon by setting the EXTRA_OPTS
+variable in their respective file in /etc/conf.d"
+
+pkg_setup() {
+ enewgroup quagga
+ enewuser quagga -1 -1 /var/empty quagga
+}
+
+src_prepare() {
+ # Classless prefixes for BGP
+ # http://hasso.linux.ee/doku.php/english:network:quagga
+ use bgpclassless && eapply -p0 "${DISTDIR}/${CLASSLESS_BGP_PATCH}"
+
+ eapply "${PATCHES[@]}"
+ eapply_user
+ eautoreconf
+}
+
+src_configure() {
+ append-flags -fno-strict-aliasing
+
+ # do not build PDF docs
+ export ac_cv_prog_PDFLATEX=no
+ export ac_cv_prog_LATEXMK=no
+
+ econf \
+ --enable-exampledir=/usr/share/doc/${PF}/samples \
+ --enable-irdp \
+ --enable-isisd \
+ --enable-isis-topology \
+ --enable-pimd \
+ --enable-user=quagga \
+ --enable-group=quagga \
+ --enable-vty-group=quagga \
+ --with-cflags="${CFLAGS}" \
+ --with-pkg-extra-version="-gentoo" \
+ --sysconfdir=/etc/quagga \
+ --localstatedir=/run/quagga \
+ --disable-static \
+ $(use_enable caps capabilities) \
+ $(usex snmp '--enable-snmp' '' '' '') \
+ $(use_enable !elibc_glibc pcreposix) \
+ $(use_enable fpm) \
+ $(use_enable tcp-zebra) \
+ $(use_enable doc) \
+ $(usex multipath $(use_enable multipath) '' '=0' '') \
+ $(usex ospfapi '--enable-ospfclient' '' '' '') \
+ $(use_enable readline vtysh) \
+ $(use_with pam libpam) \
+ $(use_enable nhrpd) \
+ $(use_enable protobuf) \
+ $(use_enable ipv6 ripngd) \
+ $(use_enable ipv6 ospf6d) \
+ $(use_enable ipv6 rtadv)
+}
+
+src_install() {
+ default
+ prune_libtool_files
+ readme.gentoo_create_doc
+
+ keepdir /etc/quagga
+ fowners root:quagga /etc/quagga
+ fperms 0770 /etc/quagga
+
+ # Install systemd-related stuff, bug #553136
+ dotmpfiles "${FILESDIR}/systemd/quagga.conf"
+ systemd_dounit "${FILESDIR}/systemd/zebra.service"
+
+ # install zebra as a file, symlink the rest
+ newinitd "${FILESDIR}"/quagga-services.init.3 zebra
+
+ for service in bgpd isisd ospfd pimd ripd $(use ipv6 && echo ospf6d ripngd) $(use nhrpd && echo nhrpd); do
+ dosym zebra /etc/init.d/${service}
+ systemd_dounit "${FILESDIR}/systemd/${service}.service"
+ done
+
+ use readline && use pam && newpamd "${FILESDIR}/quagga.pam" quagga
+
+ insinto /etc/logrotate.d
+ newins redhat/quagga.logrotate quagga
+}
+
+pkg_postinst() {
+ # Path for PIDs before first reboot should be created here, bug #558194
+ tmpfiles_process quagga.conf
+
+ readme.gentoo_print_elog
+}