summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Thode <prometheanfire@gentoo.org>2017-02-01 15:54:53 -0600
committerMatthew Thode <prometheanfire@gentoo.org>2017-02-01 15:54:53 -0600
commit1f7893e85bf5c6e08d5f7eecec92b7bd945e3625 (patch)
treee9f9613f2a8f285c70d9c5a7058260019bfa2e40
parentsys-cluster/heat: bup (diff)
downloadgentoo-1f7893e85bf5c6e08d5f7eecec92b7bd945e3625.tar.gz
gentoo-1f7893e85bf5c6e08d5f7eecec92b7bd945e3625.tar.bz2
gentoo-1f7893e85bf5c6e08d5f7eecec92b7bd945e3625.zip
media-sound/spotify: bup
Package-Manager: portage-2.3.3
-rw-r--r--media-sound/spotify/Manifest2
-rw-r--r--media-sound/spotify/spotify-1.0.48.ebuild118
2 files changed, 120 insertions, 0 deletions
diff --git a/media-sound/spotify/Manifest b/media-sound/spotify/Manifest
index bf0c27747321..ccc27f28e184 100644
--- a/media-sound/spotify/Manifest
+++ b/media-sound/spotify/Manifest
@@ -1,2 +1,4 @@
DIST spotify-client_1.0.47.13.gd8e05b1f-16_i386.deb 73083922 SHA256 646a5e90ede734d215e807c35165796b89d68b5c3f3e0363208cc204d1146692 SHA512 22e9c4fc45c17f7f0dd910981eeeb76e1db4b413a082ea684150616d7c8af698de1f5e101b82d23e429ec0ef8197c86e74534188f7bcb056afb2335aaf4e72ac WHIRLPOOL ea3cbc2e50a0dcf87cb3dab98439500e44d16568168ebfbd450c5fde35f450eb67ccb0762781e7dad7697f94df29d9a055cd0d1763ad3cdadb4d59f80e8977d3
DIST spotify-client_1.0.47.13.gd8e05b1f-47_amd64.deb 71870788 SHA256 7f32e25aa7188ec74a93d240b994f1126fc034325b66ec6549e7006e05dee900 SHA512 b5f51ae7c034b47264e7f897f28ca4f91f37bf1c01fa70b78393415cab8bcb9064b8a9842d43d4ab2ad1b7d4621dcb633ef1671dc0996e3734a9433d4749416c WHIRLPOOL e39b3fb696b445c78fd929785571f1821ef0ccf9b0811b24df8a69ce813c63fe7920252e477d3f4b7d336b78e3bc1144ada26c7c05ef6c596d2554f4f8174255
+DIST spotify-client_1.0.48.103.g15edf1ec-14_i386.deb 73398758 SHA256 4c7f5030589b851cec85a55540e6c54cc4d70ec48619d22ad6515ab50f38413a SHA512 62af00e047ac0a3096697473667f153042d948cd9d43a41cc3ee43ca4354baa1adb61cd49c0bc0163d74bc6764178926d3d2e90cc8b5959309a24b894330f62a WHIRLPOOL 1ee55dbb07e5612c71ecb050f80c9d042feb97f9dd0ff02533970dc82b7cbfd4eeda83f27ed47d57a6beb0594fe2076db212e68d39523201d1d09dd19a2f1436
+DIST spotify-client_1.0.48.103.g15edf1ec-94_amd64.deb 72106144 SHA256 63a1289f146d8327518306a7fa92299751eb0fb264a21433850e46b1fbebfc66 SHA512 df5a63538cdc60e407390fa815cf4eb274bc357d63bcfad6587468553dbedaf72815dd91fd8880cd565dae979cfe5096192b51e65723e701eed50722ff4f5e99 WHIRLPOOL f12dc09b7bc18ca17517964240f940e994bd581bbb1db707668f17d6ada9de1dedcb1e546f24ee4affbca49d3624bc3858de743aa74f2d521ef1c292564af5d2
diff --git a/media-sound/spotify/spotify-1.0.48.ebuild b/media-sound/spotify/spotify-1.0.48.ebuild
new file mode 100644
index 000000000000..a2e4f6da0cfa
--- /dev/null
+++ b/media-sound/spotify/spotify-1.0.48.ebuild
@@ -0,0 +1,118 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+inherit eutils fdo-mime gnome2-utils pax-utils unpacker
+
+DESCRIPTION="Spotify is a social music platform"
+HOMEPAGE="https://www.spotify.com/ch-de/download/previews/"
+BUILD_ID="103.g15edf1ec"
+SRC_BASE="http://repository.spotify.com/pool/non-free/${PN:0:1}/${PN}-client/"
+SRC_URI="amd64? ( ${SRC_BASE}${PN}-client_${PV}.${BUILD_ID}-94_amd64.deb )
+ x86? ( ${SRC_BASE}${PN}-client_${PV}.${BUILD_ID}-14_i386.deb )"
+LICENSE="Spotify"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="gnome pax_kernel pulseaudio"
+RESTRICT="mirror strip"
+
+DEPEND=""
+# zenety needed for filepicker
+RDEPEND="
+ ${DEPEND}
+ dev-libs/nss
+ gnome-base/gconf
+ gnome-extra/zenity
+ media-libs/alsa-lib
+ media-libs/harfbuzz
+ media-libs/fontconfig
+ media-libs/mesa
+ net-misc/curl[ssl,curl_ssl_openssl]
+ net-print/cups[ssl]
+ x11-libs/gtk+:2
+ x11-libs/libXScrnSaver
+ x11-libs/libXtst
+ dev-python/pygobject:3
+ dev-python/dbus-python
+ pulseaudio? ( media-sound/pulseaudio )
+ gnome? ( gnome-extra/gnome-integration-spotify )"
+ #sys-libs/glibc
+
+S=${WORKDIR}/
+
+QA_PREBUILT="opt/spotify/spotify-client/spotify"
+
+src_prepare() {
+ # Fix desktop entry to launch spotify-dbus.py for GNOME integration
+ if use gnome ; then
+ sed -i \
+ -e 's/spotify \%U/spotify-dbus.py \%U/g' \
+ usr/share/spotify/spotify.desktop || die "sed failed"
+ fi
+ default
+}
+
+src_install() {
+ dodoc usr/share/doc/spotify-client/changelog.gz
+
+ SPOTIFY_PKG_HOME=usr/share/spotify
+ insinto /usr/share/pixmaps
+ doins ${SPOTIFY_PKG_HOME}/icons/*.png
+
+ # install in /opt/spotify
+ SPOTIFY_HOME=/opt/spotify/spotify-client
+ insinto ${SPOTIFY_HOME}
+ doins -r ${SPOTIFY_PKG_HOME}/*
+ fperms +x ${SPOTIFY_HOME}/spotify
+
+ dodir /usr/bin
+ cat <<-EOF >"${D}"/usr/bin/spotify || die
+ #! /bin/sh
+ exec ${SPOTIFY_HOME}/spotify "\$@"
+ EOF
+ fperms +x /usr/bin/spotify
+
+ local size
+ for size in 16 22 24 32 48 64 128 256 512; do
+ newicon -s ${size} "${S}${SPOTIFY_PKG_HOME}/icons/spotify-linux-${size}.png" \
+ "spotify-client.png"
+ done
+ domenu "${S}${SPOTIFY_PKG_HOME}/spotify.desktop"
+ if use pax_kernel; then
+ #create the headers, reset them to default, then paxmark -m them
+ pax-mark C "${ED}${SPOTIFY_HOME}/${PN}" || die
+ pax-mark z "${ED}${SPOTIFY_HOME}/${PN}" || die
+ pax-mark m "${ED}${SPOTIFY_HOME}/${PN}" || die
+ eqawarn "You have set USE=pax_kernel meaning that you intend to run"
+ eqawarn "${PN} under a PaX enabled kernel. To do so, we must modify"
+ eqawarn "the ${PN} binary itself and this *may* lead to breakage! If"
+ eqawarn "you suspect that ${PN} is being broken by this modification,"
+ eqawarn "please open a bug."
+ fi
+}
+
+pkg_preinst() {
+ gnome2_icon_savelist
+}
+
+pkg_postinst() {
+ gnome2_icon_cache_update
+ fdo-mime_mime_database_update
+ fdo-mime_desktop_database_update
+
+ ewarn "If Spotify crashes after an upgrade its cache may be corrupt."
+ ewarn "To remove the cache:"
+ ewarn "rm -rf ~/.cache/spotify"
+ ewarn
+ ewarn "If you use KDE and are upgrading from 0.9 to 1.0, you might still see the old icon."
+ ewarn "Run"
+ ewarn "$ rm /var/tmp/kdecache-\$USER/icon-cache.kcache"
+ ewarn "Then log out and log in back to KDE."
+}
+
+pkg_postrm() {
+ gnome2_icon_cache_update
+ fdo-mime_mime_database_update
+ fdo-mime_desktop_database_update
+}