summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2020-03-27 09:33:19 +0100
committerMichał Górny <mgorny@gentoo.org>2020-03-27 09:57:53 +0100
commit1fe303e786eb7cf7e8150bc87cafef58a0fc21d9 (patch)
treec79f9827ccc721c57f0b8c5e1a6b03b27d933b46
parentdev-python/empy: Stabilize 3.3.3 ALLARCHES (diff)
downloadgentoo-1fe303e786eb7cf7e8150bc87cafef58a0fc21d9.tar.gz
gentoo-1fe303e786eb7cf7e8150bc87cafef58a0fc21d9.tar.bz2
gentoo-1fe303e786eb7cf7e8150bc87cafef58a0fc21d9.zip
dev-python/empy: Remove redundant versions
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/empy/Manifest2
-rw-r--r--dev-python/empy/empy-3.3-r1.ebuild44
-rw-r--r--dev-python/empy/empy-3.3.2.ebuild39
3 files changed, 0 insertions, 85 deletions
diff --git a/dev-python/empy/Manifest b/dev-python/empy/Manifest
index 068725a042cb..916446ae3c5b 100644
--- a/dev-python/empy/Manifest
+++ b/dev-python/empy/Manifest
@@ -1,3 +1 @@
-DIST empy-3.3.2.tar.gz 138168 BLAKE2B 0afbe6f7939898013770e18a0296d45a7a4121a3b8deb66a40b6fe37a311f9c4df1f864f4d975549cf4f198494f6f069d7ec186dfa5b99e19960b0c52a7aff2e SHA512 d9098823bbb26e4447aae9042e389e000f893615117512f9b786eedbc6875dee6b7f6be50021f68a4bd6e200b364852206b36bff5c48ae1754c8f0d49682d5f2
DIST empy-3.3.3.tar.gz 138429 BLAKE2B ed2ea352161bcd141620253e059255c6d6437d72d8e72075e1abc01efc496715ff07eb1e9baef70a631e752761f828f2f4750087da154c0a6df1434e47a8f0b7 SHA512 74c091d6dac39ad9ddb6f46963066dab1f8846565f77b1b0ad4352eda3534d4312b0e95d3682387d75c2f5553d678c6d3112471eec032e2bdea0e891dd8217b1
-DIST empy-3.3.tar.gz 137144 BLAKE2B 393f9033125459d6f3d5e9484d174980a00627508d083a32582f85eca9a294394ff028ee9df85ed73b8ff61174ae2068b0b943583fc86efa741bd2def63c215d SHA512 36304577839f5e6b2fb9bb2c2d72880e1f16886b2afadbcb38fd31a85620bb0369e837b8a1d74eab09a074bfe1f7be199b38842673106e0d26f1d9abc53987a7
diff --git a/dev-python/empy/empy-3.3-r1.ebuild b/dev-python/empy/empy-3.3-r1.ebuild
deleted file mode 100644
index 9d3614920a85..000000000000
--- a/dev-python/empy/empy-3.3-r1.ebuild
+++ /dev/null
@@ -1,44 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI="5"
-PYTHON_COMPAT=( python2_7 )
-
-inherit distutils-r1
-
-DESCRIPTION="A powerful and robust templating system for Python"
-HOMEPAGE="http://www.alcyone.com/software/empy/"
-SRC_URI="http://www.alcyone.com/software/${PN}/${P}.tar.gz"
-
-LICENSE="LGPL-2.1"
-SLOT="0"
-KEYWORDS="amd64 ~arm ia64 ppc x86"
-IUSE="doc"
-
-DEPEND=""
-RDEPEND=""
-
-python_prepare_all() {
- sed -e "s:/usr/local/bin/python:/usr/bin/python:g" -i em.py || die "sed failed"
- distutils-r1_python_prepare_all
-}
-
-python_test() {
- "${PYTHON}" em.py sample.em | diff sample.bench -
- if [[ ${PIPESTATUS[0]} -ne 0 || ${PIPESTATUS[1]} -ne 0 ]]; then
- die "Testing failed with ${EPYTHON}"
- fi
-}
-
-python_install_all() {
- distutils-r1_python_install_all
- if use doc; then
- dodir /usr/share/doc/"${PF}"/examples
- insinto /usr/share/doc/"${PF}"/examples
- doins sample.em sample.bench
- #3.3 has the html in this funny place. Fix in later version:
- dohtml doc/home/max/projects/empy/doc/em/*
- dohtml doc/home/max/projects/empy/doc/em.html
- dohtml doc/index.html
- fi
-}
diff --git a/dev-python/empy/empy-3.3.2.ebuild b/dev-python/empy/empy-3.3.2.ebuild
deleted file mode 100644
index 1083d80234c1..000000000000
--- a/dev-python/empy/empy-3.3.2.ebuild
+++ /dev/null
@@ -1,39 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI="5"
-PYTHON_COMPAT=( python{2_7,3_6} pypy3 )
-
-inherit distutils-r1
-
-DESCRIPTION="A powerful and robust templating system for Python"
-HOMEPAGE="http://www.alcyone.com/software/empy/"
-SRC_URI="http://www.alcyone.com/software/${PN}/${P}.tar.gz"
-
-LICENSE="LGPL-2.1"
-SLOT="0"
-KEYWORDS="~amd64 ~arm ~ia64 ~ppc ~x86"
-IUSE="doc"
-
-DEPEND=""
-RDEPEND=""
-
-python_test() {
- "${PYTHON}" em.py sample.em | diff sample.bench -
- if [[ ${PIPESTATUS[0]} -ne 0 || ${PIPESTATUS[1]} -ne 0 ]]; then
- die "Testing failed with ${EPYTHON}"
- fi
-}
-
-python_install_all() {
- distutils-r1_python_install_all
- if use doc; then
- dodir /usr/share/doc/"${PF}"/examples
- insinto /usr/share/doc/"${PF}"/examples
- doins sample.em sample.bench
- #3.3 has the html in this funny place. Fix in later version:
- dohtml doc/home/max/projects/empy/doc/em/*
- dohtml doc/home/max/projects/empy/doc/em.html
- dohtml doc/index.html
- fi
-}