summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPeter Levine <plevine457@gmail.com>2018-03-24 18:04:04 -0400
committerPacho Ramos <pacho@gentoo.org>2018-04-14 18:08:03 +0200
commit1ffb32396837505f577b5b18e0cb9e6d74bbc4b1 (patch)
tree4c209086593152b4883c3dfe8d3b7af246e62c78
parentnet-libs/loudmouth: Drop old (diff)
downloadgentoo-1ffb32396837505f577b5b18e0cb9e6d74bbc4b1.tar.gz
gentoo-1ffb32396837505f577b5b18e0cb9e6d74bbc4b1.tar.bz2
gentoo-1ffb32396837505f577b5b18e0cb9e6d74bbc4b1.zip
dev-util/codeblocks: Fix building with GCC-7
Bug: https://bugs.gentoo.org/649248 Package-Manager: Portage-2.3.16, Repoman-2.3.6 Closes: https://bugs.gentoo.org/649248 Closes: https://bugs.gentoo.org/637126 Closes: https://github.com/gentoo/gentoo/pull/7600
-rw-r--r--dev-util/codeblocks/codeblocks-16.01.ebuild4
-rw-r--r--dev-util/codeblocks/files/codeblocks-16.01-gcc7.patch30
2 files changed, 33 insertions, 1 deletions
diff --git a/dev-util/codeblocks/codeblocks-16.01.ebuild b/dev-util/codeblocks/codeblocks-16.01.ebuild
index 047fa0975850..07a042e6263e 100644
--- a/dev-util/codeblocks/codeblocks-16.01.ebuild
+++ b/dev-util/codeblocks/codeblocks-16.01.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2017 Gentoo Foundation
+# Copyright 1999-2018 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
EAPI=6
@@ -28,6 +28,8 @@ RDEPEND="app-arch/zip
DEPEND="${RDEPEND}
virtual/pkgconfig"
+PATCHES=( "${FILESDIR}"/${P}-gcc7.patch )
+
src_configure() {
touch "${S}"/revision.m4 -r "${S}"/acinclude.m4
setup-wxwidgets
diff --git a/dev-util/codeblocks/files/codeblocks-16.01-gcc7.patch b/dev-util/codeblocks/files/codeblocks-16.01-gcc7.patch
new file mode 100644
index 000000000000..84cbc88696c7
--- /dev/null
+++ b/dev-util/codeblocks/files/codeblocks-16.01-gcc7.patch
@@ -0,0 +1,30 @@
+Bug: https://bugs.gentoo.org/649248
+SVN Revision: https://sourceforge.net/p/codeblocks/code/11006
+GIT Commit: https://github.com/jenslody/codeblocks/commit/1fd6799ded8475fafaca17de9c23db767177d31b
+
+From 1fd6799ded8475fafaca17de9c23db767177d31b Mon Sep 17 00:00:00 2001
+From: jenslody <jenslody@2a5c6006-c6dd-42ca-98ab-0921f2732cef>
+Date: Fri, 10 Feb 2017 20:56:25 +0000
+Subject: [PATCH] gcc7 build-fix: avoid template-related error
+
+---
+ src/include/scripting/sqplus/sqplus.h | 4 ++--
+ 1 file changed, 2 insertions(+), 2 deletions(-)
+
+diff --git a/src/include/scripting/sqplus/sqplus.h b/src/include/scripting/sqplus/sqplus.h
+index 73f37b24f..ae7d3c75f 100644
+--- a/src/include/scripting/sqplus/sqplus.h
++++ b/src/include/scripting/sqplus/sqplus.h
+@@ -154,10 +154,10 @@ struct ScriptStringVar : ScriptStringVarBase {
+ return safeStringCopy(s,_s.s,MaxLength);
+ }
+ bool operator == (const ScriptStringVar & _s) {
+- return _strcmp(s,_s.s) == 0;
++ return strcmp(s,_s.s) == 0;
+ }
+ bool compareCaseInsensitive(const ScriptStringVar & _s) {
+- return _stricmp(s,_s.s) == 0;
++ return strcasecmp(s,_s.s) == 0;
+ }
+ };
+