summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIonen Wolkens <ionen@gentoo.org>2022-08-10 01:52:40 -0400
committerIonen Wolkens <ionen@gentoo.org>2022-08-10 01:55:41 -0400
commit2100c13cb03e39e0745e6b41de17a25ad329fe44 (patch)
tree63b074a0283c419b1647ae0449c3f05fa5bf02c8
parentwww-apps/mediawiki: dropped obsolete 1.37.3 (diff)
downloadgentoo-2100c13cb03e39e0745e6b41de17a25ad329fe44.tar.gz
gentoo-2100c13cb03e39e0745e6b41de17a25ad329fe44.tar.bz2
gentoo-2100c13cb03e39e0745e6b41de17a25ad329fe44.zip
app-portage/iwdevtools: add 0.11.6
Signed-off-by: Ionen Wolkens <ionen@gentoo.org>
-rw-r--r--app-portage/iwdevtools/Manifest1
-rw-r--r--app-portage/iwdevtools/iwdevtools-0.11.6.ebuild64
2 files changed, 65 insertions, 0 deletions
diff --git a/app-portage/iwdevtools/Manifest b/app-portage/iwdevtools/Manifest
index 274e2d13cdba..6219e8157377 100644
--- a/app-portage/iwdevtools/Manifest
+++ b/app-portage/iwdevtools/Manifest
@@ -1 +1,2 @@
DIST iwdevtools-0.11.5.tar.gz 85698 BLAKE2B 0f5b0c81735017b82144c74b2396826b2e6ea97db70704977c7885bdb00442c83023f593aeb25ab2e51f3a35cd659be98440f51e4496418a92f1559212db5b5d SHA512 05e0169a465cd4956d663f54bdc66d3c17379229b23c26a94d9deff879ef9e53b1b28f59e7cf314d36127954cb75728f008d0b0728659436ad1e63de5fb11bbb
+DIST iwdevtools-0.11.6.tar.gz 85945 BLAKE2B 61c18ae0ed1c0f7e90d41af485f18f891cdd9ffbaff5437cb9f9ca88622efa0f5acd89ac8596e7d41c25a083a970143f3b226284f4566b0b8ee3718071cd6cbb SHA512 21ffda72945947658bf6867bf83d9b9ad4f6b930d4c2cee3dea551581030668ab286a4c4a07edeae937fd91f4aba08fe8e7c6506459808c4ada38502226b5b26
diff --git a/app-portage/iwdevtools/iwdevtools-0.11.6.ebuild b/app-portage/iwdevtools/iwdevtools-0.11.6.ebuild
new file mode 100644
index 000000000000..68858249d8a0
--- /dev/null
+++ b/app-portage/iwdevtools/iwdevtools-0.11.6.ebuild
@@ -0,0 +1,64 @@
+# Copyright 2021-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit meson optfeature
+
+DESCRIPTION="Small tools to aid with Gentoo development, primarily intended for QA"
+HOMEPAGE="https://github.com/ionenwks/iwdevtools"
+SRC_URI="https://github.com/ionenwks/iwdevtools/archive/refs/tags/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~loong ~ppc ~ppc64 ~riscv ~sparc ~x86 ~x64-macos"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ app-misc/pax-utils
+ app-portage/portage-utils
+ >=app-shells/bash-5.1
+ dev-libs/libxml2:2
+ sys-apps/diffutils
+ sys-apps/file
+ sys-apps/portage
+ || ( sys-apps/util-linux app-misc/getopt )"
+BDEPEND="
+ sys-apps/help2man
+ || ( sys-apps/util-linux app-misc/getopt )
+ test? ( ${RDEPEND} )"
+
+src_configure() {
+ local emesonargs=(
+ -Ddocdir=${PF}
+ -Deprefix="${EPREFIX}"
+ -Dshellcheck=false
+ $(meson_use test)
+ )
+
+ has_version sys-apps/util-linux || emesonargs+=( -Dgetopt=getopt-long )
+
+ meson_src_configure
+}
+
+pkg_postinst() {
+ optfeature "detecting potential ABI issues using abidiff" dev-util/libabigail
+
+ if [[ ! ${REPLACING_VERSIONS} ]]; then
+ elog "Optional portage integration relies on using /etc/portage/bashrc."
+ elog "The example bashrc can be used as-is if not already using one:"
+ elog
+ elog " ln -s ../../usr/share/${PN}/bashrc ${EROOT}/etc/portage/bashrc"
+ elog
+ elog "Otherwise, inspect the tools' --help output and the example to integrate"
+ elog "(if not defining the same phase functions, the example can be sourced)."
+ elog
+ elog "Note that \`eqawarn\` is used for portage output by default. QA messages"
+ elog "aren't logged / shown post-emerge unless e.g. in /etc/portage/make.conf:"
+ elog
+ elog ' PORTAGE_ELOG_CLASSES="${PORTAGE_ELOG_CLASSES} qa"'
+ elog
+ elog "See ${EROOT}/usr/share/doc/${PF}/README.rst* for information on tools."
+ fi
+}