summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2015-09-26 13:38:21 -0400
committerMike Frysinger <vapier@gentoo.org>2015-09-26 14:15:06 -0400
commit21049b7dd9e07fc5320d8e28348d8e1b46dc5bc5 (patch)
tree813bbd15b80c9cac77f26d94a34c79e0b2c3ac3f
parentsys-devel/binutils-config: move libs/headers to binutils-libs #528088 (diff)
downloadgentoo-21049b7dd9e07fc5320d8e28348d8e1b46dc5bc5.tar.gz
gentoo-21049b7dd9e07fc5320d8e28348d8e1b46dc5bc5.tar.bz2
gentoo-21049b7dd9e07fc5320d8e28348d8e1b46dc5bc5.zip
sys-devel/gdb: stop installing bfd/opcodes translations #528088
The binutils-libs package will install the canonical files for the various binutils libraries and that includes translations. Delete the copies in gdb until we can figure out how to localize them.
-rw-r--r--sys-devel/gdb/gdb-7.10-r1.ebuild (renamed from sys-devel/gdb/gdb-7.10.ebuild)8
-rw-r--r--sys-devel/gdb/gdb-9999.ebuild8
2 files changed, 16 insertions, 0 deletions
diff --git a/sys-devel/gdb/gdb-7.10.ebuild b/sys-devel/gdb/gdb-7.10-r1.ebuild
index 5cd44b4cff8b..ec3031d7d1c2 100644
--- a/sys-devel/gdb/gdb-7.10.ebuild
+++ b/sys-devel/gdb/gdb-7.10-r1.ebuild
@@ -170,6 +170,14 @@ src_install() {
use client && find "${ED}"/usr -name libiberty.a -delete
cd "${S}"
+ # Delete translations that conflict with binutils-libs. #528088
+ # Note: Should figure out how to store these in an internal gdb dir.
+ if use nls ; then
+ find "${ED}" \
+ -regextype posix-extended -regex '.*/(bfd|opcodes)[.]g?mo$' \
+ -delete
+ fi
+
# Don't install docs when building a cross-gdb
if [[ ${CTARGET} != ${CHOST} ]] ; then
rm -r "${ED}"/usr/share/{doc,info,locale}
diff --git a/sys-devel/gdb/gdb-9999.ebuild b/sys-devel/gdb/gdb-9999.ebuild
index 5cd44b4cff8b..ec3031d7d1c2 100644
--- a/sys-devel/gdb/gdb-9999.ebuild
+++ b/sys-devel/gdb/gdb-9999.ebuild
@@ -170,6 +170,14 @@ src_install() {
use client && find "${ED}"/usr -name libiberty.a -delete
cd "${S}"
+ # Delete translations that conflict with binutils-libs. #528088
+ # Note: Should figure out how to store these in an internal gdb dir.
+ if use nls ; then
+ find "${ED}" \
+ -regextype posix-extended -regex '.*/(bfd|opcodes)[.]g?mo$' \
+ -delete
+ fi
+
# Don't install docs when building a cross-gdb
if [[ ${CTARGET} != ${CHOST} ]] ; then
rm -r "${ED}"/usr/share/{doc,info,locale}