summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2023-03-29 02:20:09 +0100
committerSam James <sam@gentoo.org>2023-03-29 13:56:22 +0100
commit2162ac53c165db115199ec06b2dcf99ae58372ca (patch)
tree766281c94aa804c1efeafb6cb73cb549c6048e6a
parentdev-ruby/rmagick: drop 4.2.5 (diff)
downloadgentoo-2162ac53c165db115199ec06b2dcf99ae58372ca.tar.gz
gentoo-2162ac53c165db115199ec06b2dcf99ae58372ca.tar.bz2
gentoo-2162ac53c165db115199ec06b2dcf99ae58372ca.zip
dev-ruby/rmagick: drop 5.0.0, 5.1.0
Signed-off-by: Sam James <sam@gentoo.org>
-rw-r--r--dev-ruby/rmagick/Manifest2
-rw-r--r--dev-ruby/rmagick/rmagick-5.0.0.ebuild76
-rw-r--r--dev-ruby/rmagick/rmagick-5.1.0.ebuild78
3 files changed, 0 insertions, 156 deletions
diff --git a/dev-ruby/rmagick/Manifest b/dev-ruby/rmagick/Manifest
index 75a1a9bbdc82..26251b8e0188 100644
--- a/dev-ruby/rmagick/Manifest
+++ b/dev-ruby/rmagick/Manifest
@@ -1,4 +1,2 @@
DIST rmagick-4.3.0.tar.gz 1986554 BLAKE2B bf6afb0b19a98f45dd9f3a8261b67ad05ed774784e9fb19009a83c266c16362b4938acd8b0af6a07d3a37fb255fb5bee7a33b7f26c2c49460d546665a98a7871 SHA512 1b108d61b836bf382c9776badc45614ff88ca74176595765c3caba00cc6af0f955dd6f7649a9f97698832193d85292bc22ff0bf290d0bfbf9e8faa58b99b0b1c
-DIST rmagick-5.0.0.tar.gz 1981170 BLAKE2B e73ca833d7e04ae5755d987f32a220d3f286c3398b24729a60365365f91efad28897d62a50f43082fb3b026c4438e8872a636e9aa66e7abf8fc9a7be593b796b SHA512 82cbef42cb8707f4160fecfa10f09ffe4ed5dade492145cd8ae7b856c585bf0ec65aa114340b39bee6f42505c84fee25ef3e542ec06a02105f0112a50129fad5
-DIST rmagick-5.1.0.tar.gz 1991405 BLAKE2B 79b0a5551ec51edac9c023edd9b7962f033884143d546a91081f15c9f826c72f636c77f1af614d75d7be569c8f3c7edaedc8fa348e53f4b9ea1e7e9543b736e9 SHA512 e96b576232a329077cb45b032330a0399dfde625636f5c81bb499c17fef8cda80902479859a836f40db70277be7cff6856723920a6b602df1f336ddbd658722e
DIST rmagick-5.2.0.tar.gz 1991303 BLAKE2B 131e0a9ac1e56942b1281f1ce1a62c86e6997fcbc3f162fc4afea897831003bee2e010a27b6ab4f59331b720ff06d61c07b0ae9ce5327752658627adaab0ccad SHA512 9c7262db329869f33c6ae27980a86bd24b7a4a72d7b826eb3e75d28571d954ff5cba6c7ac86a0540663c9ddf2a8185ca3007d3c2ac5cc5339e4cc327e5f7910f
diff --git a/dev-ruby/rmagick/rmagick-5.0.0.ebuild b/dev-ruby/rmagick/rmagick-5.0.0.ebuild
deleted file mode 100644
index 8078c21eb70d..000000000000
--- a/dev-ruby/rmagick/rmagick-5.0.0.ebuild
+++ /dev/null
@@ -1,76 +0,0 @@
-# Copyright 1999-2022 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-USE_RUBY="ruby27 ruby30 ruby31"
-
-RUBY_FAKEGEM_RECIPE_TEST="rspec3"
-
-RUBY_FAKEGEM_TASK_DOC=""
-
-RUBY_FAKEGEM_EXTRADOC="CHANGELOG.md README.md"
-
-RUBY_FAKEGEM_GEMSPEC="rmagick.gemspec"
-
-RUBY_FAKEGEM_EXTENSIONS=(ext/RMagick/extconf.rb)
-
-MY_PV=RMagick_${PV//\./-}
-
-inherit ruby-fakegem
-
-DESCRIPTION="An interface between Ruby and the ImageMagick(TM) image processing library"
-HOMEPAGE="https://github.com/rmagick/rmagick"
-SRC_URI="https://github.com/rmagick/rmagick/archive/${MY_PV}.tar.gz -> ${P}.tar.gz"
-RUBY_S="rmagick-${MY_PV}"
-
-LICENSE="Artistic"
-SLOT="$(ver_cut 1)"
-KEYWORDS="~amd64 ~hppa ~ppc ~ppc64 ~x86"
-IUSE="doc"
-
-RDEPEND+=" >=media-gfx/imagemagick-6.9.0:="
-DEPEND+=" >=media-gfx/imagemagick-6.9.0 test? ( >=media-gfx/imagemagick-7.1.0:=[jpeg,lqr,lcms,postscript,tiff,webp] )"
-
-all_ruby_prepare() {
- # Avoid unused dependency on rake-compiler. This also avoids an
- # extra compile during tests.
- sed -i -e '/extensiontask/ s:^:#:' \
- -e '/ExtensionTask/,/end/ s:^:#:' \
- -e '/compile/ s:^:#:' Rakefile || die
- sed -i -e '/pry/ s:^:#:' spec/spec_helper.rb || die
- sed -i -e 's/git ls-files/find */' ${RUBY_FAKEGEM_GEMSPEC} || die
-
- # Squelch harmless warning about imagemagick installation.
- sed -i -e '/prefix/ s:ImageMagick:ImageMagick-6:' ext/RMagick/extconf.rb || die
-
- # Create directory used for a test
- mkdir tmp
-}
-
-each_ruby_test() {
- # Borrowed from media-gfx/gscan2pdf
- # Needed to avoid test failures on e.g. ppc, bug #815856
- # (Unclear why it doesn't manifest on amd64 here at least)
- local confdir="${HOME}/.config/ImageMagick"
- mkdir -p "${confdir}" || die
- cat > "${confdir}/policy.xml" <<-EOT || die
- <policymap>
- <policy domain="coder" rights="read|write" pattern="PDF" />
- <policy domain="coder" rights="read" pattern="PS" />
- </policymap>
- EOT
-
- RSPEC_VERSION="3" ruby-ng_rspec
-}
-
-all_ruby_install() {
- all_fakegem_install
-
- docinto examples
- dodoc examples/*
-
- if use doc ; then
- docinto .
- dodoc -r doc
- fi
-}
diff --git a/dev-ruby/rmagick/rmagick-5.1.0.ebuild b/dev-ruby/rmagick/rmagick-5.1.0.ebuild
deleted file mode 100644
index 26adb72d7ad0..000000000000
--- a/dev-ruby/rmagick/rmagick-5.1.0.ebuild
+++ /dev/null
@@ -1,78 +0,0 @@
-# Copyright 1999-2022 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-USE_RUBY="ruby27 ruby30 ruby31"
-
-RUBY_FAKEGEM_RECIPE_TEST="rspec3"
-
-RUBY_FAKEGEM_TASK_DOC=""
-
-RUBY_FAKEGEM_EXTRADOC="CHANGELOG.md README.md"
-
-RUBY_FAKEGEM_GEMSPEC="rmagick.gemspec"
-
-RUBY_FAKEGEM_EXTENSIONS=(ext/RMagick/extconf.rb)
-
-MY_PV=RMagick_${PV//\./-}
-
-inherit ruby-fakegem
-
-DESCRIPTION="An interface between Ruby and the ImageMagick(TM) image processing library"
-HOMEPAGE="https://github.com/rmagick/rmagick"
-SRC_URI="https://github.com/rmagick/rmagick/archive/${MY_PV}.tar.gz -> ${P}.tar.gz"
-RUBY_S="rmagick-${MY_PV}"
-
-LICENSE="Artistic"
-SLOT="$(ver_cut 1)"
-KEYWORDS="~amd64 ~hppa ~ppc ~ppc64 ~x86"
-IUSE="doc"
-
-RDEPEND+=" >=media-gfx/imagemagick-6.9.0:="
-DEPEND+=" >=media-gfx/imagemagick-6.9.0 test? ( >=media-gfx/imagemagick-7.1.0:=[jpeg,lqr,lcms,postscript,tiff,webp] )"
-
-ruby_add_bdepend "dev-ruby/pkg-config"
-
-all_ruby_prepare() {
- # Avoid unused dependency on rake-compiler. This also avoids an
- # extra compile during tests.
- sed -i -e '/extensiontask/ s:^:#:' \
- -e '/ExtensionTask/,/end/ s:^:#:' \
- -e '/compile/ s:^:#:' Rakefile || die
- sed -i -e '/pry/ s:^:#:' spec/spec_helper.rb || die
- sed -i -e 's/git ls-files/find */' ${RUBY_FAKEGEM_GEMSPEC} || die
-
- # Squelch harmless warning about imagemagick installation.
- sed -i -e '/prefix/ s:ImageMagick:ImageMagick-6:' ext/RMagick/extconf.rb || die
-
- # Create directory used for a test
- mkdir tmp
-}
-
-each_ruby_test() {
- # Borrowed from media-gfx/gscan2pdf
- # Needed to avoid test failures on e.g. ppc, bug #815856
- # (Unclear why it doesn't manifest on amd64 here at least)
- local confdir="${HOME}/.config/ImageMagick"
- mkdir -p "${confdir}" || die
- cat > "${confdir}/policy.xml" <<-EOT || die
- <policymap>
- <policy domain="coder" rights="read|write" pattern="PDF" />
- <policy domain="coder" rights="read" pattern="PS" />
- </policymap>
- EOT
-
- RSPEC_VERSION="3" ruby-ng_rspec
-}
-
-all_ruby_install() {
- all_fakegem_install
-
- docinto examples
- dodoc examples/*
-
- if use doc ; then
- docinto .
- dodoc -r doc
- fi
-}