summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2018-07-03 12:44:22 +0200
committerAlexis Ballier <aballier@gentoo.org>2018-07-03 13:21:48 +0200
commit217d3174473bb3cf915b634fcea276864aebee97 (patch)
treeb288bf263c85c19065a041f8028c84688722507c
parentkde5-functions.eclass: Add minimum deps for Plasma 5.13 (diff)
downloadgentoo-217d3174473bb3cf915b634fcea276864aebee97.tar.gz
gentoo-217d3174473bb3cf915b634fcea276864aebee97.tar.bz2
gentoo-217d3174473bb3cf915b634fcea276864aebee97.zip
dev-python/catkin_pkg: Remove old
Package-Manager: Portage-2.3.41, Repoman-2.3.9
-rw-r--r--dev-python/catkin_pkg/Manifest2
-rw-r--r--dev-python/catkin_pkg/catkin_pkg-0.3.9.ebuild46
-rw-r--r--dev-python/catkin_pkg/catkin_pkg-0.4.1-r1.ebuild47
3 files changed, 0 insertions, 95 deletions
diff --git a/dev-python/catkin_pkg/Manifest b/dev-python/catkin_pkg/Manifest
index 413b7da1d4b9..4815360a72bc 100644
--- a/dev-python/catkin_pkg/Manifest
+++ b/dev-python/catkin_pkg/Manifest
@@ -1,3 +1 @@
-DIST catkin_pkg-0.3.9-gh.tar.gz 48290 BLAKE2B fbba89008946433007f1016addeb73e44108b057609d52d693e80024460c5d77686bde241331845d36068b23e87a4ac33dcc0c6c29af95c4e86e8a30bbe52918 SHA512 39c7dbd7b3bb7d0fd7f37e6931e5de8c76c28ca329db5783d1cf0b01e9a7f58079c45434d937a8edcf29cbdebdcfb4b18480508d688dcefdf58c218838af65c8
-DIST catkin_pkg-0.4.1-gh.tar.gz 50886 BLAKE2B 03a5205271fd3f12e4a3bcd093d8e1811d3a1e3197292004e9dd4e255fa10741fdb90a754df4a1fd6705f305e524413cdb7a8dc9f5174a162a20ffa95cfc3b2e SHA512 d7802bbfd0187f1411d36fbecca2afa43dc55f54441a6e0ddc54c2153bf1c553cfa76e5a3d1d08a92fe765c530d1668a762eaaf45e1f68b61c2cf6d1ec49e4a7
DIST catkin_pkg-0.4.2-gh.tar.gz 52930 BLAKE2B 2b8589441d241197c661975c07c60856c614c4c328e441e6fbb1cb41ea2919f57864f67198b684eba7183004671df0980ddcf0070a53099074433166b5d7db20 SHA512 cb47771172d88792bc7039f072175a6f410aa046e2611ccc75e46bda388d620ac0059e0fa9e087fbb7f2833600a7233d714c1aeeab65e264606d8ae2e64d76bb
diff --git a/dev-python/catkin_pkg/catkin_pkg-0.3.9.ebuild b/dev-python/catkin_pkg/catkin_pkg-0.3.9.ebuild
deleted file mode 100644
index 0967bd6ff8e6..000000000000
--- a/dev-python/catkin_pkg/catkin_pkg-0.3.9.ebuild
+++ /dev/null
@@ -1,46 +0,0 @@
-# Copyright 1999-2017 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=5
-PYTHON_COMPAT=( python{2_7,3_4,3_5,3_6} pypy{,3} )
-
-SCM=""
-if [ "${PV#9999}" != "${PV}" ] ; then
- SCM="git-r3"
- EGIT_REPO_URI="https://github.com/ros-infrastructure/catkin_pkg"
-fi
-
-inherit ${SCM} distutils-r1
-
-DESCRIPTION="Standalone Python library for the catkin package system"
-HOMEPAGE="http://wiki.ros.org/catkin_pkg"
-if [ "${PV#9999}" != "${PV}" ] ; then
- SRC_URI=""
- KEYWORDS=""
-else
- SRC_URI="https://github.com/ros-infrastructure/catkin_pkg/archive/${PV}.tar.gz -> ${P}-gh.tar.gz"
- KEYWORDS="~amd64 ~arm"
-fi
-
-LICENSE="BSD"
-SLOT="0"
-IUSE="test"
-
-RDEPEND="
- dev-python/setuptools[${PYTHON_USEDEP}]
- dev-python/docutils[${PYTHON_USEDEP}]
- dev-python/python-dateutil[${PYTHON_USEDEP}]
-"
-DEPEND="${RDEPEND}
- test? ( dev-python/mock[${PYTHON_USEDEP}] dev-python/nose[${PYTHON_USEDEP}] )
-"
-PATCHES=(
- "${FILESDIR}/catkin_prefix.patch"
- "${FILESDIR}/argparse.patch"
- "${FILESDIR}/ros_packages.patch"
- "${FILESDIR}/infinite_loop2.patch"
-)
-
-python_test() {
- nosetests -s --tests test || die
-}
diff --git a/dev-python/catkin_pkg/catkin_pkg-0.4.1-r1.ebuild b/dev-python/catkin_pkg/catkin_pkg-0.4.1-r1.ebuild
deleted file mode 100644
index f74d5f891e53..000000000000
--- a/dev-python/catkin_pkg/catkin_pkg-0.4.1-r1.ebuild
+++ /dev/null
@@ -1,47 +0,0 @@
-# Copyright 1999-2018 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=5
-PYTHON_COMPAT=( python{2_7,3_4,3_5,3_6} pypy{,3} )
-
-SCM=""
-if [ "${PV#9999}" != "${PV}" ] ; then
- SCM="git-r3"
- EGIT_REPO_URI="https://github.com/ros-infrastructure/catkin_pkg"
-fi
-
-inherit ${SCM} distutils-r1
-
-DESCRIPTION="Standalone Python library for the catkin package system"
-HOMEPAGE="http://wiki.ros.org/catkin_pkg"
-if [ "${PV#9999}" != "${PV}" ] ; then
- SRC_URI=""
- KEYWORDS=""
-else
- SRC_URI="https://github.com/ros-infrastructure/catkin_pkg/archive/${PV}.tar.gz -> ${P}-gh.tar.gz"
- KEYWORDS="~amd64 ~arm"
-fi
-
-LICENSE="BSD"
-SLOT="0"
-IUSE="test"
-
-RDEPEND="
- dev-python/setuptools[${PYTHON_USEDEP}]
- dev-python/docutils[${PYTHON_USEDEP}]
- dev-python/python-dateutil[${PYTHON_USEDEP}]
- dev-python/pyparsing[${PYTHON_USEDEP}]
-"
-DEPEND="${RDEPEND}
- test? ( dev-python/mock[${PYTHON_USEDEP}] dev-python/nose[${PYTHON_USEDEP}] )
-"
-PATCHES=(
- "${FILESDIR}/catkin_prefix.patch"
- "${FILESDIR}/argparse.patch"
- "${FILESDIR}/ros_packages.patch"
- "${FILESDIR}/infinite_loop2.patch"
-)
-
-python_test() {
- nosetests -s --tests test || die
-}