summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2016-06-20 18:23:09 +0200
committerAlexis Ballier <aballier@gentoo.org>2016-06-20 19:02:54 +0200
commit225c6eecc035b5319a78cf4a14770555a16fbd0b (patch)
tree82a116bcbc0318382a4461b1a56a309d6b7a6c0b
parentapp-emulation/runc: version bump to 1.0.0_rc1 (diff)
downloadgentoo-225c6eecc035b5319a78cf4a14770555a16fbd0b.tar.gz
gentoo-225c6eecc035b5319a78cf4a14770555a16fbd0b.tar.bz2
gentoo-225c6eecc035b5319a78cf4a14770555a16fbd0b.zip
dev-ml/js_of_ocaml: bump to 2.8
Package-Manager: portage-2.3.0_rc1
-rw-r--r--dev-ml/js_of_ocaml/Manifest1
-rw-r--r--dev-ml/js_of_ocaml/js_of_ocaml-2.8.ebuild57
-rw-r--r--dev-ml/js_of_ocaml/metadata.xml1
3 files changed, 59 insertions, 0 deletions
diff --git a/dev-ml/js_of_ocaml/Manifest b/dev-ml/js_of_ocaml/Manifest
index e312923d8a2c..019ba1be228d 100644
--- a/dev-ml/js_of_ocaml/Manifest
+++ b/dev-ml/js_of_ocaml/Manifest
@@ -1 +1,2 @@
DIST js_of_ocaml-2.7.tar.gz 1304487 SHA256 52922f55428a1d8a55ec2493c4989152e06efd29a981adf8ac9f343f558854b5 SHA512 ab6e5d16342bf763c10eb5c2e7589610622034eee2ad82aa09c6f68448f155a5c56584702307852b251bde80146c1b7115ed6add1358ad96b130c9dd2b96118b WHIRLPOOL 278c17432fdf9bf670df33479c68705868be39eb4d53f67fc489fe44ac2e7645dd5e2ed3e6e71752a2387b516ce0ab6dc99ac1d870fc75ffdad9df87031e9de4
+DIST js_of_ocaml-2.8.tar.gz 1330364 SHA256 98564d9a36025edb5edd9d58c565fc7b38a3b49f9b8e32d7dc29289d443894b0 SHA512 914b2a1a452acd494c3373fa65e858c2747bd7d946d6077320429160d4172f627978a0b4ee526fc6e39378dffc9c965b81e5a1f16eba1f60529e4a6b5f474c1e WHIRLPOOL cfb71c97c3c43e873dc1f83b26ccacf93be846940596e99f004e6539c5bfa15e810d290b254c4bfecce65133dc6b79247c3cb2cd301297b6062ac6526147f94d
diff --git a/dev-ml/js_of_ocaml/js_of_ocaml-2.8.ebuild b/dev-ml/js_of_ocaml/js_of_ocaml-2.8.ebuild
new file mode 100644
index 000000000000..58bce363cc0f
--- /dev/null
+++ b/dev-ml/js_of_ocaml/js_of_ocaml-2.8.ebuild
@@ -0,0 +1,57 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit findlib eutils
+
+DESCRIPTION="A compiler from OCaml bytecode to javascript"
+HOMEPAGE="http://ocsigen.org/js_of_ocaml/"
+SRC_URI="https://github.com/ocsigen/js_of_ocaml/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="LGPL-2.1-with-linking-exception"
+SLOT="0/${PV}"
+KEYWORDS="~amd64"
+IUSE="+async +ocamlopt doc +deriving +ppx +ppx-deriving +react +xml X"
+
+RDEPEND="
+ >=dev-lang/ocaml-3.12:=[ocamlopt?,X?]
+ >=dev-ml/lwt-2.4.4:=
+ async? ( dev-ml/async_kernel:= )
+ react? ( dev-ml/react:= dev-ml/reactiveData:= )
+ xml? ( >=dev-ml/tyxml-4:= )
+ ppx? ( dev-ml/ppx_tools:= )
+ ppx-deriving? ( dev-ml/ppx_deriving:= )
+ dev-ml/cmdliner:=
+ dev-ml/menhir:=
+ dev-ml/ocaml-base64:=
+ dev-ml/camlp4:=
+ dev-ml/cppo:=
+ deriving? ( >=dev-ml/deriving-0.6:= )"
+DEPEND="${RDEPEND}
+ dev-ml/ocamlbuild"
+
+src_configure() {
+ printf "\n\n" >> Makefile.conf
+ use ocamlopt || echo "BEST := byte" >> Makefile.conf
+ use ocamlopt || echo "NATDYNLINK := NO" >> Makefile.conf
+ use deriving || echo "WITH_DERIVING := NO" >> Makefile.conf
+ use X || echo "WITH_GRAPHICS := NO" >> Makefile.conf
+ use react || echo "WITH_REACT := NO" >> Makefile.conf
+ use ppx || echo "WITH_PPX := NO" >> Makefile.conf
+ use ppx-deriving || echo "WITH_PPX_PPX_DERIVING := NO" >> Makefile.conf
+ use async || echo "WITH_ASYNC := NO" >> Makefile.conf
+}
+
+src_compile() {
+ emake -j1
+ use doc && emake doc
+}
+
+src_install() {
+ findlib_src_preinst
+ emake BINDIR="${ED}/usr/bin/" install
+ dodoc CHANGES README.md
+ use doc && dohtml -r doc/api/html/
+}
diff --git a/dev-ml/js_of_ocaml/metadata.xml b/dev-ml/js_of_ocaml/metadata.xml
index 0b34c19deedf..61eb3e1f8706 100644
--- a/dev-ml/js_of_ocaml/metadata.xml
+++ b/dev-ml/js_of_ocaml/metadata.xml
@@ -6,6 +6,7 @@
<name>Gentoo ML Project</name>
</maintainer>
<use>
+ <flag name="async">Enable support of <pkg>dev-ml/async_kernel</pkg>.</flag>
<flag name="deriving">Enable <pkg>dev-ml/deriving</pkg> support for improving the type safety.</flag>
<flag name="ppx">Enables the ppx syntax extension</flag>
<flag name="ppx-deriving">Enables deriving support through ppx syntax extensions.</flag>