summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMart Raudsepp <leio@gentoo.org>2018-08-03 12:04:56 +0300
committerMart Raudsepp <leio@gentoo.org>2018-08-03 12:04:56 +0300
commit22b568cd5025db3ca89b568e2d0248a556d34f74 (patch)
tree174beab1c6c700b4a5065cbeb60ed0c891f654ec
parentnet-libs/webkit-gtk: roll ~ppc64 keyword forward (diff)
downloadgentoo-22b568cd5025db3ca89b568e2d0248a556d34f74.tar.gz
gentoo-22b568cd5025db3ca89b568e2d0248a556d34f74.tar.bz2
gentoo-22b568cd5025db3ca89b568e2d0248a556d34f74.zip
x11-themes/adwaita-icon-theme: bump to 3.26.1
This is not in a gnome 3.26 global mask on purpose. Compared to 3.24.x it only adds new icons and fixes bugs relevant to 3.24 as well. The most visible change is a redesigned new tab icon, but this is relevant as a bug fix to nautilus 3.24 as well. Package-Manager: Portage-2.3.43, Repoman-2.3.10
-rw-r--r--x11-themes/adwaita-icon-theme/Manifest1
-rw-r--r--x11-themes/adwaita-icon-theme/adwaita-icon-theme-3.26.1.ebuild58
2 files changed, 59 insertions, 0 deletions
diff --git a/x11-themes/adwaita-icon-theme/Manifest b/x11-themes/adwaita-icon-theme/Manifest
index 6ff414bf6de4..f2e54bd110fc 100644
--- a/x11-themes/adwaita-icon-theme/Manifest
+++ b/x11-themes/adwaita-icon-theme/Manifest
@@ -1,3 +1,4 @@
DIST adwaita-icon-theme-3.22.0.tar.xz 18395856 BLAKE2B 8b6a7f10b1598803db431eb435a7862b107e9ab715e7d462a938b7a3bdc697d33d5317daebc230674c99d8ac5d5aec5389be8fbcb757498593d0e7fcc1c7fb98 SHA512 33d5eab0a7295069bb3cc8939bebeed0bad8ff72bfe42b0a90e616190ce519e7d7e2b4e9e4c145d04911ea37c205c12ca39972fd00e6ef34271b66a25ff24983
DIST adwaita-icon-theme-3.24.0.tar.xz 20717972 BLAKE2B cce76731e7c33d42330eb2e0039979db3f2280fe84ef427ac6295244f750eedb93584efddb4299260846facb7c3afb9d1baa86a5ddd8d36f3d81220d18dc49a1 SHA512 d415859bc46deb3dcf5e845af88689c507d6b110d6312af75145d6c46cc277ca2d17ae6a0f506c09ca7d543c5eca47b2506169bb0482ae68f2e3baef70889090
+DIST adwaita-icon-theme-3.26.1.tar.xz 20729696 BLAKE2B 428027b2e4d2662fd1c58165f68e0c2e85f3a7710897deaf309fc1774fc8ef0167188ac3cf84b9491f66671f6e236c6f8d1711ae1c2c78fdfa923a871d0c21ba SHA512 bed005074b63e72b6f4280aa5bc998099217336bed43ccc2f139ddc56f1bb83786238c3c2615254b2cd78c26cbc82114b207adeb3932add22efd39e8ca47eda6
DIST tango-gentoo-v1.1.tar.gz 29322 BLAKE2B 83fa2bf37727e60851dd679054fe1b153ebfea58c9a9a40f891f7d68d3b047b02e8effa1d1b4e08d64500a2072ce7200f159c92a352da7124de27e1b05bb6027 SHA512 87d47ddab68361db6d99866c51705dcb3e198f8345a1096859acf2c6cca5099dd23c7fb30d124f52c4933ea38fd45fadffbbe6ecbdfa84f5b60938a4824f9045
diff --git a/x11-themes/adwaita-icon-theme/adwaita-icon-theme-3.26.1.ebuild b/x11-themes/adwaita-icon-theme/adwaita-icon-theme-3.26.1.ebuild
new file mode 100644
index 000000000000..237c5b413d88
--- /dev/null
+++ b/x11-themes/adwaita-icon-theme/adwaita-icon-theme-3.26.1.ebuild
@@ -0,0 +1,58 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="6"
+
+inherit gnome2
+
+DESCRIPTION="GNOME default icon theme"
+HOMEPAGE="https://git.gnome.org/browse/adwaita-icon-theme/"
+
+SRC_URI="${SRC_URI}
+ branding? ( https://www.mail-archive.com/tango-artists@lists.freedesktop.org/msg00043/tango-gentoo-v1.1.tar.gz )
+"
+LICENSE="
+ || ( LGPL-3 CC-BY-SA-3.0 )
+ branding? ( CC-BY-SA-4.0 )
+"
+SLOT="0"
+IUSE="branding"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sh ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux ~arm-linux ~x86-linux ~sparc-solaris ~x64-solaris ~x86-solaris"
+
+# gtk+:3 is needed for build for the gtk-encode-symbolic-svg utility
+# librsvg is needed for gtk-encode-symbolic-svg to be able to read the source SVG via its pixbuf loader and at runtime for rendering scalable icons shipped by the theme
+COMMON_DEPEND="
+ >=x11-themes/hicolor-icon-theme-0.10
+ gnome-base/librsvg:2
+"
+RDEPEND="${COMMON_DEPEND}
+ !<x11-themes/gnome-themes-standard-3.14
+"
+DEPEND="${COMMON_DEPEND}
+ x11-libs/gtk+:3
+ sys-devel/gettext
+ virtual/pkgconfig
+"
+# This ebuild does not install any binaries
+RESTRICT="binchecks strip"
+
+src_prepare() {
+ if use branding; then
+ for i in 16 22 24 32 48; do
+ cp "${WORKDIR}"/tango-gentoo-v1.1/${i}x${i}/gentoo.png \
+ "${S}"/Adwaita/${i}x${i}/places/start-here.png \
+ || die "Copying gentoo logos failed"
+ done
+ fi
+
+ # Install cursors in the right place used in Gentoo
+ sed -e 's:^\(cursordir.*\)icons\(.*\):\1cursors/xorg-x11\2:' \
+ -i "${S}"/Makefile.am \
+ -i "${S}"/Makefile.in || die
+
+ gnome2_src_prepare
+}
+
+src_configure() {
+ gnome2_src_configure GTK_UPDATE_ICON_CACHE=$(type -P true)
+}