summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2017-07-29 07:18:18 +0200
committerHans de Graaff <graaff@gentoo.org>2017-07-29 07:42:06 +0200
commit22ea101fb26ee7c2ec281e82710b7ccf061d5518 (patch)
treec7f8c44f0c6aca1c3fac26ead0409c61c57b865f
parentmedia-gfx/feh: version bump to 2.19.1 (diff)
downloadgentoo-22ea101fb26ee7c2ec281e82710b7ccf061d5518.tar.gz
gentoo-22ea101fb26ee7c2ec281e82710b7ccf061d5518.tar.bz2
gentoo-22ea101fb26ee7c2ec281e82710b7ccf061d5518.zip
dev-ruby/mixlib-shellout: add 2.3.2
Package-Manager: Portage-2.3.6, Repoman-2.3.2
-rw-r--r--dev-ruby/mixlib-shellout/Manifest1
-rw-r--r--dev-ruby/mixlib-shellout/mixlib-shellout-2.3.2.ebuild26
2 files changed, 27 insertions, 0 deletions
diff --git a/dev-ruby/mixlib-shellout/Manifest b/dev-ruby/mixlib-shellout/Manifest
index 47a7de2a0284..a91ca44d3aba 100644
--- a/dev-ruby/mixlib-shellout/Manifest
+++ b/dev-ruby/mixlib-shellout/Manifest
@@ -1 +1,2 @@
DIST mixlib-shellout-2.2.7.tar.gz 35122 SHA256 9fc9cd467d27ac3cb50cb3993a55d1aeb04ec92e74de4b2d73d839bce9f2e6e9 SHA512 e1179e296471d3aa0c22f2d7a9dfd957da4870f7fd5456c9f6788fca6a1efc62487fd719e45a6c3f85539db46cad0fbf4a67eddac087393004a179a19ce36fa3 WHIRLPOOL 35e98ebedb21c5a5852cac4d734ea90206a1a727c2884a82411126b42d03ef39ef611447240ba8ebe7b0b91448fc86d501eb83ef709a194d5115bd632ff4132e
+DIST mixlib-shellout-2.3.2.tar.gz 35828 SHA256 b80209525ae4232c9e6a51c3c0c508a9cec89958553a79a323babc63099ba399 SHA512 72f4979d1c444b1f097ecfd4767a2989e60398e84a78106b80077b664bc01d6fc68022cec26172f1e7c0384dd3fc4f64c723ad3a2882db7284dbadacc7cf24c9 WHIRLPOOL df320d02a6b29578ba8989f48cfffb3292ca353fe0f023aace1579f48908c5d620b52f74c586e5b8c634e77ad6500f3869e806cfb8f4895c6f5341bd47da4d1a
diff --git a/dev-ruby/mixlib-shellout/mixlib-shellout-2.3.2.ebuild b/dev-ruby/mixlib-shellout/mixlib-shellout-2.3.2.ebuild
new file mode 100644
index 000000000000..adcdf80bf37e
--- /dev/null
+++ b/dev-ruby/mixlib-shellout/mixlib-shellout-2.3.2.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+USE_RUBY="ruby21 ruby22 ruby23 ruby24"
+
+RUBY_FAKEGEM_TASK_DOC=""
+RUBY_FAKEGEM_RECIPE_TEST="rspec3"
+
+RUBY_FAKEGEM_EXTRA_DOC="CHANGELOG.md README.md"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Run external commands on Unix or Windows"
+HOMEPAGE="https://github.com/opscode/mixlib-shellout"
+SRC_URI="https://github.com/opscode/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+each_ruby_prepare() {
+ # Make sure we actually use the right interpreter for testing
+ sed -i -e "/ruby_eval/ s:ruby :${RUBY} :" spec/mixlib/shellout_spec.rb || die
+}