summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSebastian Pipping <sping@gentoo.org>2020-01-13 19:43:16 +0100
committerSebastian Pipping <sping@gentoo.org>2020-01-13 19:46:08 +0100
commit230057ed14012fd2fdc8282dbc99f0ddcb2b9198 (patch)
tree14e3e5eb34f6b9c0138da30eb8a01f94a2a6a2c6
parentsys-apps/util-linux: Python 3.8 compatibility (diff)
downloadgentoo-230057ed14012fd2fdc8282dbc99f0ddcb2b9198.tar.gz
gentoo-230057ed14012fd2fdc8282dbc99f0ddcb2b9198.tar.bz2
gentoo-230057ed14012fd2fdc8282dbc99f0ddcb2b9198.zip
dev-python/beautifulsoup: 4.8.2
Signed-off-by: Sebastian Pipping <sping@gentoo.org> Package-Manager: Portage-2.3.84, Repoman-2.3.20
-rw-r--r--dev-python/beautifulsoup/Manifest1
-rw-r--r--dev-python/beautifulsoup/beautifulsoup-4.8.2.ebuild36
2 files changed, 37 insertions, 0 deletions
diff --git a/dev-python/beautifulsoup/Manifest b/dev-python/beautifulsoup/Manifest
index 940c2cc10de9..5778b158fe08 100644
--- a/dev-python/beautifulsoup/Manifest
+++ b/dev-python/beautifulsoup/Manifest
@@ -2,3 +2,4 @@ DIST BeautifulSoup-3.2.1.tar.gz 31224 BLAKE2B 9361ce6d048d0443c3257d10ec2734c242
DIST beautifulsoup4-4.5.1.tar.gz 158039 BLAKE2B 5eb99c7efdb13c359385c7c7f3280332ca28cc4b5ff80b90c326d80ef55acef8e98d86691a7b1df420bf68bc65e96ad7d559b461a03f44e494fb4b7789753601 SHA512 d560d7f743507084ec546708d29bb3764512f5b2c380004280dde813350bf48d1697fddce3bd3f95186407bf5142941d7adc7d0de8e7962eb5ca1278dbc7e93f
DIST beautifulsoup4-4.6.3.tar.gz 167469 BLAKE2B 0bc8f729298a2fd1e8f3cc8a7635587217f9a2e6e2c71709e99c40eedf1ebb4d76cd0d17ec36b99f3ee047193e4d44e31b8d2aa9864c43ce5db380fbdc083f76 SHA512 0cacae77843326ebee87d108b6706a7ca6943684bcccc62554d2ae5d77dfd181c97435ceca9d3e2e51962b024bbe52bc08d7f0dc516311aa87b3a1f87fb4ae23
DIST beautifulsoup4-4.8.1.tar.gz 159164 BLAKE2B 00121e9b30f700ade0bb2ec8f637b4173ecb4c187b8f9a77bcc4e6b333fced85a699c8d9efa5b757ab02f54c2b05740702c13625ff427730ccc1f6a97f43fa48 SHA512 7abc5e84cb8da5428dafc6b473418d0cc72b518cb1a73d4ae58b8dad3ec985e5778629dc1d7c8374dfb223be981983c745a1dbb55a98078b4cfe7ba5ce25539b
+DIST beautifulsoup4-4.8.2.tar.gz 298650 BLAKE2B 6826abf793efa63be89d844bc25bdb105413196bfab21c18f3816fd59a7a771459bf2c7ee209b75b0c88dfa14da8f4625c948889acfb48502e2260ccca229675 SHA512 aab90eb22614e9a2fb47792389a951b3ad7faf9791e15984a6c27a38be6f3d0ccbf3a9753d9afb5c70105097ac1a9c5f9e07206e12c6d4cb7a7f6d4e90ec18c2
diff --git a/dev-python/beautifulsoup/beautifulsoup-4.8.2.ebuild b/dev-python/beautifulsoup/beautifulsoup-4.8.2.ebuild
new file mode 100644
index 000000000000..712974a6956d
--- /dev/null
+++ b/dev-python/beautifulsoup/beautifulsoup-4.8.2.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python{2_7,3_{6,7,8}} pypy3 )
+
+inherit distutils-r1
+
+MY_PN="${PN}4"
+MY_P="${MY_PN}-${PV}"
+
+DESCRIPTION="Pythonic idioms for iterating, searching, and modifying an HTML/XML parse tree"
+HOMEPAGE="https://www.crummy.com/software/BeautifulSoup/bs4/"
+SRC_URI="mirror://pypi/${MY_P:0:1}/${MY_PN}/${MY_P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="4"
+KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86"
+
+# html5lib is optional however hard coding since its use is actively discouraged in the devmanual
+RDEPEND="
+ dev-python/soupsieve[${PYTHON_USEDEP}]
+ $(python_gen_cond_dep 'dev-python/html5lib[${PYTHON_USEDEP}]' python2_7 pypy)
+ $(python_gen_cond_dep 'dev-python/lxml[${PYTHON_USEDEP}]' python2_7 'python3*')
+"
+BDEPEND="${RDEPEND}"
+
+S="${WORKDIR}/${MY_P}"
+
+distutils_enable_tests nose
+distutils_enable_sphinx doc/source --no-autodoc
+
+python_test() {
+ nosetests --verbose -w "${BUILD_DIR}"/lib || die "Tests fail with ${EPYTHON}"
+}