summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2015-11-10 20:26:49 -0500
committerMike Frysinger <vapier@gentoo.org>2015-11-10 20:53:23 -0500
commit2347c6fe886c6b89d93ffac0faf375a613c372b1 (patch)
tree9ac1ed0abe7e86cbfe62a110a23675af21655134
parentnet-libs/mbedtls: version bump to 2.1.3 (diff)
downloadgentoo-2347c6fe886c6b89d93ffac0faf375a613c372b1.tar.gz
gentoo-2347c6fe886c6b89d93ffac0faf375a613c372b1.tar.bz2
gentoo-2347c6fe886c6b89d93ffac0faf375a613c372b1.zip
avoid using ${var^} and ${var,} as they do not work in bash-3.2
Once these upgrade to EAPI=6, they can use these case modification features, so leave a reminder note in there.
-rw-r--r--app-admin/yaala/yaala-0.7.3-r1.ebuild21
-rw-r--r--app-office/calligra/calligra-2.9.6.ebuild5
-rw-r--r--app-office/calligra/calligra-2.9.7.ebuild5
-rw-r--r--app-office/calligra/calligra-9999.ebuild5
-rw-r--r--app-text/searchmonkey/searchmonkey-2.0.0.ebuild5
-rw-r--r--dev-db/SchemaSync/SchemaSync-0.9.2.ebuild6
-rw-r--r--dev-java/groovy/groovy-2.4.5.ebuild4
-rw-r--r--dev-python/SchemaObject/SchemaObject-0.5.3.ebuild6
-rw-r--r--dev-python/cvxopt/cvxopt-1.1.6-r2.ebuild8
-rw-r--r--dev-scheme/gauche-gl/gauche-gl-0.5.1.ebuild5
-rw-r--r--dev-scheme/gauche-gl/gauche-gl-0.6.ebuild5
-rw-r--r--dev-scheme/gauche/gauche-0.9.3.3.ebuild5
-rw-r--r--dev-scheme/gauche/gauche-0.9.4-r1.ebuild3
-rw-r--r--dev-vcs/cssc/cssc-1.4.0.ebuild11
-rw-r--r--eclass/cvs.eclass4
-rw-r--r--games-board/gambit/gambit-1.0.1.ebuild12
-rw-r--r--games-board/gambit/gambit-1.0.3.ebuild12
-rw-r--r--games-fps/xonotic/xonotic-0.8.0.ebuild3
-rw-r--r--games-fps/xonotic/xonotic-0.8.1.ebuild5
-rw-r--r--media-sound/clementine/clementine-1.2.2.ebuild3
-rw-r--r--media-sound/clementine/clementine-1.2.3.ebuild3
-rw-r--r--media-sound/clementine/clementine-9999.ebuild3
-rw-r--r--net-analyzer/apinger/apinger-0.4.1.ebuild9
-rw-r--r--net-dns/dnsmasq/dnsmasq-2.66.ebuild6
-rw-r--r--net-dns/dnsmasq/dnsmasq-2.72-r2.ebuild4
-rw-r--r--net-dns/dnsmasq/dnsmasq-2.75.ebuild4
-rw-r--r--sci-mathematics/sha1-polyml/sha1-polyml-5.5.0.ebuild10
-rw-r--r--sys-devel/byfl/byfl-1.4.ebuild3
-rw-r--r--sys-devel/byfl/byfl-9999.ebuild3
29 files changed, 119 insertions, 59 deletions
diff --git a/app-admin/yaala/yaala-0.7.3-r1.ebuild b/app-admin/yaala/yaala-0.7.3-r1.ebuild
index 22d252f61c3c..0b19caef71b4 100644
--- a/app-admin/yaala/yaala-0.7.3-r1.ebuild
+++ b/app-admin/yaala/yaala-0.7.3-r1.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2013 Gentoo Foundation
+# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$
@@ -28,17 +28,20 @@ src_prepare() {
src_install() {
dobin ${PN}
- exeinto /usr/lib64/perl5/vendor_perl/${PN^}/
- doexe lib/${PN^}/*.pm
+ # Switch to ^y when we switch to EAPI=6.
+ local mod="Y${PN:1}"
- exeinto /usr/lib64/perl5/vendor_perl/${PN^}/Data/
- doexe lib/${PN^}/Data/*.pm
+ exeinto /usr/lib64/perl5/vendor_perl/${mod}/
+ doexe lib/${mod}/*.pm
- exeinto /usr/lib64/perl5/vendor_perl/${PN^}/Parser/
- doexe lib/${PN^}/Parser/*.pm
+ exeinto /usr/lib64/perl5/vendor_perl/${mod}/Data/
+ doexe lib/${mod}/Data/*.pm
- exeinto /usr/lib64/perl5/vendor_perl/${PN^}/Report/
- doexe lib/${PN^}/Report/*.pm
+ exeinto /usr/lib64/perl5/vendor_perl/${mod}/Parser/
+ doexe lib/${mod}/Parser/*.pm
+
+ exeinto /usr/lib64/perl5/vendor_perl/${mod}/Report/
+ doexe lib/${mod}/Report/*.pm
dodoc AUTHORS CHANGELOG README{,.persistency,.selections}
diff --git a/app-office/calligra/calligra-2.9.6.ebuild b/app-office/calligra/calligra-2.9.6.ebuild
index 4031e5beaaa6..ea5198b88d15 100644
--- a/app-office/calligra/calligra-2.9.6.ebuild
+++ b/app-office/calligra/calligra-2.9.6.ebuild
@@ -160,7 +160,10 @@ src_configure() {
# applications
for cal_ft in ${CAL_FTS}; do
- use calligra_features_${cal_ft} && myproducts+=( ${cal_ft^^} )
+ # Switch to ^^ when we switch to EAPI=6.
+ #local prod=${cal_ft^^}
+ local prod=$(tr '[:lower:]' '[:upper:]' <<<"${cal_ft}")
+ use calligra_features_${cal_ft} && myproducts+=( "${prod}" )
done
local mycmakeargs=( -DPRODUCTSET="${myproducts[*]}" )
diff --git a/app-office/calligra/calligra-2.9.7.ebuild b/app-office/calligra/calligra-2.9.7.ebuild
index 97cea479c13f..0822a6951c58 100644
--- a/app-office/calligra/calligra-2.9.7.ebuild
+++ b/app-office/calligra/calligra-2.9.7.ebuild
@@ -157,7 +157,10 @@ src_configure() {
# applications
for cal_ft in ${CAL_FTS}; do
- use calligra_features_${cal_ft} && myproducts+=( ${cal_ft^^} )
+ # Switch to ^^ when we switch to EAPI=6.
+ #local prod=${cal_ft^^}
+ local prod=$(tr '[:lower:]' '[:upper:]' <<<"${cal_ft}")
+ use calligra_features_${cal_ft} && myproducts+=( "${prod}" )
done
local mycmakeargs=( -DPRODUCTSET="${myproducts[*]}" )
diff --git a/app-office/calligra/calligra-9999.ebuild b/app-office/calligra/calligra-9999.ebuild
index 97cea479c13f..0822a6951c58 100644
--- a/app-office/calligra/calligra-9999.ebuild
+++ b/app-office/calligra/calligra-9999.ebuild
@@ -157,7 +157,10 @@ src_configure() {
# applications
for cal_ft in ${CAL_FTS}; do
- use calligra_features_${cal_ft} && myproducts+=( ${cal_ft^^} )
+ # Switch to ^^ when we switch to EAPI=6.
+ #local prod=${cal_ft^^}
+ local prod=$(tr '[:lower:]' '[:upper:]' <<<"${cal_ft}")
+ use calligra_features_${cal_ft} && myproducts+=( "${prod}" )
done
local mycmakeargs=( -DPRODUCTSET="${myproducts[*]}" )
diff --git a/app-text/searchmonkey/searchmonkey-2.0.0.ebuild b/app-text/searchmonkey/searchmonkey-2.0.0.ebuild
index 9bf17458ddd1..89c1cf9e730c 100644
--- a/app-text/searchmonkey/searchmonkey-2.0.0.ebuild
+++ b/app-text/searchmonkey/searchmonkey-2.0.0.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2013 Gentoo Foundation
+# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$
@@ -11,7 +11,8 @@ MY_P=${PN}_v${PV}
DESCRIPTION="Powerful text searches using regular expressions"
HOMEPAGE="http://searchmonkey.sourceforge.net/"
-SRC_URI="mirror://sourceforge/project/${PN}/${MY_PN^}/${PV}%20%5Bstable%5D/${MY_P}.zip"
+# Switch to ^s when we switch to EAPI=6.
+SRC_URI="mirror://sourceforge/project/${PN}/S${MY_PN:1}/${PV}%20%5Bstable%5D/${MY_P}.zip"
LICENSE="GPL-3"
SLOT="2"
diff --git a/dev-db/SchemaSync/SchemaSync-0.9.2.ebuild b/dev-db/SchemaSync/SchemaSync-0.9.2.ebuild
index d11c55cae690..2769787743be 100644
--- a/dev-db/SchemaSync/SchemaSync-0.9.2.ebuild
+++ b/dev-db/SchemaSync/SchemaSync-0.9.2.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2014 Gentoo Foundation
+# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$
@@ -12,7 +12,9 @@ DESCRIPTION="MySQL Schema Versioning and Migration Utility"
HOMEPAGE="http://schemasync.org/"
SRC_URI="http://www.schemasync.org/downloads/${P}.tar.gz"
-pn="${PN,,}"
+# Switch to ,, when we switch to EAPI=6.
+#pn="${PN,,}"
+pn="schemasync"
LICENSE="Apache-2.0"
SLOT="0"
diff --git a/dev-java/groovy/groovy-2.4.5.ebuild b/dev-java/groovy/groovy-2.4.5.ebuild
index 62183ff87c6d..d6d53f01fc77 100644
--- a/dev-java/groovy/groovy-2.4.5.ebuild
+++ b/dev-java/groovy/groovy-2.4.5.ebuild
@@ -7,7 +7,9 @@ JAVA_PKG_IUSE="doc source"
inherit java-pkg-2 java-pkg-simple versionator
-MY_PN="${PN^^}"
+# Switch to ^^ when we switch to EAPI=6.
+#MY_PN="${PN^^}"
+MY_PN="GROOVY"
MY_PV="$(replace_all_version_separators _ ${PV})"
MY_P="${MY_PN}_${MY_PV}"
diff --git a/dev-python/SchemaObject/SchemaObject-0.5.3.ebuild b/dev-python/SchemaObject/SchemaObject-0.5.3.ebuild
index 5cb07d3f8834..6c56950b7f63 100644
--- a/dev-python/SchemaObject/SchemaObject-0.5.3.ebuild
+++ b/dev-python/SchemaObject/SchemaObject-0.5.3.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2014 Gentoo Foundation
+# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$
@@ -12,7 +12,9 @@ DESCRIPTION="A simple Python object interface to a MySQL database schema"
HOMEPAGE="http://matuson.com/code/schemaobject/"
SRC_URI="http://www.matuson.com/code/schemaobject/downloads/${P}.tar.gz"
-pn="${PN,,}"
+# Switch to ,, when we switch to EAPI=6.
+#pn="${PN,,}"
+pn="schemaobject"
S="${WORKDIR}/${pn}"
LICENSE="Apache-2.0"
diff --git a/dev-python/cvxopt/cvxopt-1.1.6-r2.ebuild b/dev-python/cvxopt/cvxopt-1.1.6-r2.ebuild
index 256fcd3eb840..150ba1525895 100644
--- a/dev-python/cvxopt/cvxopt-1.1.6-r2.ebuild
+++ b/dev-python/cvxopt/cvxopt-1.1.6-r2.ebuild
@@ -61,9 +61,13 @@ python_prepare_all(){
}
use_cvx() {
- if use $1 ; then
+ local flag=$1
+ if use ${flag} ; then
+ # Switch to ^^ when we switch to EAPI=6.
+ #local uflag=${flag^^}
+ local uflag=$(tr '[:lower:]' '[:upper:]' <<<"${flag}")
sed -i \
- -e "s/\(BUILD_${1^^} =\) 0/\1 1/" \
+ -e "s/\(BUILD_${uflag} =\) 0/\1 1/" \
setup.py || die
fi
}
diff --git a/dev-scheme/gauche-gl/gauche-gl-0.5.1.ebuild b/dev-scheme/gauche-gl/gauche-gl-0.5.1.ebuild
index 14215b85d0a2..3b670e5c3cdf 100644
--- a/dev-scheme/gauche-gl/gauche-gl-0.5.1.ebuild
+++ b/dev-scheme/gauche-gl/gauche-gl-0.5.1.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2014 Gentoo Foundation
+# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$
@@ -6,7 +6,8 @@ EAPI="5"
inherit eutils
-MY_P="${P^g}"
+# Switch to ^g when we switch to EAPI=6.
+MY_P="G${P:1}"
DESCRIPTION="OpenGL binding for Gauche"
HOMEPAGE="http://practical-scheme.net/gauche/"
diff --git a/dev-scheme/gauche-gl/gauche-gl-0.6.ebuild b/dev-scheme/gauche-gl/gauche-gl-0.6.ebuild
index 45b7fe38815d..57687ddbac7c 100644
--- a/dev-scheme/gauche-gl/gauche-gl-0.6.ebuild
+++ b/dev-scheme/gauche-gl/gauche-gl-0.6.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2014 Gentoo Foundation
+# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$
@@ -6,7 +6,8 @@ EAPI="5"
inherit eutils
-MY_P="${P^g}"
+# Switch to ^g when we switch to EAPI=6.
+MY_P="G${P:1}"
DESCRIPTION="OpenGL binding for Gauche"
HOMEPAGE="http://practical-scheme.net/gauche/"
diff --git a/dev-scheme/gauche/gauche-0.9.3.3.ebuild b/dev-scheme/gauche/gauche-0.9.3.3.ebuild
index ee0aa0df3978..da7ad5f7fea6 100644
--- a/dev-scheme/gauche/gauche-0.9.3.3.ebuild
+++ b/dev-scheme/gauche/gauche-0.9.3.3.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2014 Gentoo Foundation
+# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$
@@ -6,7 +6,8 @@ EAPI="5"
inherit autotools eutils
-MY_P="${P^g}"
+# Switch to ^g when we switch to EAPI=6.
+MY_P="G${P:1}"
DESCRIPTION="A Unix system friendly Scheme Interpreter"
HOMEPAGE="http://practical-scheme.net/gauche/"
diff --git a/dev-scheme/gauche/gauche-0.9.4-r1.ebuild b/dev-scheme/gauche/gauche-0.9.4-r1.ebuild
index edcf1be6c676..2dbbe970ca2f 100644
--- a/dev-scheme/gauche/gauche-0.9.4-r1.ebuild
+++ b/dev-scheme/gauche/gauche-0.9.4-r1.ebuild
@@ -6,7 +6,8 @@ EAPI="5"
inherit autotools eutils
-MY_P="${P^g}"
+# Switch to ^g when we switch to EAPI=6.
+MY_P="G${P:1}"
DESCRIPTION="A Unix system friendly Scheme Interpreter"
HOMEPAGE="http://practical-scheme.net/gauche/"
diff --git a/dev-vcs/cssc/cssc-1.4.0.ebuild b/dev-vcs/cssc/cssc-1.4.0.ebuild
index 4435d37edee4..3d138e2a56eb 100644
--- a/dev-vcs/cssc/cssc-1.4.0.ebuild
+++ b/dev-vcs/cssc/cssc-1.4.0.ebuild
@@ -1,12 +1,17 @@
-# Copyright 1999-2014 Gentoo Foundation
+# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$
EAPI=5
inherit autotools eutils
+# Switch to ^^ when we switch to EAPI=6.
+#MY_PN="${PN^^}"
+MY_PN="CSSC"
+MY_P="${MY_PN}-${PV}"
+
DESCRIPTION="The GNU Project's replacement for SCCS"
-SRC_URI="mirror://gnu/${PN}/${P^^}.tar.gz"
+SRC_URI="mirror://gnu/${PN}/${MY_P}.tar.gz"
HOMEPAGE="https://www.gnu.org/software/cssc/"
SLOT="0"
LICENSE="GPL-3"
@@ -20,7 +25,7 @@ DEPEND="
DOCS=( AUTHORS ChangeLog NEWS README )
-S="${WORKDIR}/${P^^}"
+S="${WORKDIR}/${MY_P}"
src_prepare() {
epatch \
diff --git a/eclass/cvs.eclass b/eclass/cvs.eclass
index b9c8a818b6ca..58efcf1aa2b6 100644
--- a/eclass/cvs.eclass
+++ b/eclass/cvs.eclass
@@ -1,4 +1,4 @@
-# Copyright 1999-2014 Gentoo Foundation
+# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$
@@ -566,7 +566,7 @@ cvs_src_unpack() {
# Implement some of base_src_unpack's functionality; note however
# that base.eclass may not have been inherited!
if [[ -n ${PATCHES} ]] ; then
- debug-print "${FUNCNAME}: PATCHES=${PATCHES,} S=${S}, autopatching"
+ debug-print "${FUNCNAME}: PATCHES=${PATCHES}, S=${S}, autopatching"
cd "${S}"
epatch ${PATCHES}
# Make sure we don't try to apply patches more than once,
diff --git a/games-board/gambit/gambit-1.0.1.ebuild b/games-board/gambit/gambit-1.0.1.ebuild
index 9a55d662d015..cd8832041c26 100644
--- a/games-board/gambit/gambit-1.0.1.ebuild
+++ b/games-board/gambit/gambit-1.0.1.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2014 Gentoo Foundation
+# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$
@@ -7,9 +7,12 @@ EAPI="5"
CMAKE_IN_SOURCE_BUILD=true
inherit cmake-utils games
+# Switch to ^ when we switch to EAPI=6.
+MY_P="G${P:1}"
+
DESCRIPTION="Qt-based chess application + engine \"gupta\""
HOMEPAGE="http://sourceforge.net/projects/gambitchess/"
-SRC_URI="mirror://sourceforge/project/${PN}chess/${PN^}-${PV}/${PN^}-${PV}-src.tar.bz2"
+SRC_URI="mirror://sourceforge/project/${PN}chess/${MY_P}/${MY_P}-src.tar.bz2"
LICENSE="CC0-1.0"
SLOT="0"
@@ -23,7 +26,7 @@ DEPEND="dev-qt/qtcore:4
x11-libs/libX11"
RDEPEND="${DEPEND}"
-S="${WORKDIR}"/${PN^}-${PV}-src
+S="${WORKDIR}/${MY_P}-src"
src_configure() {
local mycmakeargs=(
@@ -45,7 +48,8 @@ src_install() {
doins -r data/* || die
doicon artwork/icons/${PN}/${PN}.svg
- make_desktop_entry ${PN}chess ${PN^} ${PN} Game || die
+ # Switch to ^ when we switch to EAPI=6.
+ make_desktop_entry ${PN}chess G${PN:1} ${PN} Game || die
dodoc doc/contributors.txt || die
dogamesbin engine/gupta/gupta || die
diff --git a/games-board/gambit/gambit-1.0.3.ebuild b/games-board/gambit/gambit-1.0.3.ebuild
index 9a55d662d015..cd8832041c26 100644
--- a/games-board/gambit/gambit-1.0.3.ebuild
+++ b/games-board/gambit/gambit-1.0.3.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2014 Gentoo Foundation
+# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$
@@ -7,9 +7,12 @@ EAPI="5"
CMAKE_IN_SOURCE_BUILD=true
inherit cmake-utils games
+# Switch to ^ when we switch to EAPI=6.
+MY_P="G${P:1}"
+
DESCRIPTION="Qt-based chess application + engine \"gupta\""
HOMEPAGE="http://sourceforge.net/projects/gambitchess/"
-SRC_URI="mirror://sourceforge/project/${PN}chess/${PN^}-${PV}/${PN^}-${PV}-src.tar.bz2"
+SRC_URI="mirror://sourceforge/project/${PN}chess/${MY_P}/${MY_P}-src.tar.bz2"
LICENSE="CC0-1.0"
SLOT="0"
@@ -23,7 +26,7 @@ DEPEND="dev-qt/qtcore:4
x11-libs/libX11"
RDEPEND="${DEPEND}"
-S="${WORKDIR}"/${PN^}-${PV}-src
+S="${WORKDIR}/${MY_P}-src"
src_configure() {
local mycmakeargs=(
@@ -45,7 +48,8 @@ src_install() {
doins -r data/* || die
doicon artwork/icons/${PN}/${PN}.svg
- make_desktop_entry ${PN}chess ${PN^} ${PN} Game || die
+ # Switch to ^ when we switch to EAPI=6.
+ make_desktop_entry ${PN}chess G${PN:1} ${PN} Game || die
dodoc doc/contributors.txt || die
dogamesbin engine/gupta/gupta || die
diff --git a/games-fps/xonotic/xonotic-0.8.0.ebuild b/games-fps/xonotic/xonotic-0.8.0.ebuild
index a725428083a0..4fa4fedf5e36 100644
--- a/games-fps/xonotic/xonotic-0.8.0.ebuild
+++ b/games-fps/xonotic/xonotic-0.8.0.ebuild
@@ -5,7 +5,8 @@
EAPI=5
inherit eutils check-reqs games
-MY_PN="${PN^}"
+# Switch to ^ when we switch to EAPI=6.
+MY_PN="X${PN:1}"
DESCRIPTION="Fork of Nexuiz, Deathmatch FPS based on DarkPlaces, an advanced Quake 1 engine"
HOMEPAGE="http://www.xonotic.org/"
SRC_URI="http://dl.xonotic.org/${P}.zip"
diff --git a/games-fps/xonotic/xonotic-0.8.1.ebuild b/games-fps/xonotic/xonotic-0.8.1.ebuild
index cea73568b1de..1cf837c624b0 100644
--- a/games-fps/xonotic/xonotic-0.8.1.ebuild
+++ b/games-fps/xonotic/xonotic-0.8.1.ebuild
@@ -1,11 +1,12 @@
-# Copyright 1999-2014 Gentoo Foundation
+# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$
EAPI=5
inherit eutils check-reqs toolchain-funcs games
-MY_PN="${PN^}"
+# Switch to ^ when we switch to EAPI=6.
+MY_PN="X${PN:1}"
DESCRIPTION="Fork of Nexuiz, Deathmatch FPS based on DarkPlaces, an advanced Quake 1 engine"
HOMEPAGE="http://www.xonotic.org/"
SRC_URI="http://dl.xonotic.org/${P}.zip"
diff --git a/media-sound/clementine/clementine-1.2.2.ebuild b/media-sound/clementine/clementine-1.2.2.ebuild
index 9a65d1032530..9eb2fe105b3e 100644
--- a/media-sound/clementine/clementine-1.2.2.ebuild
+++ b/media-sound/clementine/clementine-1.2.2.ebuild
@@ -87,8 +87,9 @@ DOCS="Changelog"
# https://github.com/clementine-player/Clementine/issues/3935
RESTRICT="test"
+# Switch to ^ when we switch to EAPI=6.
[[ ${PV} == *9999* ]] || \
-S="${WORKDIR}/${P^}"
+S="${WORKDIR}/C${P:1}"
PATCHES=(
"${FILESDIR}"/${P}-fix-build.patch
diff --git a/media-sound/clementine/clementine-1.2.3.ebuild b/media-sound/clementine/clementine-1.2.3.ebuild
index 22d7690b0239..ace65742d613 100644
--- a/media-sound/clementine/clementine-1.2.3.ebuild
+++ b/media-sound/clementine/clementine-1.2.3.ebuild
@@ -90,8 +90,9 @@ DOCS="Changelog"
# https://github.com/clementine-player/Clementine/issues/3935
RESTRICT="test"
+# Switch to ^ when we switch to EAPI=6.
[[ ${PV} == *9999* ]] || \
-S="${WORKDIR}/${P^}"
+S="${WORKDIR}/C${P:1}"
PATCHES=(
"${FILESDIR}/${PN}-1.2.3-namespaces.patch"
diff --git a/media-sound/clementine/clementine-9999.ebuild b/media-sound/clementine/clementine-9999.ebuild
index e8970fff8f50..e1e83c0137eb 100644
--- a/media-sound/clementine/clementine-9999.ebuild
+++ b/media-sound/clementine/clementine-9999.ebuild
@@ -88,8 +88,9 @@ DOCS="Changelog"
# https://github.com/clementine-player/Clementine/issues/3935
RESTRICT="test"
+# Switch to ^ when we switch to EAPI=6.
[[ ${PV} == *9999* ]] || \
-S="${WORKDIR}/${P^}"
+S="${WORKDIR}/C${P:1}"
src_prepare() {
cmake-utils_src_prepare
diff --git a/net-analyzer/apinger/apinger-0.4.1.ebuild b/net-analyzer/apinger/apinger-0.4.1.ebuild
index b52981599b4f..05290113aadf 100644
--- a/net-analyzer/apinger/apinger-0.4.1.ebuild
+++ b/net-analyzer/apinger/apinger-0.4.1.ebuild
@@ -5,9 +5,14 @@
EAPI=5
inherit autotools
+# Switch to ^^ when we switch to EAPI=6.
+#MY_PN="${PN^^}"
+MY_PN="APINGER"
+MY_P="${MY_PN}_${PV//./_}"
+
DESCRIPTION="Alarm Pinger"
HOMEPAGE="https://github.com/Jajcus/apinger/"
-SRC_URI="${HOMEPAGE}archive/${PN^^}_${PV//./_}.tar.gz -> ${P}.tar.gz"
+SRC_URI="${HOMEPAGE}archive/${MY_P}.tar.gz -> ${P}.tar.gz"
LICENSE="GPL-2"
SLOT="0"
@@ -18,7 +23,7 @@ DEPEND="
virtual/yacc
"
-S=${WORKDIR}/${PN}-${PN^^}_${PV//./_}
+S="${WORKDIR}/${PN}-${MY_P}"
DOCS=( AUTHORS ChangeLog NEWS README TODO )
diff --git a/net-dns/dnsmasq/dnsmasq-2.66.ebuild b/net-dns/dnsmasq/dnsmasq-2.66.ebuild
index 74eef761c495..a5dfba9bdd5c 100644
--- a/net-dns/dnsmasq/dnsmasq-2.66.ebuild
+++ b/net-dns/dnsmasq/dnsmasq-2.66.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2014 Gentoo Foundation
+# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$
@@ -47,7 +47,9 @@ use_have() {
fi
local UWORD=${2:-$1}
- UWORD=${UWORD^^*}
+ # Switch to ^^ when we switch to EAPI=6.
+ #UWORD=${UWORD^^}
+ UWORD=$(tr '[:lower:]' '[:upper:]' <<<"${UWORD}")
if ! use ${1}; then
echo " -DNO_${UWORD}"
diff --git a/net-dns/dnsmasq/dnsmasq-2.72-r2.ebuild b/net-dns/dnsmasq/dnsmasq-2.72-r2.ebuild
index 2f14c001a891..b119b064ce72 100644
--- a/net-dns/dnsmasq/dnsmasq-2.72-r2.ebuild
+++ b/net-dns/dnsmasq/dnsmasq-2.72-r2.ebuild
@@ -69,7 +69,9 @@ use_have() {
shift
while [[ ${uword} ]]; do
- uword=${uword^^*}
+ # Switch to ^^ when we switch to EAPI=6.
+ #uword=${uword^^}
+ uword=$(tr '[:lower:]' '[:upper:]' <<<"${uword}")
if ! use "${useflag}"; then
echo -n " -DNO_${uword}"
diff --git a/net-dns/dnsmasq/dnsmasq-2.75.ebuild b/net-dns/dnsmasq/dnsmasq-2.75.ebuild
index 05bc1cd73145..ecc0a1b9d741 100644
--- a/net-dns/dnsmasq/dnsmasq-2.75.ebuild
+++ b/net-dns/dnsmasq/dnsmasq-2.75.ebuild
@@ -64,7 +64,9 @@ use_have() {
shift
while [[ ${uword} ]]; do
- uword=${uword^^*}
+ # Switch to ^^ when we switch to EAPI=6.
+ #uword=${uword^^}
+ uword=$(tr '[:lower:]' '[:upper:]' <<<"${uword}")
if ! use "${useflag}"; then
echo -n " -DNO_${uword}"
diff --git a/sci-mathematics/sha1-polyml/sha1-polyml-5.5.0.ebuild b/sci-mathematics/sha1-polyml/sha1-polyml-5.5.0.ebuild
index b8150e07cd2b..a5d68567de68 100644
--- a/sci-mathematics/sha1-polyml/sha1-polyml-5.5.0.ebuild
+++ b/sci-mathematics/sha1-polyml/sha1-polyml-5.5.0.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2012 Gentoo Foundation
+# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$
@@ -60,9 +60,11 @@ src_prepare() {
}
src_compile() {
- arch=$(uname -m)
- uos=$(uname)
- los=${uos,,}
+ local arch=$(uname -m)
+ local uos=$(uname)
+ # Switch to ,, when we switch to EAPI=6.
+ #local los=${uos,,}
+ local los=$(tr '[:upper:]' '[:lower:]' <<<"${uos}")
./build "${arch}-${los}" || die "build failed"
}
diff --git a/sys-devel/byfl/byfl-1.4.ebuild b/sys-devel/byfl/byfl-1.4.ebuild
index e57a7eac468c..4744ebfed7ff 100644
--- a/sys-devel/byfl/byfl-1.4.ebuild
+++ b/sys-devel/byfl/byfl-1.4.ebuild
@@ -8,7 +8,8 @@ inherit autotools-utils flag-o-matic
if [ "${PV}" = "9999" ]; then
LLVM_VERSION="3.7.0"
- EGIT_REPO_URI="git://github.com/losalamos/${PN^b}.git https://github.com/losalamos/${PN}.git"
+ # Switch to ^b when we switch to EAPI=6.
+ EGIT_REPO_URI="git://github.com/losalamos/B${PN:1}.git https://github.com/losalamos/${PN}.git"
inherit git-2
KEYWORDS=""
AUTOTOOLS_AUTORECONF=1
diff --git a/sys-devel/byfl/byfl-9999.ebuild b/sys-devel/byfl/byfl-9999.ebuild
index e57a7eac468c..4744ebfed7ff 100644
--- a/sys-devel/byfl/byfl-9999.ebuild
+++ b/sys-devel/byfl/byfl-9999.ebuild
@@ -8,7 +8,8 @@ inherit autotools-utils flag-o-matic
if [ "${PV}" = "9999" ]; then
LLVM_VERSION="3.7.0"
- EGIT_REPO_URI="git://github.com/losalamos/${PN^b}.git https://github.com/losalamos/${PN}.git"
+ # Switch to ^b when we switch to EAPI=6.
+ EGIT_REPO_URI="git://github.com/losalamos/B${PN:1}.git https://github.com/losalamos/${PN}.git"
inherit git-2
KEYWORDS=""
AUTOTOOLS_AUTORECONF=1