summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorManuel Ullmann <labre@posteo.de>2018-01-17 04:07:30 +0100
committerJames Le Cuirot <chewi@gentoo.org>2018-01-21 16:38:49 +0000
commit236a0950a8bc82c58c494c8a373855cdd8f6f87d (patch)
tree7d74fb0e4d412c1b8f324f7b0c2dbb4689a40f82
parentdev-java/oracle-jre-bin: version bump to 1.8.0.162 (diff)
downloadgentoo-236a0950a8bc82c58c494c8a373855cdd8f6f87d.tar.gz
gentoo-236a0950a8bc82c58c494c8a373855cdd8f6f87d.tar.bz2
gentoo-236a0950a8bc82c58c494c8a373855cdd8f6f87d.zip
dev-java/java-sdk-docs: version bump to 1.8.0.162
Package-Manager: Portage-2.3.13, Repoman-2.3.3 Closes: https://github.com/gentoo/gentoo/pull/6886
-rw-r--r--dev-java/java-sdk-docs/Manifest1
-rw-r--r--dev-java/java-sdk-docs/java-sdk-docs-1.8.0.162.ebuild44
2 files changed, 45 insertions, 0 deletions
diff --git a/dev-java/java-sdk-docs/Manifest b/dev-java/java-sdk-docs/Manifest
index 7eb610ed6e56..9a54e9222c7e 100644
--- a/dev-java/java-sdk-docs/Manifest
+++ b/dev-java/java-sdk-docs/Manifest
@@ -1,2 +1,3 @@
DIST jdk-8u152-docs-all.zip 93495668 BLAKE2B 9bb791ef4ace0fd180953e12501900a21583cf9cd8c256246c0d8b1fe139aa7c21fffd073cf6cfc27c206f00eb9d77fd510f8ced752f7c690a4762a9f52f3e8d SHA512 5aa49103685fc466bf2c5ff32aeee9ccf5b51359bb8e558bc8f23dc399fb108cba7fd282b669ce3b8062865fc4507afc809f8fb0ca844587eb168ad44c69ad77
+DIST jdk-8u162-docs-all.zip 93476221 BLAKE2B bf871623cbf3bebd123edf73844d574cb9b88b4117a1c3a976654693e923c1a34249b5ef0c6c7812be29ed8581a1699b53536550583e666f844239ba554a1225 SHA512 944b93db6a2b471c2507786c45c50715222ad904c0f537c0e3cdf47a4b05ce560f8543377fe1c2217a79e064453aefdd70fafd32534131da2f246f6e39e60ebb
DIST jdk-9.0.4_doc-all.zip 70500089 BLAKE2B 549da2c6baf1b39082f05d42d0fd02f7682a765c1d43a605063b155b3b3e2e20053b4044a238afb41c758700efa5de9ec53c29e2e8be1d682c2e9e7b221c0875 SHA512 7d8b40499a0ea91ac922c6916b19a061b39e73e54e123a943fcaa75fcfe66672ad445dbd789c2c9448c8cee0e7f72974ca6ad53bcaa5667547feca5791dab92b
diff --git a/dev-java/java-sdk-docs/java-sdk-docs-1.8.0.162.ebuild b/dev-java/java-sdk-docs/java-sdk-docs-1.8.0.162.ebuild
new file mode 100644
index 000000000000..d060fa7fcc62
--- /dev/null
+++ b/dev-java/java-sdk-docs/java-sdk-docs-1.8.0.162.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="6"
+
+inherit versionator
+
+DOWNLOAD_URL="http://www.oracle.com/technetwork/java/javase/documentation/jdk8-doc-downloads-2133158.html"
+
+[[ "$(get_version_component_range 4)" == 0 ]] \
+ || MY_PV_EXT="u$(get_version_component_range 4)"
+
+MY_PV="$(get_version_component_range 2)${MY_PV_EXT}"
+ORIG_NAME="jdk-${MY_PV}-docs-all.zip"
+
+DESCRIPTION="Oracle's documentation bundle (including API) for Java SE"
+HOMEPAGE="http://download.oracle.com/javase/8/docs/"
+SRC_URI="${ORIG_NAME}"
+LICENSE="oracle-java-documentation-8"
+SLOT="1.8"
+KEYWORDS="amd64 ~arm ~arm64 ~ppc64 x86 ~amd64-linux ~x86-linux"
+RESTRICT="fetch"
+
+DEPEND="app-arch/unzip"
+
+S="${WORKDIR}/docs"
+
+pkg_nofetch() {
+ einfo "Please download ${ORIG_NAME} from "
+ einfo "${DOWNLOAD_URL}"
+ einfo "(agree to the license) and place it in ${DISTDIR}"
+
+ einfo "If you find the file on the download page replaced with a higher"
+ einfo "version, please report to the bug 67266 (link below)."
+ einfo "If emerge fails because of a checksum error it is possible that"
+ einfo "the upstream release changed without renaming. Try downloading the file"
+ einfo "again (or a newer revision if available). Otherwise report this to"
+ einfo "https://bugs.gentoo.org/67266 and we will make a new revision."
+}
+
+src_install(){
+ insinto /usr/share/doc/${P}/html
+ doins -r index.html */
+}