summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlex Brandt <alunduil@gentoo.org>2016-09-03 09:40:35 -0500
committerAlex Brandt <alunduil@gentoo.org>2016-09-03 09:40:35 -0500
commit241d9e68a9c545df9d0b9618486c1db7a5ae4b66 (patch)
tree283b07bd12fa859dd61788dc35a58e9393f64eeb
parentdev-python/botocore: remove version 1.4.43 (diff)
downloadgentoo-241d9e68a9c545df9d0b9618486c1db7a5ae4b66.tar.gz
gentoo-241d9e68a9c545df9d0b9618486c1db7a5ae4b66.tar.bz2
gentoo-241d9e68a9c545df9d0b9618486c1db7a5ae4b66.zip
dev-python/mypy: add version 0.4.4
Package-Manager: portage-2.3.0
-rw-r--r--dev-python/mypy/Manifest1
-rw-r--r--dev-python/mypy/mypy-0.4.4.ebuild42
2 files changed, 43 insertions, 0 deletions
diff --git a/dev-python/mypy/Manifest b/dev-python/mypy/Manifest
index 749bde75362c..560272d24167 100644
--- a/dev-python/mypy/Manifest
+++ b/dev-python/mypy/Manifest
@@ -1,3 +1,4 @@
DIST mypy-0.4.1.tar.gz 682081 SHA256 37e94e528078fff782bfbe36c0e9cbd2ff40aa436eb335c2c75d006136aee3e7 SHA512 fafe93ba5e5989be5ebe966c9b8ca3ff899101b56407d5167ef42173374aae5f8ebf5631e573b5d45b845fe2b17488834c72e2483e68abf4992a39188ffa50a1 WHIRLPOOL 5b2f2d5d6fe00ccad93824476e55f673c9ecc8bc38b0aa2f3ce2f25850a9dca17b8bb91ad537801a6ecc0bc2ac0210282bcbd755e6c0a96cd9f8b647530cc093
DIST mypy-0.4.2.tar.gz 697919 SHA256 d39607701c226007f3bb5a7619222c6c6e7e4c4a2c565d99d44377324d2072ad SHA512 16d2f1476bc7b40c20b66aca81b3c99477394cbcbbff5541ca26179bde0634794126c0b28506ad3019d6a1c5cd0bf48292b4de0152927123ffdfb3bbbc69ee15 WHIRLPOOL 45e459ac076e5bb800a3b8f62828fb326a43d69522caf493166694e4a11b65136756dde43f01e13ac4c74a0535595914364096042dad40c631f17837ca1aca0b
DIST mypy-0.4.3.tar.gz 714118 SHA256 d90aaf3e8c01ccdfdb5b74e9321a3f3a32dea964ce13472f406cec43c174229d SHA512 2185eccb6fa783168879acfc316da0c879fca0b04e6a21bbd47a456014281d634711d9f3e25fa3a64a0b7819b54f0bb87f8bede7452147fd3bab8bca4859f5f0 WHIRLPOOL 4b1db030e1c8aed69e763141a812626129451f04ec32ed4cd4bff15461d826b9479a85a92dcc846baa16dda3056840e6c7f798e9b27317d5158e4ccc769c34c9
+DIST mypy-0.4.4.tar.gz 757353 SHA256 665c9eecc1d43380534d2b88bfc6df2fc7c387f23772e5d82cb37ae96c580034 SHA512 7a5cb8dae4d28cb7803b56ce17e379dd5f1f953663af6a5c2510e3183028f06a8b3722b94843a782e01e4a65b3f5ae48ff002ad85bfb85cad05abb181fc60e47 WHIRLPOOL 71e0b90d521e09c8df21db3bd8a37d3f738ab91823a82481397f81a30cd0f04031a73b71acefefc77405570c8080bf7ccc19669db565313b676c2384018c0863
diff --git a/dev-python/mypy/mypy-0.4.4.ebuild b/dev-python/mypy/mypy-0.4.4.ebuild
new file mode 100644
index 000000000000..bdebb35d44ba
--- /dev/null
+++ b/dev-python/mypy/mypy-0.4.4.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+PYTHON_COMPAT=( python3_3 python3_4 python3_5 )
+
+inherit distutils-r1 vcs-snapshot
+
+DESCRIPTION="Optional static typing for Python"
+HOMEPAGE="http://www.mypy-lang.org/"
+SRC_URI="https://github.com/JukkaL/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="doc test"
+
+DEPEND="
+ test? ( dev-python/flake8[${PYTHON_USEDEP}] )
+ doc? (
+ dev-python/sphinx[${PYTHON_USEDEP}]
+ dev-python/sphinx_rtd_theme[${PYTHON_USEDEP}]
+ )
+"
+RDEPEND="$(python_gen_cond_dep '!dev-python/typing[${PYTHON_USEDEP}]' 'python3_3' 'python3_4')"
+
+python_compile_all() {
+ use doc && emake -C docs html
+}
+
+python_test() {
+ local PYTHONPATH="$(pwd)"
+
+ "${PYTHON}" runtests.py || die "tests failed under ${EPYTHON}"
+}
+
+python_install_all() {
+ use doc && local HTML_DOCS=( docs/build/html/. )
+
+ distutils-r1_python_install_all
+}