summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatt Turner <mattst88@gentoo.org>2021-01-07 22:16:20 -0500
committerMatt Turner <mattst88@gentoo.org>2021-01-07 22:21:30 -0500
commit24333cf8b38421e94c153792a4f05cc773c662bb (patch)
tree613bd8c9e611266175947188d7c5dcdfa84a1bf1
parentdev-libs/tree-sitter: version bump to 0.18.0 (diff)
downloadgentoo-24333cf8b38421e94c153792a4f05cc773c662bb.tar.gz
gentoo-24333cf8b38421e94c153792a4f05cc773c662bb.tar.bz2
gentoo-24333cf8b38421e94c153792a4f05cc773c662bb.zip
dev-util/wayland-scanner: Version bump to 1.18.92
Signed-off-by: Matt Turner <mattst88@gentoo.org>
-rw-r--r--dev-util/wayland-scanner/Manifest1
-rw-r--r--dev-util/wayland-scanner/wayland-scanner-1.18.92.ebuild49
2 files changed, 50 insertions, 0 deletions
diff --git a/dev-util/wayland-scanner/Manifest b/dev-util/wayland-scanner/Manifest
index 8abe868d035a..36f469572777 100644
--- a/dev-util/wayland-scanner/Manifest
+++ b/dev-util/wayland-scanner/Manifest
@@ -1 +1,2 @@
DIST wayland-1.18.91.tar.xz 453500 BLAKE2B 6e234fa637bf4329fcf37c7372e3d02a50742812e2f61477ce302da4c2a1b9377874b0e4e2da899c726ede417081c4d459e40863169352825dd38a8fe0dcf267 SHA512 5ab770c87507e8248aa5197a253f27f3cca984bf1a69c52b438e9aaf512e6b0d841321f81c20643a49ef62eeb6c8b3a6391eadfee5c8822c3cf0d63bb0a8e0f8
+DIST wayland-1.18.92.tar.xz 456320 BLAKE2B bd88156773b5ca817544e0aa496101dc144723dc7f4602011ce1bc4fedbbb20081d99fc882866c0f572139cf4bf4dcf1e7b181af48653b2c67622af07c7ab650 SHA512 837afe1accc632c445868a85792e708daa5d7dc5942888c2fa0981cfb0dd34a3d37667407f1875f04aa5710a07089f3b620a6b78dd19030b477d8b25941e6305
diff --git a/dev-util/wayland-scanner/wayland-scanner-1.18.92.ebuild b/dev-util/wayland-scanner/wayland-scanner-1.18.92.ebuild
new file mode 100644
index 000000000000..eeb424d9d3c1
--- /dev/null
+++ b/dev-util/wayland-scanner/wayland-scanner-1.18.92.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+if [[ ${PV} = *9999* ]]; then
+ EGIT_REPO_URI="https://gitlab.freedesktop.org/wayland/wayland.git"
+ inherit git-r3
+else
+ SRC_URI="https://wayland.freedesktop.org/releases/wayland-${PV}.tar.xz"
+ KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+ S="${WORKDIR}/wayland-${PV}"
+fi
+inherit meson multilib-minimal
+
+DESCRIPTION="wayland-scanner tool"
+HOMEPAGE="https://wayland.freedesktop.org/ https://gitlab.freedesktop.org/wayland/wayland"
+
+LICENSE="MIT"
+SLOT="0"
+
+BDEPEND="virtual/pkgconfig"
+RDEPEND="
+ !<dev-libs/wayland-${PV}
+ >=dev-libs/expat-2.1.0-r3:=[$MULTILIB_USEDEP]
+"
+DEPEND="${RDEPEND}"
+
+multilib_src_configure() {
+ local emesonargs=(
+ -Ddocumentation=false
+ -Ddtd_validation=false
+ -Dlibraries=false
+ -Dscanner=true
+ )
+ meson_src_configure
+}
+
+multilib_src_compile() {
+ meson_src_compile
+}
+
+multilib_src_test() {
+ meson_src_test
+}
+
+multilib_src_install() {
+ meson_src_install
+}