summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArfrever Frehtes Taifersar Arahesis <Arfrever@Apache.Org>2016-10-13 09:01:46 +0200
committerMike Gilbert <floppym@gentoo.org>2016-10-13 12:08:17 -0400
commit24478e643e816b56c6f79f3c74d606a167c08f25 (patch)
treeceda34465ca9f3f57a7250960ad40ebc7953080e
parentapp-i18n/fcitx-qt5: Version bump (1.0.6). (diff)
downloadgentoo-24478e643e816b56c6f79f3c74d606a167c08f25.tar.gz
gentoo-24478e643e816b56c6f79f3c74d606a167c08f25.tar.bz2
gentoo-24478e643e816b56c6f79f3c74d606a167c08f25.zip
app-i18n/fcitx-unikey: Use EAPI="6". Fix LICENSE, dependencies. Call gnome2_icon_savelist().
-rw-r--r--app-i18n/fcitx-unikey/fcitx-unikey-0.2.5.ebuild39
1 files changed, 30 insertions, 9 deletions
diff --git a/app-i18n/fcitx-unikey/fcitx-unikey-0.2.5.ebuild b/app-i18n/fcitx-unikey/fcitx-unikey-0.2.5.ebuild
index d02e5363cac0..5a087b5d2a52 100644
--- a/app-i18n/fcitx-unikey/fcitx-unikey-0.2.5.ebuild
+++ b/app-i18n/fcitx-unikey/fcitx-unikey-0.2.5.ebuild
@@ -1,30 +1,51 @@
-# Copyright 1999-2015 Gentoo Foundation
+# Copyright 1999-2016 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$
-EAPI=5
+EAPI="6"
+
inherit cmake-utils gnome2-utils
-DESCRIPTION="Vietnamese Unikey module for Fcitx"
-HOMEPAGE="http://fcitx-im.org/"
-SRC_URI="http://download.fcitx-im.org/${PN}/${P}.tar.xz"
+if [[ "${PV}" == "9999" ]]; then
+ inherit git-r3
+
+ EGIT_REPO_URI="https://github.com/fcitx/fcitx-unikey"
+fi
-LICENSE="GPL-3"
+DESCRIPTION="Vietnamese Unikey input methods for Fcitx"
+HOMEPAGE="https://fcitx-im.org/ https://github.com/fcitx/fcitx-unikey"
+if [[ "${PV}" == "9999" ]]; then
+ SRC_URI=""
+else
+ SRC_URI="https://download.fcitx-im.org/${PN}/${P}.tar.xz"
+fi
+
+LICENSE="GPL-2+ GPL-3+"
SLOT="0"
KEYWORDS="~amd64 ~ppc ~ppc64 ~x86"
IUSE="+qt4"
-RDEPEND=">=app-i18n/fcitx-4.2.8[qt4?]"
+RDEPEND=">=app-i18n/fcitx-4.2.8[qt4?]
+ virtual/libiconv
+ virtual/libintl"
DEPEND="${RDEPEND}
- sys-devel/gettext"
+ sys-devel/gettext
+ virtual/pkgconfig"
+
+DOCS=()
src_configure() {
local mycmakeargs=(
- $(cmake-utils_use_enable qt4 QT)
+ -DENABLE_QT=$(usex qt4)
)
+
cmake-utils_src_configure
}
+pkg_preinst() {
+ gnome2_icon_savelist
+}
+
pkg_postinst() {
gnome2_icon_cache_update
}