summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLouis Sautier <sautier.louis@gmail.com>2016-03-12 22:04:57 +0100
committerPatrice Clement <monsieurp@gentoo.org>2016-03-12 21:35:27 +0000
commit2490b50c6e89e98fe462e506f9acb040244bf8fb (patch)
treefca7297ef47ab6107f330e6d277335819829c94f
parentapp-emulation/wine: Enable mono on 64 bit builds. Bug #577120 (diff)
downloadgentoo-2490b50c6e89e98fe462e506f9acb040244bf8fb.tar.gz
gentoo-2490b50c6e89e98fe462e506f9acb040244bf8fb.tar.bz2
gentoo-2490b50c6e89e98fe462e506f9acb040244bf8fb.zip
dev-python/nagiosplugin: bump to 1.2.4, EAPI=6
Package-Manager: portage-2.2.27 Closes: https://github.com/gentoo/gentoo/pull/1036
-rw-r--r--dev-python/nagiosplugin/Manifest1
-rw-r--r--dev-python/nagiosplugin/metadata.xml25
-rw-r--r--dev-python/nagiosplugin/nagiosplugin-1.2.4.ebuild28
3 files changed, 42 insertions, 12 deletions
diff --git a/dev-python/nagiosplugin/Manifest b/dev-python/nagiosplugin/Manifest
index b018c5dd24bb..81bbf09ad9f9 100644
--- a/dev-python/nagiosplugin/Manifest
+++ b/dev-python/nagiosplugin/Manifest
@@ -1 +1,2 @@
DIST nagiosplugin-1.2.3.tar.gz 37570 SHA256 9a1729d6479b71b1c7184e88a6214b00133953921df1be2d14ccb35a94a3c8dd SHA512 3f3045db181acc144cb41871f2f67090a7b096d600c9cda7e4f9b86648d47319dca7c42b74670ba307c0bc60955eb33aefcde9c895e544bbb4c7ca1f80e8919d WHIRLPOOL 2482a04ba7280973e9c4f8faedc4c54ca193bd1ff3d37c608dc4018dc2e39dd719e43edac7393c9102436ff8f5dacbeaa3df32c9523924aa6474ca20cdc83445
+DIST nagiosplugin-1.2.4.tar.gz 38290 SHA256 6b020aca516f3643ad02378866d382f0296bf378fa3874d9b2e1d3cc6135f8bb SHA512 42c7823445c0dc1f5fedc6b8bed6c5be4e2b5e4c14cfa2cfbd158ae43485baa0fc74b80f9dcbb89bfdb27b984d72201c8a7c330c71d837c0f822603a5f8f7ae3 WHIRLPOOL 4f62e0f589cde46324b71060ba6e9aa37fcf08d9277fb26f03df3f5b6cfa6b181394cdde6f10dd5c5aa4fae3010c91e0895698724e7147ad30f07e342ef6987b
diff --git a/dev-python/nagiosplugin/metadata.xml b/dev-python/nagiosplugin/metadata.xml
index eea93069637f..ccebbfed0c0e 100644
--- a/dev-python/nagiosplugin/metadata.xml
+++ b/dev-python/nagiosplugin/metadata.xml
@@ -1,16 +1,17 @@
<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
- <maintainer type="person">
- <email>sautier.louis@gmail.com</email>
- <name>Louis Sautier</name>
- </maintainer>
- <maintainer type="project">
- <email>proxy-maint@gentoo.org</email>
- <name>Proxy Maintainers</name>
- </maintainer>
- <upstream>
- <remote-id type="pypi">nagiosplugin</remote-id>
- <remote-id type="bitbucket">flyingcircus/nagiosplugin</remote-id>
- </upstream>
+ <maintainer type="person">
+ <email>sautier.louis@gmail.com</email>
+ <name>Louis Sautier</name>
+ </maintainer>
+ <maintainer type="project">
+ <email>proxy-maint@gentoo.org</email>
+ <name>Proxy Maintainers</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="pypi">nagiosplugin</remote-id>
+ <remote-id type="bitbucket">flyingcircus/nagiosplugin</remote-id>
+ <bugs-to>https://bitbucket.org/flyingcircus/nagiosplugin/issues</bugs-to>
+ </upstream>
</pkgmetadata>
diff --git a/dev-python/nagiosplugin/nagiosplugin-1.2.4.ebuild b/dev-python/nagiosplugin/nagiosplugin-1.2.4.ebuild
new file mode 100644
index 000000000000..0345645b6fcc
--- /dev/null
+++ b/dev-python/nagiosplugin/nagiosplugin-1.2.4.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+PYTHON_COMPAT=( python{2_7,3_3,3_4,3_5} pypy )
+
+inherit distutils-r1
+
+DESCRIPTION="A class library for writing nagios-compatible plugins"
+HOMEPAGE="https://bitbucket.org/flyingcircus/nagiosplugin/ https://pypi.python.org/pypi/nagiosplugin/"
+if [[ ${PV} == "9999" ]] ; then
+ inherit mercurial
+ EHG_REPO_URI="https://bitbucket.org/flyingcircus/nagiosplugin/"
+else
+ SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+ KEYWORDS="~amd64 ~x86"
+fi
+
+LICENSE="ZPL"
+SLOT="0"
+
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
+
+python_test() {
+ esetup.py test
+}