summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorZac Medico <zmedico@gentoo.org>2021-05-31 22:47:48 -0700
committerZac Medico <zmedico@gentoo.org>2021-05-31 22:47:48 -0700
commit259fc4b16932e16760aba01554ca501060e7a632 (patch)
tree9b8cfc05a83e34bec2ce2d1a7da09acf7113324d
parentapp-text/gnome-doc-utils: Fix build (diff)
downloadgentoo-259fc4b16932e16760aba01554ca501060e7a632.tar.gz
gentoo-259fc4b16932e16760aba01554ca501060e7a632.tar.bz2
gentoo-259fc4b16932e16760aba01554ca501060e7a632.zip
app-misc/filebus: Initial import
Package-Manager: Portage-3.0.19, Repoman-3.0.3 Signed-off-by: Zac Medico <zmedico@gentoo.org>
-rw-r--r--app-misc/filebus/Manifest1
-rw-r--r--app-misc/filebus/filebus-0.0.1.ebuild25
-rw-r--r--app-misc/filebus/metadata.xml11
3 files changed, 37 insertions, 0 deletions
diff --git a/app-misc/filebus/Manifest b/app-misc/filebus/Manifest
new file mode 100644
index 000000000000..1aa0e6b6080f
--- /dev/null
+++ b/app-misc/filebus/Manifest
@@ -0,0 +1 @@
+DIST filebus-0.0.1.tar.gz 6472 BLAKE2B 5c6a86e0bd7e879e64cef6b590401b7c5e6c093df65c9154aa20ee4f9f4a47d340730dda5c6139fcd34c7d6e393c94fc18c915de8fecbe6903be30513d396431 SHA512 26221db5e5d1e2f23aed5aa7522af46470ea828618e961333befb95c114eab216efd8c8d5fbebccfffaa316c5518a4c103c79a2379744a43010bd93f66cd7145
diff --git a/app-misc/filebus/filebus-0.0.1.ebuild b/app-misc/filebus/filebus-0.0.1.ebuild
new file mode 100644
index 000000000000..e92d77e87298
--- /dev/null
+++ b/app-misc/filebus/filebus-0.0.1.ebuild
@@ -0,0 +1,25 @@
+# Copyright 2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+PYTHON_COMPAT=( python3_{7,8,9} )
+
+inherit distutils-r1
+
+DESCRIPTION="Multicast communication channels based on regular files"
+HOMEPAGE="https://github.com/zmedico/filebus"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+KEYWORDS="~amd64"
+SLOT="0"
+IUSE="+inotify test"
+RESTRICT="!test? ( test )"
+RDEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
+ dev-python/filelock[${PYTHON_USEDEP}]
+ inotify? ( dev-python/watchdog[${PYTHON_USEDEP}] )"
+BDEPEND="${RDEPEND}"
+
+python_test() {
+ esetup.py test || die "tests failed for ${EPYTHON}"
+}
diff --git a/app-misc/filebus/metadata.xml b/app-misc/filebus/metadata.xml
new file mode 100644
index 000000000000..e83dcf85167b
--- /dev/null
+++ b/app-misc/filebus/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <upstream>
+ <remote-id type="github">zmedico/filebus</remote-id>
+ <remote-id type="pypi">filebus</remote-id>
+ </upstream>
+ <maintainer type="person">
+ <email>zmedico@gentoo.org</email>
+ </maintainer>
+</pkgmetadata>